Compiling qjackctl-0.3.1a.

16 replies [Last post]
Remedial
User offline. Last seen 4 years 40 weeks ago. Offline
Joined: 2006-03-28
Posts:

Okay, so I figured I'd give compiling the latest version of qjackctl a go. I'm on OS X 10.4.10 with Quicktime 7.2.0 installed. I extracted the .tar file to a folder entitled "qjackctl-0.3.1a" in my Applications folder.

So, I then opened Terminal, changed directories to the folder I created and then ran the command ".configure". On the qjackctl page, these are the instructions:

The installation procedure follows the standard for source distributions. In the extracted source directory, just do:

./configure [--prefix=prefix]
make

and optionally as root:

make install

Everytime I tried running that command, I would get back an error message stating that "configure: error: invalid variable name: [--prefix" .

Now, please keep in mind that I'm a total noob to using Terminal, so I figure that I'd just take of the "[--prefix=prefix]" from the first line of the command. So, I did that and Terminal appeared to be compiling the program, but then the final line of the ensuing process stated that I didn't have Qt 4.1 or greater. Here's the exact verbiage:

checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking how to run the C preprocessor... gcc -E
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking how to run the C++ preprocessor... g++ -E
checking for egrep... grep -E
checking whether gcc needs -traditional... no
checking for Qt library version >= 4.1... no; Qt 4.1 or greater is required

After that, I just get a fresh prompt line. So, I figured, maybe everything worked out fine. So, I typed "make", then got this:

make: *** No targets specified and no makefile found. Stop.

Can someone tell me where I'm going wrong? Thanks.

Jonathan Stowe
User offline. Last seen 6 years 35 weeks ago. Offline
Joined: 2007-09-21
Posts:

Hi,
QJackCtl requires the Qt GUI toolkit (totally unrelated to QuickTime) and "configure" cannot find it installed on your system. You can get Qt for Mac OS/X but you really do need to have it installed before you can build qjackctl.

I think there are alternative programs that you can use on the MAc but I'm sure someone else will be able to advise better.

/J\

Remedial
User offline. Last seen 4 years 40 weeks ago. Offline
Joined: 2006-03-28
Posts:

Thanks. I actually got the heads up on the Qt program from a post I made over at macosxhints.com. Funny thing is, I installed version 4.3.1 from the dmg that they had available but qjackctl still won't compile and is giving me the same exact error. Would you know if I have to maybe run the Qt program first (even though it installed properly) before my system registers it as updated? If you have any idea, please let me know. Thanks.

Jonathan Stowe
User offline. Last seen 6 years 35 weeks ago. Offline
Joined: 2007-09-21
Posts:

Hi,
Qt isn't a "program" in itself but a set of libraries and tools for creating GUI applications, most such libraries will have two options for installation: one a minimal one which is sufficient for pre-built programs to use, and a "devel" version that includes all of the header files, linker libraries and tools that are required to build applications using the library. The configure program will check that the latter is present in order that the library can be used, and it would appear that in your case it either isn't present or that configure cannot find it. I'd guess that the .dmg file on the URL I gave above should provide all of that, however I don't have a Mac so I can't advise you further on that.

I'm pretty sure however that someone's going to come along soon and suggest something easier for you to use on the Mac than qjackctl. You might want to check here in the first instance.

/J\

joshpar
User offline. Last seen 1 year 8 weeks ago. Offline
Joined: 2006-03-28
Posts:

I installed qt4-mac from MacPorts. If you have MacPorts installed, do:

sudo port install qt4-mac

and give it your password

then told configure where to look:

./configure --with-qt=/opt/local/

And it built fine.

Hope that helps.

Josh

Remedial
User offline. Last seen 4 years 40 weeks ago. Offline
Joined: 2006-03-28
Posts:

It seems that qt4 installed fine (I checked it by opening the Qt assistant and verifying the version number). I might still try compiling it via Mac Ports. But, one quick question: What's the advantage of using Mac Ports over Terminal?

joshpar
User offline. Last seen 1 year 8 weeks ago. Offline
Joined: 2006-03-28
Posts:

MacPorts is a package manager. You run it from the Terminal. Once installed, MacPorts (formerly DarwinPorts) gives you access to a large number of Linux / OSS resources for you Mac.

If you think it installed, maybe you just need to point ./configure to its location? Where on your system are the qt libs?

towynlin
towynlin's picture
User offline. Last seen 1 year 42 weeks ago. Offline
Joined: 2006-10-15
Posts:

same problem: qjackctl config script can't find Qt

I'm a mac user who's always been fine with JackPilot but wants to give qjackctl a try since everyone recommends it. I'm getting the same configuration error after having installed the Qt disk image from here.

The Qt installer put tools in /Developer/Applications/Qt/ and the headers and libraries in /Library/Frameworks/Qt*.framework/ where the * is 3Support, Assistant, Core, Designer, DesignerComponents, Gui, Network, OpenGL, Script, Sql, Svg, Test, and Xml.

I tried doing ./configure --with-qt=/Library/Frameworks/QtCore.framework/QtCore and other likely variants, but couldn't get the configure script to recognize anything.

I also attempted to install the Qt/X11 (as opposed to Qt/mac) package, since ardour's an X11 app, but there the configure script (of Qt/X11) fails for other reasons. I tried lots of things, including even switching to the macports XFree86, but only got the same errors... (and which prevents Ardour from starting of course)

Guess I'll try macports Qt... good to hear that works for someone... if anyone figures out where to point the qjackctl config script for the Qt/mac installation, please post it.

maltedcoffee
User offline. Last seen 4 years 6 weeks ago. Offline
Joined: 2008-04-20
Posts:

I'm having the exact same issue here with compiling qjackctl under Mac OS. Running ./configure always gets cancelled after this console output:

checking for Qt library version >= 4.1... no; Qt 4.1 or greater is required

I'm pretty sure that Qt libraries are installed correctly. Specifically pointing ./configure to the Qt4 libraries path as mentioned above doesn't solve the problem. I tried different locations here.

I also installed Qt using Macports - same problem here. I tried to find a solution via Google, but without success. Really no hints available on what might cause this error?

Regards,
maltedcoffee

Noctivigant
User offline. Last seen 6 years 13 weeks ago. Offline
Joined: 2007-11-02
Posts:

I'm also having the same problem...

Help! Please! :P

maltedcoffee
User offline. Last seen 4 years 6 weeks ago. Offline
Joined: 2008-04-20
Posts:

I tried to adjust the configure script to make it work under Leopard, but for the time being, without success. Still not giving up...

Just to make this clear: I know that compiling qjackctl is not an issue related to Ardour. Anyway, the coder of qjackctl does not help with Mac support for the software simply because he doesn't know anything about Mac-related problems. That we have one older version of qjackctl available for Mac OS seems to be the effort of some genius coders who figured out how to make the configure script work on a Mac. This is why I'm asking my question in these forums, hoping to find some people who can give us a hint.

Cheers
maltedcoffee

scacinto
scacinto's picture
User offline. Last seen 5 years 25 weeks ago. Offline
Joined: 2007-03-07
Posts:

I was able to compile this with success by setting the --with-qt variable at go-time on an Intel mac with Tiger. However, when I upgraded to Leopard, it broke. (Surprise surprise) Trying to build it again under Leopard fails even with the --with-qt fails.

Has anyone been able to build this on a Leopard machine, or just Tiger? Perhaps Leopard is the problem...

-S

scacinto
scacinto's picture
User offline. Last seen 5 years 25 weeks ago. Offline
Joined: 2007-03-07
Posts:

Revision: I was able to build on Leopard using a previous installation of QT 4.3. I must have installed the mac package from their site. I used the following command (all one line):

./configure --with-qt=/usr/local/Trolltech/Qt-4.3.0/

Obviously, you need to have QT installed here, but this affirms that only the qt-mac package from macports doesn't work for me.

-S

Dewdman42
User offline. Last seen 6 years 9 weeks ago. Offline
Joined: 2008-05-22
Posts:

Hmm. Problems building here on Leopard also.

I just installed latest QT4.4 from their site. After installing it , when I run configure, I'm told that QT is not installed. Obviously, the configure script is broken.

checking for Qt library version >= 4.1... no;
Qt 4.1 or greater is required

I have also tried with the -with-qt option as mentioned above, though the actual path for QT4.4 seems to be a bit different

/usr/local/Qt4.4/

But the error result is the same.

I will try to see if using Qt4.3(if I can find it) will solve the issue.

rhomme
User offline. Last seen 3 years 18 weeks ago. Offline
Joined: 2006-03-27
Posts:

Just checking to see if anyone has built qjackctl for Leopard successfully with Qt4.4, and if so, how?

scacinto
scacinto's picture
User offline. Last seen 5 years 25 weeks ago. Offline
Joined: 2007-03-07
Posts:

I just built qjackctl on a Macbook Pro (specs below) with OS 10.5.6.

1) downloaded latest qjack source (0.3.4)

2) downloaded latest qt4 (4.4.3) source (MUST be source, not dmg)
ftp://ftp.trolltech.no/qt/source/qt-mac-opensource-src-4.4.3.tar.gz

3) compiled qt4, which dropped Qt4.4.3 in /usr/local/Trolltech/Qt4.4.3

(From qt directory run one after the other)
./configure
make
sudo make install

4) compiled qjackctl from the directory: ./configure --with-qt=/usr/local/Trolltech/Qt-4.4.3/
then
make
(NOTE: you must have jack installed in the standard /usr/local/... directory or supply an alternate path for this as well)

There will now be a qjackctl.app in the qjackctl directory. Drag the app to your applications folder (or wherever you want) and configure it.

Start the application and select 'Setup...'

1) change default 'jackd' directory (was incorrect when I did the initial setup in qjackctl) Chang from 'jackd' to '/usr/local/bin/jackd'.
2) I used 'coreaudio' as my 'interface' and 'audio' set to 'duplex' (assuming you have an aggregate device created which has audio in and audio out, this should be what you select)
3) i'm not sure if SampleRate needs to match your coreaudio settings, or whether jack changes those at runtime, but i set both to 96k before running jack.

I Hope this helps.

Scott

--
YalMusT Labs
Department of Music
Yale University
New Haven, CT

scacinto
scacinto's picture
User offline. Last seen 5 years 25 weeks ago. Offline
Joined: 2007-03-07
Posts:

I just built qjackctl on a Macbook Pro (specs below) with OS 10.5.6.

1) downloaded latest qjack source (0.3.4)

2) downloaded latest qt4 (4.4.3) source (MUST be source, not dmg)
ftp://ftp.trolltech.no/qt/source/qt-mac-opensource-src-4.4.3.tar.gz

3) compiled qt4, which dropped Qt4.4.3 in /usr/local/Trolltech/Qt4.4.3

(From qt directory run one after the other)
./configure
make
sudo make install

4) compiled qjackctl from the directory: ./configure --with-qt=/usr/local/Trolltech/Qt-4.4.3/
then
make
(NOTE: you must have jack installed in the standard /usr/local/... directory or supply an alternate path for this as well)

There will now be a qjackctl.app in the qjackctl directory. Drag the app to your applications folder (or wherever you want) and configure it.

Start the application and select 'Setup...'

1) change default 'jackd' directory (was incorrect when I did the initial setup in qjackctl) Chang from 'jackd' to '/usr/local/bin/jackd'.
2) I used 'coreaudio' as my 'interface' and 'audio' set to 'duplex' (assuming you have an aggregate device created which has audio in and audio out, this should be what you select)
3) i'm not sure if SampleRate needs to match your coreaudio settings, or whether jack changes those at runtime, but i set both to 96k before running jack.

I Hope this helps.

Scott

--
YalMusT Labs
Department of Music
Yale University
New Haven, CT