5.6 won't open some session files from 4.6

2 replies [Last post]
bdp
bdp's picture
User offline. Last seen 9 hours 56 min ago. Offline
Joined: 2013-08-11
Posts:

Hi, I'm updating a workstation that I've lent to a friend for a long time. He's been working with Ardour 4.6.0. I've updated to 5.6.0 and can't open any of the sessions he's been working on.

I'm using a pretty standard install of Debian 8.7, on a pentium i5 system.

As expected Ardour noticed the old session file format, backed up the file to -3001.ardour and tried to alter/update/open the session. At this point Ardour shows the splash screen (strangely mostly greyed out, but I can read "please wait while Ardour loads your session at the bottom) then gets to show an empty edit window, with transport and menus etc... nothing will respond to mouse clicks. This must be force closed.

I did try on my Ardour 5.5 installation on my laptop, this also hung opening this file, I've no idea what is different, but for one of my attempts at opening I'd accidentally killed jack part way through and I saw an Ardour error message: "Programming Error, no temo section in tempo map", I tried opening on A5.6.0 with plugins disabled and using Alsa without Jack and also saw the Programming Error message on the workstation machine.

I have very little else installed on this machine, but could possibly install some debug tools if that would allow someone to help me troubleshoot this.

Ardour 5.6.0 will happily create and open new sessions. It's just this EP's worth of 4.6.0 format session files that have been worked on over several months that I would like to carry on working with a recent release.

Any ideas?

paul
paul's picture
User offline. Last seen 12 hours 39 min ago. Offline
Joined: 2006-03-16
Posts:

Please file a bug report at tracker.ardour.org and attach the session file (*.ardour, inside the session folder). We don't need the actual data from the session.

bdp
bdp's picture
User offline. Last seen 9 hours 56 min ago. Offline
Joined: 2013-08-11
Posts:

OK done that now, thanks Paul.