Calf PlugIn UIs laggy

2 replies [Last post]
tptptp
User offline. Last seen 1 day 12 hours ago. Offline
Joined: 2014-01-30
Posts:

Been a while since I've had to do some mixing and I notice the Calf plugin UIs are now lagging. Specifically, the yellow/green sections of the compressor and 8 band Eq (maybe others too, but these are my 'go to' plugins).

Running Ardour 5.8 and Ubuntu studio 16.10 but can't be certain when this behaviour started. In the past, the comp would show how it attenuates the incoming audio, now nothing. In the case of the eq, there's no immediate response to turning on a band or the analyzer. Wait long enough and the eventually the graph starts and a hot spot appears that can be dragged.

Is anyone else experiencing this behaviour?

klaumi
User offline. Last seen 3 days 5 hours ago. Offline
Joined: 2006-10-13
Posts:

It's a little bit more than laggy here with Ardour 5.8 on Debian-stretch(testing):

I just downloaded version 5.8 and opened a test-session created with ardour-5.5. There is a calf-reverb inserted pre-fader in a track, which I cannot access anymore. It is not shown in the mixer strip anymore and I cannot recall the gui, but it is inserted and works, as I can hear! I can also manipulate the automation of the reverb in the tracks automation bar. When I try to delete all inserts from the track (I can not select the reverb itself, but it's the only insert) nothing happens.

When I reopen the session with ardour-5.5 (from the debian-package) all works as expected: The plugin appears in the mixer-strip and its gui as well after a double-click.

Version of calf-plugins is 0.0.60 from the debian-package 0.0.60-4+b1.

GMaq
GMaq's picture
User offline. Last seen 2 hours 50 min ago. Offline
Joined: 2007-12-11
Posts:

Hi,

Ardour 5.8 had a new version of libcairo (which deals with graphics) it was discovered to affect the U-he plugin UI's negatively (Calf wasn't reported but that doesn't mean there were not any issues) so the Ardour devs rolled back to a previous version of libcairo that was used in Ardour 5.5, this change is reflected in the nightly builds after Ardour 5.8 of Ardour 5.8.XX found here: https://nightly.ardour.org/

Maybe you should try a nightly build and see if it fixes it for you.