BWF support

2 replies [Last post]
nottooloud
User offline. Last seen 4 years 36 weeks ago. Offline
Joined: 2009-01-15
Posts:

I'm trying to leave Cubendo behind.
Just threw some coins in the pot and downloaded Ardour 2.8.7.

One of my most common workflows is to remote record a group on a
Mackie MDR recorder. It makes timestamped Broadcast WAV files.
Back in the studio I plug the Mackie's drive into a bay in my Mac,
drop the files onto Cubase, and hit Move To Origin.
A day's worth of 24 track recording files go boink into place.

As I understand it, I should be able to do the same thing in Ardour.
However, Ardour seems to wipe out the BWF timestamp on import.
I can't figure out how to make it work.

paul
paul's picture
User offline. Last seen 2 hours 26 min ago. Offline
Joined: 2006-03-16
Posts:

@nottooloud: assuming that you have "Copy files to session enabled", you should check Options -> Audio File Format -> File Type and make sure it is set to Broadcast WAV. Otherwise, the imported files will just be in "ordinary" WAV, AIFF, CAF etc. Also, when importing, make sure you set the "Insert" point to "use timestamp" (bottom of the import dialog), otherwise it will be ignored when placing the file.

nottooloud
User offline. Last seen 4 years 36 weeks ago. Offline
Joined: 2009-01-15
Posts:

Thanks for the very prompt reply. Unfortunately, I've been there and tried that.

Options|Audio File Format|Sample Format|24-bit integer
Options|Audio File Format|File Type|Broadcast WAVE
this matches the existing file specs

Files manually moved to the project's interchange|projectname|audiofiles folder

Import to Region List|Add existing audio|as new tracks|use file timestamp|one track per file|uncheck Copy files to session

Ardour creates new files in the same folder, named -1, and places them all at 0:00

Opening these new files in BWAVReader 1.1 shows no data for Origination Date or Origination Time, and 0:00 for Timecode Start

I'm on a G5 running 10.5.8