new install on os10.4.8 crash

No replies
kobel
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2006-10-01
Posts:

hi, upgraded os from 3 to 4 and no ardour anymore. was working fine in 3. i have reinstalled ardour using the version for tiger. i have x11 installed. i get this console message:

args are /Applications/Ardour.app
cwd is /Applications/Ardour.app/Contents/Resources
SHELL=/bin/bash
USER=jean
__CF_USER_TEXT_ENCODING=0x1F5:0:0
PATH=/usr/bin:/bin:/usr/sbin:/sbin
APP_BUNDLER=Platypus-3.2
PWD=/
SHLVL=1
HOME=/Users/jean
SECURITYSESSIONID=505b50
_=/usr/bin/env

XFree86 Version 4.4.0 / X Window System
(protocol Version 11, revision 0, vendor release 6600)
_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
[DRI] screen 0 installation complete
Screen 0 added: 1024x768 @ (0,0)
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
bash: no job control in this shell
dyld: incompatible cpu-subtype
Dec 15 18:30:17 jeans-ibook crashdump[411]: ardour crashed
Dec 15 18:30:17 jeans-ibook crashdump[411]: crash report written to: /Users/jean/Library/Logs/CrashReporter/ardour.crash.log
jack main caught signal 3
no message buffer overruns
Quitting XDarwin...

and this crash log:

Host Name: jeans-ibook
Date/Time: 2006-12-15 06:23:16.745 +0000
OS Version: 10.4.8 (Build 8L127)
Report Version: 4

Command: ardour
Path: /Applications/Ardour.app/Contents/Resources/bin/ardour
Parent: Ardour [263]

Version: 0.99.3 (0.99.3)

PID: 264
Thread: Unknown

Link (dyld) error:

incompatible cpu-subtype
**********

Host Name: jeans-ibook
Date/Time: 2006-12-15 18:28:23.079 +0000
OS Version: 10.4.8 (Build 8L127)
Report Version: 4

Command: ardour
Path: /Applications/Ardour.app/Contents/Resources/bin/ardour
Parent: Ardour [339]

Version: 0.99.3 (0.99.3)

PID: 340
Thread: Unknown

Link (dyld) error:

incompatible cpu-subtype
**********

Host Name: jeans-ibook
Date/Time: 2006-12-15 18:30:17.205 +0000
OS Version: 10.4.8 (Build 8L127)
Report Version: 4

Command: ardour
Path: /Applications/Ardour.app/Contents/Resources/bin/ardour
Parent: Ardour [378]

Version: 0.99.3 (0.99.3)

PID: 379
Thread: Unknown

Link (dyld) error:

incompatible cpu-subtype

-------------------------

any ideas appreciated thanks

kobel
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2006-10-01
Posts:

Ah, posted too soon, sorry
scratch this thread

for anyone who experiences similar problem in future, i tried to install the ardour for 10.4 on a g3 mac, this g3 still uses the older version of ardour for 10.3 fine [ardour-0.99.3-panther], and cannot run the version for g4 (ardour-0.99.3-universal)

hence the incompatible-cpu log

sometimes dont see wood for log on head in way

MusicMan3569
User offline. Last seen 30 weeks 6 days ago. Offline
Joined: 2006-12-13
Posts:

If you haven't already tried this, here is one possibility that fixed a similar problem I had with JackOsX after upgrading. It's from an article at: http://www.macworld.com/2006/02/secrets/marchmac911/index.php

"after installing an OS upgrade—say from OS X 10.4.1 to OS X 10.4.2—you should immediately dash to Apple’s Disk Utility (/Applications/Utilities), select your startup drive from the list of drives at the left of the Disk Utility window, and click on Repair Permissions to put any errant file permissions back in line. I’ve found doing so to be an absolute necessity for this particular update."

This can actually fix a lot of weird error messages that creep up after upgrading. Hope it helps!

MusicMan3569
User offline. Last seen 30 weeks 6 days ago. Offline
Joined: 2006-12-13
Posts:

oops, didn't thoroughly read your 2nd message. Still a good idea, though.