Volcas don't start at step 1

11 replies [Last post]
dbra
User offline. Last seen 1 hour 28 min ago. Offline
Joined: 2012-12-27
Posts:

Hi!

I recentyl bought a Volca Beats and a Volca Keys. I synced both via MIDI-Clock with Ardour. The tempo-sync works fine. What doesn't work: Both machines start to play at the step at which they are stopped the last time. Not at step 1 as they should (at least when playing the song from the beginning)

I already asked about this on another forum. Those people (who are using different DAWs) told me, their Volcas always start at step 1. So this must be an issue with Ardour...

I'm using the Ardour 3.3-binary-bundle from this site on Fedora 17 with Planet CCRMA repos.

Any help?

Thanks in advance.

dbra
User offline. Last seen 1 hour 28 min ago. Offline
Joined: 2012-12-27
Posts:

Just to clarify: The Volcas start to play at the wrong location when I hit the play-button in Ardour...

nedzad
User offline. Last seen 2 weeks 1 day ago. Offline
Joined: 2011-09-06
Posts:

i would check midi preferences in ardour and also both units you use to generate sounds.
It looks like ardour does not know where are your modules in time.
So somehow Volcas are not slaves.
I jus saw midi in on them and sync ins!
Korg says you can use it as analogue sound module
look in this video (clearing midi notes so that "they come from ableton")
1min 35 sec in video "reseting midi notes per hand"http://www.youtube.com/watch?v=jSh-L-8bqgw
:)

dbra
User offline. Last seen 1 hour 28 min ago. Offline
Joined: 2012-12-27
Posts:

For jamming I prefer to use the built-in sequencer of the Volcas and use Ardour just for recording and FX.

I already checked the prefs for MIDI-clock and MTC. All Ardour misc-stuff is connected to the appropriate MIDI-interface ports. One Volca is connected via MIDI to receive the MIDI-clock, the other one ist connected through the sync-cable (this one, the Beats, have to be started manually because of no MIDI-connection). They are in sync, but the Keys is at the wrong step.

On the Volca Beats I can simply work around this problem by going into step-jump-mode and manually select step 1. But the Keys doesn't have such a mode...

cajmere
User offline. Last seen 23 hours 21 min ago. Offline
Joined: 2009-04-30
Posts:

i should think, that ardour is not sending a midi message so your volca starts again at the beginning.
I guess ardour is sending a 'continue' midi message instead of a start message.
Maybe you can monitor what midi messages are sended.

dbra
User offline. Last seen 1 hour 28 min ago. Offline
Joined: 2012-12-27
Posts:

Yes, that's it. Ardour only sends start-messages when the song is played from bar 1-beat 1. To have room in front of the song I always start my songs at bar 17 or 33 and move the start-marker accordingly. Therefore I always get continue-messages.

But how to work around it? One could argue if it is a bug or not to send a continue-message at the start-marker. But I also want to start recording in the middle of a song. And this usually takes place on bar-boundaries (the sequence the Volcas can hold only have a length of 1 bar).

Maybe I could write a mididings-script to replace continue- with start-messages?

dbra
User offline. Last seen 1 hour 28 min ago. Offline
Joined: 2012-12-27
Posts:

@paul (when he's looking inside this thread...): Other people told me, that other DAWs send a start-message, regardless of the song-position. Is this a bug?

paul
paul's picture
User offline. Last seen 19 hours 3 min ago. Offline
Joined: 2006-03-16
Posts:

sounds like a bug to me.

allank
allank's picture
User offline. Last seen 6 weeks 2 days ago. Offline
Joined: 2006-12-07
Posts:

Start should come from beat 1 bar 1... Continue can come from anywhere... do you have SPP configured?? I only ever sync the other way around.. from MPC 2500 to Ardour - my studio is pulled apart for the moment.. (furniture swapout).. so this will take a while before I can check how the MPC sees it..

dbra
User offline. Last seen 1 hour 28 min ago. Offline
Joined: 2012-12-27
Posts:

I read about SPP, but cannot find anything about it in Ardour or the Volcas-"manual". And the Volcas don't have MIDI-out so I cannot use them as clock-master.

It's the first time I use external sequencers, so I don't know exactly which MIDI-messages are used to perform positioning etc. .

Could someone please report it as a bug in mantis? I have problems with my registration...

allank
allank's picture
User offline. Last seen 6 weeks 2 days ago. Offline
Joined: 2006-12-07
Posts:

Just been thinking about this... On hardware sequencers.. there is often a play and a 'play start' button. The Play button sends a continue message, but Play Start sends a start message and jumps back to bar 1 beat 1... I'm happy to log a feature request but would prefer to have this as a switchable feature.. (especially if I change from using my MPC as the clock source and start using Ardour as the clock source)

dbra
User offline. Last seen 1 hour 28 min ago. Offline
Joined: 2012-12-27
Posts:

Yes, I already thought about a switchable option, too. Would be nice if you could file the bug-report.