Please help me with linking qjackctl and Ardour

3 replies [Last post]
solinent
User offline. Last seen 6 years 42 weeks ago. Offline
Joined: 2007-06-22
Posts:

Well, it's just not working. I can get a simple track working in Audacity, straight through OSS.

Also, I'm not very bad technically with computers, just quite new to the music recording stuff. So be nice on me ok?

Ok, here's my problem. I have qjackctl starting jackd and it seems to work fine. I was getting odd input when I was using alsa, and Audacity wouldn't work with alsa (I had to use aoss to get it to work), so I'm using oss with qjackctl in the options.

Here's some screenshots of my configuration:

Free Image Hosting at www.ImageShack.us

Basically, ardour doesn't pick up anything from qjackctl. Pressing "start transport" on qjackctl doesn't do a thing (it says something like "starting transport" but then nothing happens, and the play button is active again).

I got the transport to work before, but I remember it still wasn't working, probably because I was trying to use alsa.

This is really my last resort, if you need any more details, ask.

Thanks!

solinent
User offline. Last seen 6 years 42 weeks ago. Offline
Joined: 2007-06-22
Posts:

This was the command I had to use to finally get it to work, with realtime mode (I realised that it worked when I made it capture only, then searched for that, found people had troubles with getting realtime to work in general in ubuntu, I thought it was my soundcard, so I searched for that, and this is what I found!)

sudo su -c 'echo @audio - rtprio 99 >> /etc/security/limits.conf'

From the forums:
http://ubuntuforums.org/archive/index.php/t-453486.html

Just incase anyone else is using ubuntu and has this problem.

grfpopl
User offline. Last seen 6 years 6 weeks ago. Offline
Joined: 2007-01-25
Posts:

adding the lines:

@audio - nice -10
@audio - memlock 250000

to your /etc/security/limits.conf

also might help keeping things smooth. Depending on how much memory you have, raising the amount of locked memory might be a good idea as well. I have 2GB, and 750000 (750MB) seems to work well for me. Of course this all assumes you are using a realtime preempted kernel.

Getting ALSA instead of OSS might also be a good idea if it isn't too much trouble.

niko123456
User offline. Last seen 5 years 11 weeks ago. Offline
Joined: 2007-01-05
Posts:

forget about oss and try and unlearn everything you've done up until this point.

there are a number of things you need:

a real-time kernel. if you use Ubuntu (and I dont), google for Ubuntu Studio, which apparently provides everything you need to get started. you will also need to modify your security/limits.conf file as you found.

alsa. only use alsa from now on. it is by far the more common and supported standard. i didn't even think jack provided support for oss, so it seems to me as if you're using oss emulation (which is alsa).

--

you can control everything with the qjackctl transport, as long as you have told other programs to sync to jack. in Ardour, this can be achieved in the Options Editor, or in a drop-down box on Ardours main panel (it probably says 'Internal', you want it to say 'JACK')

getting started is difficult, but it will all make sense if you keep at it. my only suggestion at this point is to spend some time on it