Problem with playback after JACK Sync.

2 replies [Last post]
hyweljones
hyweljones's picture
User offline. Last seen 6 years 42 weeks ago. Offline
Joined: 2007-07-02
Posts:

Hi. Really enjoying getting started with Ardour and so far I've got a pretty good understanding of the basics.

My setup is as follows:- Audigy set to capture on Line in (Works fine) for my Akai S3000XL Sampler which is routed to an input on Audacity which is then routed to master out. ZynnAddSubFX is routed in a similar way. Master out is routed to the soundcards PCM out. This set up works fine when I play back midi data unsynchronised in rosegarden. The level meters on the mixers all bounce up and down in time with the music and I can hear the out put through speakers.

My problem arises when I try to sync Ardour and Rosegarden using JACK transport. I use ardour as the master JACK timer but when this happens I lose the sound! I know MIDI data is getting to both the Akai and Zyn as the lights are flashing on them.

Heres where it gets stranger. If I press the record buttons on the Akai and Zyn channels in this situation, the signal is recieved (The bars on the mixer cahnnels go up and down) but not routed to the master and there is no sound through the speakers.

If I unsync them both, it goes back to working no problem.

Can anybody help me on this one?

Many thanks,

Hywel.

nick_m
User offline. Last seen 3 years 41 weeks ago. Offline
Joined: 2006-03-29
Posts:

i think the problem you're having is something to do with the monitoring mode of the session.

ardour switches between input and off-disk monitoring in much the same way as a tape machine does.. when you're in play mode (ie synced to rosegarden and rolling), the default is to monitor off disk until the record button is pressed. override this with the 'auto-input' button.. switch auto input off, and a record-enabled track will switch to input whether you're in play mode or not.
by 'switch to input', i'm referring to the program changing from off-disk playback to the 'monitoring' setting for your session.
in order to hear soft synths, you'll have to use the 'software monitoring' setting in the options->monitoring menu. this processes the input signal as if it had come off disk.
i doubt that the audigy supports hardware monitoring (but i dont know for sure), and 'external monitoring' will simply cut the signal on input, so i think in your situation 'software monitoring' seems the only choice.

hyweljones
hyweljones's picture
User offline. Last seen 6 years 42 weeks ago. Offline
Joined: 2007-07-02
Posts:

Thanks, your advice has sorted the problem. After clicking the "auto input" button to off, I opened up the options menu and under "Misc" I noticed the "Hardware Monitoring" button was checked as well as "Software Monitoring". I unclicked the "Hardware Monitoring" and its working perfectly.

Thank you very Much,

Hywel.