Problems with running Ardour under OSX 10.3.4

1 reply [Last post]
jeremy123
User offline. Last seen 6 years 39 weeks ago. Offline
Joined: 2007-07-16
Posts:

Hi, hi there. Adour doesn't work on my system. I checked the FAQ's but it didn't help. I guess the main problem hides in these lines:

undefined reference to _jack_recompute_total_latencies expected to be defined in /usr/local/lib/libjack.0.dylib

What can I do now?

My System: MAC OSX 10.3.4

processor: 1.33 Ghz PowerPC G4, 768 MB DDR SDRAM

This is the whole content:

JP: Reading preferences
JAR: Reading Preferences fInputChannels: 16 fOutputChannels: 16 fAutoConnect: 1
JAR: Reading Preferences fDefaultInput: 16 fDefaultOutput: 16 fDefaultSystem: 1 fDeviceID: 10
JAR: Blacklisted client Xquartz
JAR: Initialize [inSelf, name] : 3541872 JackPilot
JAR: kAudioHardwarePropertyProcessIsMaster err theSize 0 4
JAR: kAudioHardwarePropertyProcessIsMaster err outData 0 0
JAR: jack server not running?
JP: Selected device: Select an audio interface.
JP: Adding device: Built-in Audio.
JP: got output channels ok, 2 channels
JP: got input channels ok, 2 channels
JP: got samplerates ok
JP: got nominal samplerate ok
JP: got actual buffersize ok 512
JP: buffersizes tests ok
JP: got actual buffersize ok 4096
JP: AudioDeviceSetProperty kAudioDevicePropertyBufferFrameSize 512
JP: set old buffersize ok
JP: Selected device: Built-in Audio.
JP: Adding device: Built-in Audio.
JP: got output channels ok, 2 channels
JP: got input channels ok, 2 channels
JP: got samplerates ok
JP: got nominal samplerate ok
JP: got actual buffersize ok 512
JP: buffersizes tests ok
JP: got actual buffersize ok 4096
JP: AudioDeviceSetProperty kAudioDevicePropertyBufferFrameSize 512
JP: set old buffersize ok
JP: /usr/local/bin/./jackd -R -d coreaudio -r 44100 -p 512 -o 2 -i 2 -I 10
jackd 0.99.49
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with POSIX SHM support.
loading driver ..
JAR: Reading Preferences fInputChannels: 16 fOutputChannels: 16 fAutoConnect: 1
JAR: Reading Preferences fDefaultInput: 16 fDefaultOutput: 16 fDefaultSystem: 1 fDeviceID: 10
JAR: Blacklisted client Xquartz
JAR: Initialize [inSelf, name] : 3173776 jackd
JAR: Rejected client : jackd
args are /Applications/ardour/Ardour.app
cwd is /Applications/ardour/Ardour.app/Contents/Resources
SHELL=/bin/bash
USER=jeremy123
__CF_USER_TEXT_ENCODING=0x1F5:0:3
PATH=/usr/bin:/bin:/usr/sbin:/sbin:/Users/jeremy123
PWD=/
SHLVL=1
HOME=/Users/jeremy123
SECURITYSESSIONID=210950
_=/usr/bin/env

XFree86 Version 4.3.0 / X Window System
(protocol Version 11, revision 0, vendor release 6600)
JAR: Reading Preferences fInputChannels: 16 fOutputChannels: 16 fAutoConnect: 1
JAR: Reading Preferences fDefaultInput: 16 fDefaultOutput: 16 fDefaultSystem: 1 fDeviceID: 10
JAR: Blacklisted client Xquartz
JAR: Initialize [inSelf, name] : 3549136 Xquartz
JAR: Rejected client : Xquartz
[DRI] screen 0 installation complete
Screen 0 added: 1024x768 @ (0,0)
bash: no job control in this shell
dyld: /Applications/ardour/Ardour.app/Contents/Resources/bin/ardour Undefined symbols:
/Applications/ardour/Ardour.app/Contents/Resources/bin/ardour undefined reference to _jack_recompute_total_latencies expected to be defined in /usr/local/lib/libjack.0.dylib

Thanks a lot.

Jeremy123

paul
paul's picture
User offline. Last seen 10 hours 42 min ago. Offline
Joined: 2006-03-16
Posts:

You are using an extremely old version of JACK (0.99) which is missing functionality required by current versions of Ardour. The current version of JACK is 0.103.0, although there may not be a JackOSX package of that yet. However, even 0.101, which does have a JackOSX package available, would be preferable.