Audition audio works but transport monitor/playback does not.

12 replies [Last post]
Metatron_X
User offline. Last seen 4 years 24 weeks ago. Offline
Joined: 2007-07-31
Posts:

I'm new to Ardour and Jack so it's possible I have something mis-configured but for the life of me I can't figure out what. I have an Intel based iMac OSX 10.4.10. I am not able to record or play back tracks. I can, however, audition an audio file from within Ardour after importing it into the "Regions" area. I have aggregated the duplex in and out ports for the default Intel based iMac audio. JACK is selected in the dropdown box. JackPilot is set to use the Aggregated audio device. What am I missing? Are there some settings I haven't found yet? I can't get it to work on my Linux box either. Audacity works fine on the Mac so I know the imac is fine. However, when I select the JACK server as the default device for Audacity I get an error stating "Error while opening sound device. Please check the output device settings and the project sample rate." I did.... the project sample rate and device settings are all at 48,000 Hz & 24 bit. I'm using the QjackCtl and JackPilot interfaces to control Jack.

scacinto
scacinto's picture
User offline. Last seen 5 years 12 weeks ago. Offline
Joined: 2007-03-07
Posts:

There are several places you need to set up your audio routing.

1) Make sure your aggregate device is shown in the JackPilot preferences as the 'audio interface' and that the sample rate is what you want -- once you start jack, you can't change these settings unless you turn Jack off... this is a pain if you have Ardour already up and running, because you have to turn it off as well.

2) When you turn Ardour on and start a new project, you have the option of having the program make audio connections for you or you can do it manually. I usually do it myself in the JackPilot 'Routing' window - right under the play/stop button. You should see Aggregate Device and Ardour in this window. If you click the arrows, the devices will reveal their in and out ports. FOR EACH NEW TRACK, you will have to connect the in/out ports in order to be able to hear them! So, lets say you have 1 stereo track going out 'audio1' and 'audio 2' you will have to physically connect audio 1 (on the left of the routing window) with Aggregate Device 'out 1' on the right side, etc.

ALSO

3) You have to make sure to set the audio routing for each track. Go to the Mixer View and click the bottom of the track you need to route where it says 'output'. You can set this to Master, or whatever you want, but make sure that that bus is actually connected to your aggregate device.

Hope this helps,

Let us know if this works!

-S

Metatron_X
User offline. Last seen 4 years 24 weeks ago. Offline
Joined: 2007-07-31
Posts:

1. When I open Jack Pilot the Agregate Device: in ports do not always appear. I have to open and close JackPilot several times and hope that it eventually appears. When/if it does finally appear I select the "start" button on the Qjackctl interface and then I start Ardour.

Once Ardor is open and I select the routing connections in the jack pilot Routing window:

In Ardour I have the following
MasterBus
rhythm A
rhythm B
rhythm C
lead A
lead B

The Jack Pilot Connections Manager looks like this.

+Aggregate Device
out1
out2
+Ardour
lead A/out 1
master/out 1
master/out 2
auditioner/out 1
auditioner/out 2
rhythm A/out 1
rhythm A/out 2
rhythm B/out 1
rhythm B/out 2
lead C/out 1
lead C/out 2
click/out 1
lead B/out 1
lead B/out 2
lead A/out 2

----------------------

+Aggregate Device
in1
in2
+Ardour
master/in 1
master/in 2
rhythm A/in 1
rhythm A/in 2
rhythm B/in 1
rhythm B/in 2
lead A/in 1
lead C/in 1
lead C/in 2
lead B/in 1
lead B/in 2
lead A/in 2
---------------------

So, auditioner and click/ do not show up in the Aggregate Device:in area.
Everything marked with "/out 1" is connected to Aggregate Device "in1". Anything marked with "/out 2" is connected to Aggregate Device "in2". Everything marked with "/in 1" is connected to Aggregate Device "out 1". Everything marked with "/in 2" is connected to "out 2".

When I first open Ardour I can now audition imported audio samples and play back a track in the transport area... sometimes. However, when I stop the transport there is a warbling artifact and my guitar sounds warbly through the monitors. Jack Pilot shows a 100% CPU load. At this point anything I play back in the transport area is warbled and distorted. I still can not record new tracks even with the track armed to record and the record button selected along with play in the transport controls. I've managed to record one track so far with my guitar and I have not since been able to figure out what I have done wrong or right. I have not changed the Aggregate device settings since I was able to record that one track. I'm accustomed to the protools interface so I do have some knowledge of this stuff but it's just not working for me right now. Any ideas as to what I might be doing wrong?

scacinto
scacinto's picture
User offline. Last seen 5 years 12 weeks ago. Offline
Joined: 2007-03-07
Posts:

First, sorry I've not gotten back to you sooner! (Out of town)

>1. When I open Jack Pilot the Agregate Device: in ports do not always >appear. I have to open and close JackPilot several times and hope that >it eventually appears. When/if it does finally appear I select the >“start” button on the Qjackctl interface and then I start Ardour.

You shouldn't be able to see the routing unless jack is on! (IOW, that you've already pressed the start button!) Do you mean that it doesn't show up in JackPilot's Preferences?

Either you're missing a step in setup, or jack is flaking out on you (which isn't altogether unheard of.)

First, can you confirm that you are opening the jack preferences (JackPilot --> File --> Preferences) and setting your audio card to aggregate device? ALSO - be aware that the sample rate settings for the Agg device can be set BOTH in AudioMidi Setup AND jack, and that if the Sample rates do not match, JackPilot will crash or act strangely. This just means that you should set the settings first in AM Setup, and match them in JackPilot's preferences.

1) Your JackPrefs should look like the following

Driver --> coreaudio
Interface --> Aggregate Device
Sample Rate --> whatever the SR is in audiomidi setup for agg device.
Interface Output Channels --> 2
Interface Input Channels --> 2

2) Your agg device prefs should match the above. make sure your agg device is using built-in mic and built-in output.

Checking that the above is true before your session should eliminate the missing I/O buses, though I've never had that problem.

Can you just confirm the above information?

-S

Metatron_X
User offline. Last seen 4 years 24 weeks ago. Offline
Joined: 2007-07-31
Posts:

WOW, thanks for responding. I went out of town too so I'm a bit late catching up. Anyway, yeah, I do have to click "Start" on JackPilot to see the JackPilot routing table, I forgot to mention that. Regardless, when I open JackPilot, click "Start" then click "Routing" I sometimes don't have any In/Receive ports. My JackPilot Preferences match the settings you gave:

Driver –> coreaudio
Interface –> Aggregate Device
Sample Rate –> My input is 48000hz, 2ch-24bit
Interface Output Channels –> 2
Interface Input Channels –> 2

The part that confuses me is in the Mac Audio Midi Setup control panel. Per your #2 above I don't really understand why I should NOT use "Built-in input" and use "Built-in Microphone" instead but I'll take your word for it.

The Mac Audio Midi Setup "Default Input" is set for "Built-in Microphone" (the only option available), the "Default Output" is set to "Aggregate Device", the "System Output" is set to "Built-in Output" (the only option available).

In the Audio MIDI Setup "Configure Device" table I originally had "Built-in Input" checked. After I unchecked "Built-in Input" in the Audio MIDI Setup "Configure Device" table and select "Built-in Microphone as Default Input and then reboot the os my out/Send ports disappear when I start JackPilot but now I DO have In/Receive Ports...

This time I checked all of the Audio Devices in the "Configure Device" table of the Aggregate Device. So, I have Built-in Output, Built-In Microphone and Built-In Input all checked off and the Mac Audio Midi Setup "Default Input" is set for "Built-in Input" instead of "Built-in Microphone", the "Default Output" is set to "Aggregate Device", the "System Output" is set to "Built-in Output" (the only option available).
then I rebooted the os... This time I still have no out/Send ports in the JackPilot routing table...

Under "Properties For: Built-in Input" Audio Input area I have it set for 48000, 2ch-24bit. Under the "Properties For: Aggregate Device" it tells me that "Audio input is not supported"... This is driving me nuts!

OK, what should these settings be?
under Audio MIDI Setup
Default Input: ?
Default Output: ?
System Output: ?
Configure Device: Built-in Output?, Microphone? &/or Input?

I understand that settings for Aggregate device should all match JackPilot Properties. I prefer to record @ 48000hz, 2ch-24bit and then down-sample when bouncing to audio. My default audio output is always 44000hz, 2ch-16 bit (cd quality).

Also, under the "Sound" control panel in Mac system prefs. Input shows no Aggregate Device but in output it is there and selected for output; should I select "Internal Speakers: Built-In Output" instead or leave the output as "Aggregate Device"?

WHEW!

scacinto
scacinto's picture
User offline. Last seen 5 years 12 weeks ago. Offline
Joined: 2007-03-07
Posts:

Oh man.

I just spent an hour writing a witty and incredibly intensive response and when I went to post it, it disappeared and I can't get it back! (and now it's 2:44am... d*mn)

OK -- without getting into extreme detail (because I just spent a lost hour doing that! Firefox is not the best nor most stable browser... i suppose I've learned my lesson!)

The settings you make in coreaudio don't matter as long as the aggregate device is set up correctly and jack and CA agree and Ardour is only looking at jack! IOW, only devices that have to pass through CA before you want them to go to jack need CA set to jack as default in and out... does that make sense? If jack is talking to your AD and your AD is talking to default in and out via CA, then you're golden.

In your AD (aggregate device) make sure you only have built-in mic and built-in output selected -- too many ins make for bad soup!

A) AG should = (in the configure device section) built-in mic + built-in output.

B) Jack should have CA as "Driver" and your AD as "Interface". your SR only needs to match -- whether you choose to downsample or not (though if you plan to publish at 44100, it will sound better if you record and edit at 44100 -- because of dithering issues and block-conversion error!)

If your input in you AD is set to mic (2 channels) and your output is set to built-in output (2 channels) then your jack prefs should show "Interface Input channels" = 2 and "Interface Output channels" = 2. If this isn't the case, then something is screwy either with your version of jack or your CA settings.

So, without starting X11 or Ardour, just make sure these settings look right in the jack prefs and turn jack on. When you open the routine window, you should have 2 channels under in and 2 under out.

If all settings are correct (in Jack and CA) and they don't match in the routing window, most likely your installation of jackd is krunked somehow.

Can you just confirm the above? As always, more questions are welcome ;)

-S

scacinto
scacinto's picture
User offline. Last seen 5 years 12 weeks ago. Offline
Joined: 2007-03-07
Posts:

P.S. Don't reboot!!! There are an extremely limited number or reasons why you should EVER have to reboot OSX -- none of them involve the audio settings! Most likely all that is happening is that between boots, you're losing your previously defined settings! You shouldn't have to reboot at all during this process!!

Metatron_X
User offline. Last seen 4 years 24 weeks ago. Offline
Joined: 2007-07-31
Posts:

Sorry to hear about your long lost hour long post... that REALLY sucks! I really appreciate your time and effort nonetheless. I've had the same thing happen many times in both MSIE & FF so I started to write all long posts in a text document first and then cut & paste, saves a lot of time and heartache in the end.

Ok,
with your help I'm starting to figure out what my problems are.
First of all, whenever I make a change in the sample rate of the Aggregate Device (AD) in Audio MIDI setup (AMS) it temporarily loses the inputs and resets which screws up the preference settings in JackPilot (JP) too. One of my BIG mistakes is that I was assuming that once the settings were adjusted for JP and/or AMS that it would retain my settings... I found this to be untrue. When an adjustment was made in one place (AMS) I had to confirm that it was matching in the second place (JP) several times. Also, when rebooting the OS some of the settings are again changed in JP and/or AMS so I had to compare, confirm and reconfirm all settings in both places several times after all changes are complete.

I followed your instructions (made sure that: 1)all sample rates matched, 2)all channels are present and 3)settings matched in both JP and AMS AT THE SAME TIME & without any further changes to disrupt the process. I was able to record AND play back but I could ONLY record through the imac Built-in microphone. So my recording was more like a tiny guitar with loud wife and child in the background, not the result I was looking for. I went back into AMS > "Configure Device" and unchecked "Built-In Microphone" and rechecked "Built-In Input", readjusted all of my sample rates and confirmed that all settings matched in JP and AMS. I was then able to record and playback my recording (I was so happy I had to change my diaper). Then, suddenly, when I opened the mixer window I could no longer hear the recording as it played back... I realized, after some messing around, that I had to set both the inputs 1+2 and outputs 1+2 in the tracks mixer window as well. Everything was finally working all at once, for once (...So far, give me some more time to mess things up).

Question: Will un-checking "Built-In Microphone" in the "Configure Device" table (AMS) make the microphone unavailable for other programs? I don't have any programs that use it as of yet but I might use it for Skype down the road.

Also, a few things that confuse me regarding sample rates: I was originally told (in school) that it's better to sample at a higher rate and down-sample for the final bounce but I'm sure knowledge and technology have changed over the past six years. I also could be mis-remembering as the last digital audio class I took was at the Art Institute of Philadelphia six years ago and I haven't done much audio editing since then. It's also possible he (the teacher) was talking more specifically about bit depth and I forgot. With that in mind, I'm wondering if I should record at a higher bit depth (24bit) and down-sample to 16 bit or is it best to record AND bounce at 16 bit?

Another thing regarding sample rates I noticed in AMS: When JackPilot is running and I click start on JP, with audio MIDI setup open, "Jack Router" becomes an option in the "Properties For:" dropdown box in AMS. When I select "Jack Router" the sample rate "format" comes up as "44100Hz, 2ch-32bit"... Doesn't this setting conflict with the other settings if I have AD and JP set to 44100, 2ch-24bit? Why is the "Jack Router" setting showing up as 32bit and how can I change that setting to match the rest?... is it even necessary to change the JackRouter setting to match JP and Ardour? I don't even see a 32bit option in JP OR Qjackctl.

...Do I need to have/use Qjackctl for any reason if I'm using JP?

scacinto
scacinto's picture
User offline. Last seen 5 years 12 weeks ago. Offline
Joined: 2007-03-07
Posts:

Glad to hear you've made some noise! The first error-free run is really fun.

One thing before I address some of your questions: any changes you make to the device you are using (aggregate) should be done with jack closed and off.

And, one general comment that might help you conceptualize the way CA and jack interact.

You should think of your devices, built-in mic, aggregate, etc, as hardware. The limitations in terms of bit depth and sample rate are your hardware limitations. Internally, software can run at 32 bit -- jack and supercollider, etc. default to 32 bit. Your hardware, most likely tops out at 24 bit. This doesn't mean that there's a conflict - only that on the way in and out, some bit-depth dithering will most likely occur, either on the part of your software or your hardware. (Good A to D and D to A converters really do make a difference!)

QUOTE:
Question: Will un-checking “Built-In Microphone” in the “Configure Device” table (AMS) make the microphone unavailable for other programs? I don’t have any programs that use it as of yet but I might use it for Skype down the road.

A: Again, thing of hardware connections -- if you want mic input (from outside the machine) to enter the machine and reach a program, you need

A) the computer (aka CA) looking for that mic
B) the program looking at CA.

ALT 1) Jack looking at mic via the aggregate device and
ALT 2) the program looking at jack.

Diagrams really help: the key is to know A) how the audio is getting into and out of your machine, and
B) how its getting from one place to another while its rattling around in the box.

so...

mic or ---> CA --> ||AG = mic + built-out|| --> Jack
built-in

thus

||Jack = mic + built-out|| <--- prgrm

thus

||prgrm = mic + built-out VIA jack||

QUOTE:
…Do I need to have/use Qjackctl for any reason if I’m using JP?

NOPE!

Somewhere you had also wondered about the settings in CA while jack is running.

If jack is looking at your AD and its settings are cool (aka, they work), then you can set CA to whatever you want AND even run another program simultaneously using CA as your software interface instead of jack.

IOW -- both jack and CA are ways of accessing your hardware. You only need CA to define your AD, then its useless if you're using Jack and your configuration is correct.

QUOTE:
Also, a few things that confuse me regarding sample rates...

You know, I don't know that it matters all that much, in reality. (The SR) The bit-depth is muy importante, the SR... well, lets put it this way, if you plan to release in 44.1 16 bit, then when you record edit and mix at 44.1/116-bit, you know exactly what you're going to get on that CD: exactly what you've been working with. With downsampling, there is a conversion, no matter how sweet and accurate, and so the sound will change...

Hope this helps!

-S

scacinto
scacinto's picture
User offline. Last seen 5 years 12 weeks ago. Offline
Joined: 2007-03-07
Posts:

This is the rest of the above message.... which was lost... somehow

so...

thus

||prgrm = mic + built-out VIA jack||

QUOTE:
…Do I need to have/use Qjackctl for any reason if I’m using JP?

NOPE!

Somewhere you had also wondered about the settings in CA while jack is running.

If jack is looking at your AD and its settings are cool (aka, they work), then you can set CA to whatever you want AND even run another program simultaneously using CA as your software interface instead of jack.

IOW -- both jack and CA are ways of accessing your hardware. You only need CA to define your AD, then its useless if you're using Jack and your configuration is correct.

QUOTE:
Also, a few things that confuse me regarding sample rates...

You know, I don't know that it matters all that much, in reality. (The SR) The bit-depth is muy importante, the SR... well, lets put it this way, if you plan to release in 44.1 16 bit, then when you record edit and mix at 44.1/116-bit, you know exactly what you're going to get on that CD: exactly what you've been working with. With downsampling, there is a conversion, no matter how sweet and accurate, and so the sound will change...

Hope this helps!

-S

Metatron_X
User offline. Last seen 4 years 24 weeks ago. Offline
Joined: 2007-07-31
Posts:

So, with the Built-In Microphone unchecked and not available to the aggregate device as a possible input this means that it can not be used until made available by checking/selecting it?... damn. Is there any way to keep the Built-In Mic available and still use my mixing board, feedback and artifact free, with Ardour? When I had the mic available as the only input it was the only thing that Ardour utilized as input. I had to uncheck it and select Built-In Input in order to use the output coming into the iMac from my mixing board. Is there a setting or combination of settings that I missed somewhere or is this a bug in the way JP and Macs/aggregate devices interact?

scacinto
scacinto's picture
User offline. Last seen 5 years 12 weeks ago. Offline
Joined: 2007-03-07
Posts:

"So, with the Built-In Microphone unchecked and not available to the aggregate device as a possible input this means that it can not be used until made available by checking/selecting it?…"

Used by what? It can't be used by the AD, obviously, and if Jack is looking at the AD, then Jack cannot see it either. This doesn't mean that it ceases to exist. In fact, mine works setting the AD to both inputs (I then have 4 ins and 2 outs for the AD.)

Additionally, the built-in mic will still be available to any program that wants it as long as it is set as the input method of coreaudio and the program is using coreaudio as its driver. (Obviously excluding Ardour because of Jack, AD, etc... as above)

In any event, any serious work simply must be done through an audio interface! You can pick up a Mackie Onyx Satellite for $200 and it doesn't sound bad. I have a MOTU that I use for serious stuff, and the Satellite I use for anything I only need 2 pres for. Then, all this fuss about Aggregate Devices and mic-ins is pointless and things work much better as all programs can simply work through the interface.

-S

Metatron_X
User offline. Last seen 4 years 24 weeks ago. Offline
Joined: 2007-07-31
Posts:

Ok, I get it. The microphone is stil available to Core Audio and any device that uses CO but it's not available to Aggregate Device unless it's made available by checking it off under “Configure Device”. By making the mic unavailable the problem I was having with feedback loops and audio artifacts was eliminated so I'll keep it unchecked for now.

Those MOTU's are awesome! MOTU, Kurtzweil and ProTools are what I learned on in school so I'm somewhat familiar with them. All three provide quality and intuitive functionality. I love the MOTU (828MKII 24/96 Audio Interface) and hope to make that purchase one of these days. Thanks for the tip, in the meantime I'll look into that Mackie Onyx Satellite.

Thanks a lot scacinto, I appreciate all the assistance you've provided. hopefully others will find this thread as useful as I have.