Howto: compiling Ardour2.0 (Linux Debian Etch)

No replies
User offline. Last seen 8 years 8 weeks ago. Offline
Joined: 2007-07-20


I've noticed that some people have trouble locating the problem when compilations checks of Ardour fails, e.g. [i]gthread is missing[/i]. Most are related with missing the developer version of the package. What follows is an install on Linux Debian Etch, which starts with an install of developer libraries.

Install the developer libraries, using the aptitude command:

root@localhost$ aptitude install libglib2.0-dev liblrdf-dev libgnomecanvas2-dev \
libsamplerate-dev libboost-dev liblo-dev

Download the ardour source code, unpack, compile (scons) and install:

root@localhost$ cd /usr/src/
root@localhost$ bzip2 -d ardour-2.0.5.tar.bz2
root@localhost$ tar -xvf ardour-2.0.5.tar
root@localhost$ cd ardour-2.0.5
root@localhost$ scons
root@localhost$ scons install

To uninstall Ardour, do from the installation directy:

root@localhost$ cd /usr/src/ardour-2.0.5
root@localhost$ scons -c install

Best Regards,

Rob de Graaf

User offline. Last seen 2 years 46 weeks ago. Offline
Joined: 2007-08-03

for the dev dependencies, wouldn't an "apt-get build-dep ardour" be enough ?