Slackware 12, problems runing ardour...jack?

22 replies [Last post]
Zarnick
User offline. Last seen 6 years 26 weeks ago. Offline
Joined: 2007-10-07
Posts:

Hello, I've sucessfully installed JACK+Ardour and all it's dependencies, but whenever I try to run ardour, first that for running I need to run it as root(permissions...but no problem here), then, I always get this message when I try to start a test track:


the capture device "hw:0,0" is already in use. Please stop the application using it and run JACK again

Since I'm pretty new with jack, could you guys help me out?
I'm running jack like this:


jackd -R -n peacemaker -v -d alsa

And I run KDE as a Window Manager, maybe KDE is blocking things? I really don't know even how to check this...Sound in Linux is a whole new world for me.

Thanks a lot guys.

thorgal
User offline. Last seen 1 year 21 weeks ago. Offline
Joined: 2007-08-03
Posts:

Hi Zarnick,

I don't use slackware but I am used to KDE. You probably have artsd (the KDE sound daemon) running in the background. Just disable it through the KDE system settings (System settings -> Sound System -> uncheck "enable sound system") and restart jack after that. It should be all you need, unless your issue comes from e.g. a flash application running through an opened webpage, which you should close if this is the case because the flash plugin will busy your sound device without sharing it. So, as a rule of thumb, if disabling Arts does not work, try to spot every audio application that could run in the background (amarok, xmms, whatever) and terminate them.

By the way, once I set up my KDE environment as I wanted, I switched to openbox-KDE. It is more lightweighted and will preserve your KDE setup (panels, icons, menus). To the untrained eye, it will look as if you are running the full KDE. But you really don't need that when running jack stuff, you want to prioritize the audio flow.

Zarnick
User offline. Last seen 6 years 26 weeks ago. Offline
Joined: 2007-10-07
Posts:

Thanks, it solved :D
this is a very good piece of software, all I need is to find some VST plugins, specially an Equalizer.
Thanks a lot thorgal!

thorgal
User offline. Last seen 1 year 21 weeks ago. Offline
Joined: 2007-08-03
Posts:

you're welcome :)
you could try this EQ : http://www.dontcrack.com/freeware/downloads.php/id/4016/software/Classic-EQ
it's freeware ;)

Zarnick
User offline. Last seen 6 years 26 weeks ago. Offline
Joined: 2007-10-07
Posts:

I actually found a lot of LADSPA plugins right here, on the ardour manual, but I'll take a look at this, thanks a lot. :D

BTW: Just one completely out of topic question, I have a guitar+some efects+a Digitech RP2000 and a 15W Peavey, what would be the best way to record the sound from my guitar? Mic the Peavey, (I have only "normal" computer mics, no professional mics) or plugin the output of the RP2000 to the input of my SbLive sound board? It's really of the topic, but if you could give me your personal opinion...I would like to hear it.

Thanks.

thorgal
User offline. Last seen 1 year 21 weeks ago. Offline
Joined: 2007-08-03
Posts:

What I would do in your situation is to avoid mic'ing the amp because of a lack of a "proper" mic (and preamp that goes with it). Your effect rack contains some amp modeling and certainly has some level of preamplification you can use to control the gain of your output before it goes inside your sound-card. There are advantages in outputing your effect box to your soundcard : you can play in silent mode and at the same time simulate the amp of your choice (among choices the digitech offers you). This is to me the best compromise considering what you've got. If you want to capture your amp output through a mic, you would have to upgrade a few things, and that's unfortunately not for free. By the way, I don't know the quality of the SBLive sound card (the ADCs, the builtin preamps, and so on). I have a RME HDSP system (Multiface II) and a RME QuadMic preamp for mics (4 channel preamp module) and I must say, to my ears, the incoming sound is quite nice (no buzzing crap, transparent). But I had to save up money for quite a while to afford this system. My experience with cheaper sound cards is not very good. The ADCs and the preamps sit inside the computer so they pick up quite some crap. You always have to clean up your recordings for this, which is really annoying. But at the end, YMMV :)

Jonathan Stowe
User offline. Last seen 6 years 21 weeks ago. Offline
Joined: 2007-09-21
Posts:

I'd recommend going direct as well, you may have to fiddle with the levels a bit, also from my experience you might find that you get some mains hum if the unit has a cheap external power supply. Alternatively if the amplifier has a headphone output you might try that - though the level might be too high for your card. Unfortunately it appears that the RP2000 doesn't have a USB output which some more recent ones do, which could be another option if it had.

That said experimenting with the microphone might yield some interesting, if not particularly purist, results :-)

/J\

Seb
Seb's picture
User offline. Last seen 2 days 12 hours ago. Offline
Joined: 2006-04-07
Posts:

hum and buzz from the guitar is mostly pretty terrible, in comparison to other signal sources, so what the Soundblaster adds to it is likely irrelevant.

Electric guitars just "don't do" dynamic range. Not compared to other things like a violin or a singer.

A cheap-and-cheerful "comes with the soundcard" microphone in front of the peavey will likely not cope with the sound pressure offered, and distort horribly.

Zarnick
User offline. Last seen 6 years 26 weeks ago. Offline
Joined: 2007-10-07
Posts:

Hello, I've went with direct and made a very simple one take test, which you can find it in here. The point was to actually test a clean guitar with a fabric preset of the Digitech RP2000, both in a note by note, and on chords, if you listen to it correctly, you'll see that when I start doing the chords, the sound starts to crack up, and that's my problem. I never tryed with distortion, since it wass 2 am when I've did this. (alas, please don't look at the errors on the guitar, I was really tired, and it was just a test)
I did tryed some EQ tough, it didn't helpd, the output volume of the Digitech I have to put on max, otherwise the SBLive would pick it up really low volume, do you guys have any tips?

(BTW, you were all correct, mic is a hell hehehe)

Thanks a lot guys.

nowhiskey
User offline. Last seen 4 weeks 3 days ago. Offline
Joined: 2006-09-30
Posts:

if i was listening carefully enough, the sound is crackling even on a single notes, about 9. and 10. sec.?

cheers,
doc

Zarnick
User offline. Last seen 6 years 26 weeks ago. Offline
Joined: 2007-10-07
Posts:

Probably, but it cracks like hell on chords.

yawfle
User offline. Last seen 6 years 13 weeks ago. Offline
Joined: 2006-09-14
Posts:

For realtime permissions on Slackware you can use set_rlimits:

http://apps.linuxaudio.org/apps/all/set_rlimits

Zarnick
User offline. Last seen 6 years 26 weeks ago. Offline
Joined: 2007-10-07
Posts:

Is this a realtime issue?

yawfle
User offline. Last seen 6 years 13 weeks ago. Offline
Joined: 2006-09-14
Posts:

Don't know for sure that it is - is jack reporting any xruns? The slight artifacts I could hear in the sample sounded more like dropped frames than clipping to me, but maybe somebody with a better ear for that kind of thing can give their opinion.

nowhiskey
User offline. Last seen 4 weeks 3 days ago. Offline
Joined: 2006-09-30
Posts:

for me it does not sound like a clipping but more like some drop-out.
i would try to increase the latency, than the craclings should disappear at some point.

cheers,
doc

Zarnick
User offline. Last seen 6 years 26 weeks ago. Offline
Joined: 2007-10-07
Posts:

Hum...and how do I increase the latency? As I sayd before, when it comes to sound, I'm a complete newbye on linux...hehe
(Actually, I used to use Windows just for this...hehe)

nowhiskey
User offline. Last seen 4 weeks 3 days ago. Offline
Joined: 2006-09-30
Posts:

if you are using qjackctl for controlling jackd, it is pretty easy:

go to the setup dialog and try to increase 'frames/period'
or/and 'periods/buffer' variables.

cheers,
doc

Zarnick
User offline. Last seen 6 years 26 weeks ago. Offline
Joined: 2007-10-07
Posts:

No qjackctl...it uses qt4, and I still depend a lot on qt3 :(

Zarnick
User offline. Last seen 6 years 26 weeks ago. Offline
Joined: 2007-10-07
Posts:

No qjackctl...it uses qt4, and I still depend a lot on qt3 :(

yawfle
User offline. Last seen 6 years 13 weeks ago. Offline
Joined: 2006-09-14
Posts:

You can download the qjackctl-0.2.x series here:

http://qjackctl.sourceforge.net/qjackctl-dl1.html

which should build fine with qt3. I'm still using 0.2.22 myself with no problems, and it really makes everything jack-related much easier.

thorgal
User offline. Last seen 1 year 21 weeks ago. Offline
Joined: 2007-08-03
Posts:

Zarnick,

Using jackd like you do 'jackd -R -n peacemaker -v -d alsa' implies default values for the framerate and number of periods, respectively 1024 and 2.

1- try fiddling around with these parameters (-p framerate -n #periods )
2- check your rlimits config. In /etc/security/limits.conf, I have this :


@audio - nice -10
@audio - rtprio 99
@audio - memlock unlimited

This requires a recent PAM lib which slackware most likely has. This also implies that you have a unix group called 'audio' and that you belong to that group. In a shell, type 'id' and check what group you are belonging to.

I don't know how slackware manages its groups and users by default. Debian based distros (which I use) come with this group out of the box, with a GID of 29. If you want to create such a group, then you can use the KDE user and group admin interface (System Settings -> User Management -> enter the administrator mode, add a group with this GID and add yourself in that group). But then, you would have to set up udev rules for the /dev/snd so that they belong to the group audio. E.g. on my system :

ls -l /dev/snd results in

crw-rw---- 1 root audio 116, 5 2007-10-09 09:10 controlC0
crw-rw---- 1 root audio 116, 4 2007-10-09 09:10 hwC0D0
crw-rw---- 1 root audio 116, 3 2007-10-09 09:10 seq
crw-rw---- 1 root audio 116, 2 2007-10-09 09:10 timer

3- kernel : was it compiled with realtime or low latency patches ?

yawfle
User offline. Last seen 6 years 13 weeks ago. Offline
Joined: 2006-09-14
Posts:

Slackware doesn't use PAM, unless it's been added in the last release, which I haven't had a chance to investigate. See my comment about set_rlimits above.

Zarnick
User offline. Last seen 6 years 26 weeks ago. Offline
Joined: 2007-10-07
Posts:

Thanks a lot for all you help on this issue, but I was making some tests, and I think it's actually the pickups(it's a new guitar), since I've used and old guitar, and the problems were almos completly gone :O
I'm going to check this as soon as I get bether from my cold.

Thanks a lot once again guys, you guys rock!