Basic recording with the microphone input

6 replies [Last post]
Andre_gK
User offline. Last seen 6 years 26 weeks ago. Offline
Joined: 2007-10-22
Posts:

Hey there.
I've just installed Ardour and I'm trying to record my guitar which is plugged to the mic in of my pc. I just can't record anything, even after following the steps shown in the appropriate manual section.

The curious thing is that I have no problems when recording with the default Sound Recorder.

What am I doing wrong?

Thanks in advance.

Solv
User offline. Last seen 4 years 41 weeks ago. Offline
Joined: 2006-03-27
Posts:

Okay, can we have a little more info? Can you tell us the steps you have taken to try and get it to work?
I will give you a quick step by step to see if it helps:

1) Start qjackctl, make sure it is definitely running with no errors, if so then great move on to step two.
2) Start Ardour and create a new session, tell it to automatically make connections.
When it is started on the toolbar, just for now make sure you select the option 'Auto Input', and in the Options menu for 'Monitoring', select 'Software Monitoring' to make sure you can hear the guitar if it is actually coming through the sound card (when you have more experience you will know whether or not you can change back to hardware monitoring and to disable auto-input)
3) From the menu 'Session' click Add Track/Bus
4) Press Shift+E to show the channel strip on the left (if it is already there it will hide it, so toggle it to make it visible)
5)Make sure the title of the channel strip says track 1 and not master (click on track 1 of the editor window if it does say master)
6) Down below the fader in the channel strip next to the 'GRP' button it might say 'POST' or 'INPUT', press this until it says input
7) Record Arm Track 1 by pressing the red circle next to the name of the track.
8) Play some guitar and see if the levels go up in the channel strip and you hear guitar through the speakers
9) If so, then press the record button in the transport bar and press play - and you're done!
10) If not just below the name track 1 in the channel strip select the button input and in the drop down list you should see the names of available inputs from your sound card. Make sure it is selected to your mic in (btw if you are recording from your mic from a guitar you will have to play with levels in the mixer app you use for your soundcard to make sure you don't get distortion happening)
11) Note the fader level does not affect recording levels, only playback levels, so don't worry about adjusting that until after you've recorded.

If you still can't make it do something now, then please post in detail what steps you have taken or pop onto irc.

Cheers,
Andy J

acl123
User offline. Last seen 6 years 21 weeks ago. Offline
Joined: 2007-11-03
Posts:

Hi, great post - it's a big help for a newbie. I'm also trying to just get a very basic setup going.
I got up to step 8. The levels are going up in the channel strip, which means my interface is working (awesome!), but I'm not getting any sound coming through the speakers.
If I click the record button, it flashes, but I can't tell if anything is happening.
Do you know what I've missed?

I'm on Ubuntu, using a USB Edirol UA-25.

By the way, another question... editing the audio inputs is confusing for me. There are two tabs under "available connections" are alsa_pcm and ardour. Under alsa_pcm there is "capture_1" and "capture_2". When I click on "input" in the channel strip, the drop down menu contains two option "in1" and "in2".
I'm not sure what I should be looking for here.

Solv
User offline. Last seen 4 years 41 weeks ago. Offline
Joined: 2006-03-27
Posts:

If I click the record button, it flashes, but I can’t tell if anything is happening.
Would you know what I’ve missed?

Did you then press the play button after the Record button? If it is recording the transport will begin rolling and the playhead will move along with a red 'region' written on the track containing a wave form. If you get audio on to disk, then try and play it back to see if your outputs are configured correctly. On playback open you mixer window and make sure the master fader is showing levels...if so and still no sound, edit the output of the master channel and make sure you have selected alsa_pcm 1 and 2, and not something completely weird (although it should have been done for you by ardour anyway). This should give you audio.

By the way, another question… editing the audio inputs is confusing for me. There are two tabs under “available connections” are alsa_pcm and ardour. Under alsa_pcm there is “capture_1” and “capture_2”. When I click on “input” in the channel strip, the drop down menu contains two option “in1” and “in2”.

You need to select alsa_pcm to choose your soundcard inputs...ardour inputs are for routing audio within the program which you probably wouldn't use much. If you have created a stereo track then in1 is for left and in2 is for right. If you have created a mono track but have a stereo source plugged into the soundcard then you can choose either, it won't matter.
Some people might have a setup where two different sources are coming in via one physical stereo jack, and in this case one source would be coming in on the left (in1) and the other on the right (in2).

Hope this makes sense, if your still struggling, hop on irc.

Cheers,
Andy J

acl123
User offline. Last seen 6 years 21 weeks ago. Offline
Joined: 2007-11-03
Posts:

Hi, OK I managed to record and when I playback the faders are showing levels. But still no sound :(
My master's outputs are "alsa_pcm:playback1" and "alsa_pcm:playback2" on "out1" and "out2" respectively.

Thanks a lot for your help.

Solv
User offline. Last seen 4 years 41 weeks ago. Offline
Joined: 2006-03-27
Posts:

Okay last thing to check is to make sure your sound card mixer itself (ie the mixing applet that comes with your distribution) has the volume unmuted and is up for both the master and pcm sliders, also you can open up qjackctl and press connections, and make sure that ardour master out is connected to alsa_pcm:playback, if those are all fine and you can playback audio in other jack aware applications then I really am not sure.

best of luck,
Andy

acl123
User offline. Last seen 6 years 21 weeks ago. Offline
Joined: 2007-11-03
Posts:

Hmm, I just installed xmms-jack and that crashed (both xmms and jack itself). Then I tried Hydrogen and that had the same problem as Ardour - I could see the volume levels going but couldn't hear anything. I'll keep hunting around for a solution.