cant Install x11 & ardour 2.1 on OSx 10.4.10

5 replies [Last post]
clay
User offline. Last seen 6 years 26 weeks ago. Offline
Joined: 2007-10-23
Posts:

I cant Install x11 & Ardour 2.1 on my intel macbook pro (running OSx 10.4.10). The installer says I already have the newest version of x11 but when I try to install Ardour it tells me x11 needs to be installed first.

I looked for x11 in applications & the library with spotlight but the only thing comes up is the older versions that I was unable to install (downloaded from Ardour's site & apple's)

I launched Console and tried to install Ardour and got this:
"button returned:OK"

What am I doing wrong?
Does this program not work on intel macs running osx 10.4.10?

paul
paul's picture
User offline. Last seen 3 hours 32 min ago. Offline
Joined: 2006-03-16
Posts:

it does work. thousands have downloaded it and installed it.

you need to make sure you are not trying to install the "X11 SDK", which as described on the OS X download page for Ardour, is related to X11 but not the same thing. What you want is either on the original install disk or available from Apple. googling for "apple X11 download" took me here:

http://www.apple.com/support/downloads/x11formacosx.html

which notes that: "Note 10.4 customers can install X11 by using the Tiger DVD installer disk."

this comment is also troubling: "I launched Console and tried to install Ardour and got this". i am not clear that you understand what this sentence suggests. you do not install packaged software (e.g. DMG's, zip packages etc) on OS X from the console.

Zoku
Zoku's picture
User offline. Last seen 6 years 23 weeks ago. Offline
Joined: 2007-11-11
Posts:

I also had trouble installing Ardour. I first used the X11 I found on the Apple CD, but in fact it was the SDK version... Then I tried to get the right by following the link you posted, but I'm told that there's already a newer version on my computer. Can I just delete the wrong one and install the good one anyway ? Thanks by advance.

joshpar
User offline. Last seen 46 weeks 6 days ago. Offline
Joined: 2006-03-28
Posts:

The SDK (SoftwareDevelopmentKit) should probably be there also... this includes certain libraries and headers that Ardour may need to use. Just install the X11 app as well, and all should be fine.

ozza27
User offline. Last seen 6 years 23 weeks ago. Offline
Joined: 2007-11-14
Posts:

hey. im having the same problem....

i isstalled x11sdk and then tried to install x11 from the website and it says there is a newer version and i cant install....

What must i do?!?!?!

Zoku
Zoku's picture
User offline. Last seen 6 years 23 weeks ago. Offline
Joined: 2007-11-11
Posts:

Joshpar > Can it all be so simple ?... Not for me. :/

Any tips for deleting the wrong version ?
I looked for it and I only found a strange way to do that, with codes and stuff...