Ardour displays bold font as squares

4 replies [Last post]
corebots
User offline. Last seen 1 day 14 hours ago. Offline
Joined: 2015-04-29
Posts:

hello I've installed Ardour 5.5 on Fedora 25; when I start Ardour some parts of the interface aren't readable and are displayed with empty square characters instead; It looks like it's related to the bold letters only.. see screenshot for what i mean please:

http://i.imgur.com/TCL24KY.png
http://i.imgur.com/mmPCcfg.png

any idea of what this could be?

I use apples san francisco font as my system font, but while using lots of other software i nowhere see this issue besides Ardour. (if i'm correct i didn't have this problem with ardour and the same system font a few months ago)

thanks for your input.

corebots
User offline. Last seen 1 day 14 hours ago. Offline
Joined: 2015-04-29
Posts:

anyone, please?

x42
x42's picture
User offline. Last seen 21 hours 41 min ago. Offline
Joined: 2006-11-05
Posts:

We've seen similar issues in the past with missing libpango modules (depending on font and encoding)
Is this Ardour from Fedora, a self-compiled version or a binary from ardour.org?

corebots
User offline. Last seen 1 day 14 hours ago. Offline
Joined: 2015-04-29
Posts:

it is a binary from ardour.org. thanks for the hint, I've installed pangomm and pangox-compat and the squares are gone and i get proper bold font rendering. (not sure if it wasn't solved by something else I've installed in the meantime, but fact is that it's solved now :) thanks!

paul
paul's picture
User offline. Last seen 11 hours 14 min ago. Offline
Joined: 2006-03-16
Posts:

That fix should not have affected anything. Glad it is working for you now, but ....