Ardour time master with jack hydrogen guitarix

5 replies [Last post]
jupiter126
User offline. Last seen 27 weeks 1 day ago. Offline
Joined: 2017-05-11
Posts:

Hello,
I'm using Ardour rev 5.8-gentoo, which I'm trying to set as Time Master for my session.

There somehow is no button left from the timeframes, but I found the option in Session -> properties -> timecode.
Jack transport and jack master are enabled in Hydrogen

Now when I start Ardour, Hydrogen does not start playing, and vice versa.

When I start playing in tuxguitar however, hydrogen starts playing but ardour does not (and equally, when starting to play in hydrogen, tuxguitar starts playing and ardour does not).

Below the time frames in ardour, I can see that transport is set to INT/JACK. I managed to change it to INT/MTC, INT/M-Clk and INT/LTC: none of them syns with hydrogen.
I could find no way to remove the INT in order to change this to JACK only (as I saw on quite a lot of screenshots), would this be the key?

I have been through all the options that I could find but must have missed something... any help solving this issue is appreciated!

jupiter126
User offline. Last seen 27 weeks 1 day ago. Offline
Joined: 2017-05-11
Posts:

Nevermind - finally found it!
Reference: https://community.ardour.org/node/14420

yves
User offline. Last seen 1 week 3 days ago. Offline
Joined: 2010-04-26
Posts:

Hello ,
Don't know what i missed i can get ardour or mixbus be slave of jack transort
but i cannot get ardour or mixbus to be master of jack
the option Jack Transport / Time Settings in session properties seems to be useless

x42
x42's picture
User offline. Last seen 2 hours 44 min ago. Offline
Joined: 2006-11-05
Posts:

step 0: If you've previously used Ardour without JACK, Preferences > Sync > External Timecode Source "JACK"
step 1: top-left in the main toolbar there is a button to toggle "Int"ernal /External Position Sync. (left of the vari-speed control below the MIDI-Panic button)

optional step2 (with JACK) Session > Properties > Timecode .. "Time Base Master" (first jack client that asks for this wins, and can provide musical time (Bar/Beat) for the current absolute position.

x42
x42's picture
User offline. Last seen 2 hours 44 min ago. Offline
Joined: 2006-11-05
Posts:

PS. "I cannot get ardour or mixbus to be master of jack" -- that is correct and by design. JACK won't ever slave to anything and is always the master.
You can only slave Mixbus or Ardour or any other jack-client to jack's transport (not the other way 'round)

yves
User offline. Last seen 1 week 3 days ago. Offline
Joined: 2010-04-26
Posts:

"by design. JACK won't ever slave to anything and is always the master."
I understand but i thought the transport could be sync
what is the use of the option Session > Properties > Timecode > Jack Transport / Time Settings ?

in my memory i had once the sound on a computer and the picture on an other one linked by ethernet
and the picture with xjadeo was following Ardour
recently i tried to have two pictures in sync with Ardour on 2 pc with Ubuntustudio
i followed the settings from " WalkThrough_User_NetJack2 " but was unable to sync the transport between the 2 pcs
the parameter -t, --transport_sync is not recognised on the slave
finally i used miditimecode but it doesn't go backward