(k)ubuntu fftw3f packagae on 2.2

9 replies [Last post]
muzicman0
muzicman0's picture
User offline. Last seen 37 weeks 5 days ago. Offline
Joined: 2007-05-16
Posts:

This is a quote from the building ardour page:

"It is also strongly recommended that you have the FFTW library installed, particularly
the single-precision variant ("fftw3f"). Ardour will compile without this, but it will be
unable to use the RubberBand library for timestretching and pitchshifting."

has anyone succesfully found this package or compiled for kubuntu? I have tried, and haven't been able to get it to find the package...

mm0

jop
User offline. Last seen 3 years 48 weeks ago. Offline
Joined: 2008-01-14
Posts:

Here are the links:

http://packages.ubuntu.com/cgi-bin/search_packages.pl?keywords=fftw3&searchon=names&subword=1&version=gutsy&release=all

Download the amd version of course (ubuntu gutsy)

bye

muzicman0
muzicman0's picture
User offline. Last seen 37 weeks 5 days ago. Offline
Joined: 2007-05-16
Posts:

I'll give that a shot, but if I recall correctly, I installed that package already (the -dev version) from adept, and I still get the same msg when compiling...
mm0

jop
User offline. Last seen 3 years 48 weeks ago. Offline
Joined: 2008-01-14
Posts:

If it doesn't, that's because ardour uses pkgconfig to verify the presence of the library and setup cflags and libs variables.

If it does not work, create a file in
/usr/lib/pkgconfig/fftw3f.pc with the following content:

prefix=/usr
exec_prefix=/usr
libdir=/usr/lib
includedir=/usr/include

Name: FFTW
Description: fast Fourier transform library
Version: 3.0.1
Libs: -L${libdir} -lfftw3 -lm
Cflags: -I${includedir}

Then try again the scons command.

toersi
User offline. Last seen 1 year 15 weeks ago. Offline
Joined: 2007-03-04
Posts:

I have the same problem with Ubuntu gusty. The file you mentioned already exists. It only differs in the version feld. On gusty its version is 3.1.2. But scons tell me it can't find fftw3f or fftw3.

jop
User offline. Last seen 3 years 48 weeks ago. Offline
Joined: 2008-01-14
Posts:

Can you send the output of

pkg-config --cflags --libs fftw3
and
pkg-config --cflags --libs fftw3f

?

da_seeb
User offline. Last seen 4 years 9 weeks ago. Offline
Joined: 2007-10-06
Posts:

I had the same problem...
It is related to scons. If you run scons before you install FFTW3-dev it remembers building without it and doesn't look for new libraries on every new run.

there must be some switch to clear these cached options, but I didn't find out how to do this. My workaround was to enable FFTW support doing "scons FFTW=1.
(Don't remember if FFTW is the right option... was something like this)

Frizbee
Frizbee's picture
User offline. Last seen 29 weeks 3 days ago. Offline
Joined: 2007-02-13
Posts:

Good hint da seeb!

It seemed that i solved this issue with completely remove scons via Synaptic/apt-get and then install scons again!

funky regards

Rogue Frizbee|Rogue Squadron|UZN

toersi
User offline. Last seen 1 year 15 weeks ago. Offline
Joined: 2007-03-04
Posts:

Thanks! That also worked for me. But you don't have to remove scons from your hard disc. All you have to do is delete the ".sconsign.dblite" - file in ardour svn directory.

muzicman0
muzicman0's picture
User offline. Last seen 37 weeks 5 days ago. Offline
Joined: 2007-05-16
Posts:

I finally am getting around to rebuilding ardour, and removing .sconsign.dblite also worked for me...Thanks!!

mm0