I cant use a USB Mic.

4 replies [Last post]
Gadem
User offline. Last seen 4 weeks 2 days ago. Offline
Joined: 2006-03-30
Posts:

Hi Everybody, first, my mother language is Spanish, so i'm sorry for my English.
Well, i buy a USB Mic, but i cant work whit duplex audio if i select the USB Mic in the start window.

When i select the USB Mic, the Out option fill None, and if i select the Out the In option fill like this:

Thanks for your time.

mhartzel
User offline. Last seen 3 hours 42 min ago. Offline
Joined: 2013-10-15
Posts:

USB mics can be difficult to use with DAWs like Ardour. The DAW needs the audio device it uses to have both inputs and outputs and for the device to work in full duplex mode. If you try to use a different audio device for input and ouput it leads to problems, since the sample rates of the devices are not synced together.

For trouble free operation buy a proper sound card with physical audio inputs and outputs (preferebly with XLR connectors) and use a conventional (XLR) mic with that.

Gadem
User offline. Last seen 4 weeks 2 days ago. Offline
Joined: 2006-03-30
Posts:

I Solved it, using jackd1 in Ubuntu, i cant make work it in jackd2. Thanks.

x42
x42's picture
User offline. Last seen 2 hours 25 min ago. Offline
Joined: 2006-11-05
Posts:

Ardour itself does not support multiple soundcards. There's no built-in resampling to synchronize them. In short you'll want to use jackd with your default soundcard and then add the USB-mic to jack via alsa_in (comes with jackd) or zita-aj2 (from zita-ajbridge). see also http://jackaudio.org/faq/multiple_devices.html

Lexridge
User offline. Last seen 19 min 12 sec ago. Offline
Joined: 2007-09-13
Posts:

This is actually not as straight forward as it seems. I have a USB XLR mic cable (cheap). It works great under ALSA. It has a little LED which lights up when plugged in, and flashes when activated within the Pulseaudio mixer. I have tried using ALSA_IN to connect it to JACK. It does show up in the connections list, but I have not been able to get the mic to turn on (no flashing LED) unless I make it the first JACK device. Just adding it after the fact with alsa_in or zita-a2j doesn't work at all. It is seeing it fine, but just cannot turn it on, for whatever reason.