Failed to open maudio usb interface

10 replies [Last post]
mongoose
User offline. Last seen 1 week 6 days ago. Offline
Joined: 2017-08-08
Posts:

Hi,
My (admittedly old) Maudio Quattro usb1, compliant audio interface is working fine with my OS (Ubuntu 16.04): I can use it instead of built in sound. It also worked out of the box with LMMS, via ALSA.

However, when firing up Ardour (4.6), with ALSA, and selecting the Quattro for input and output device, I get the error: 'failed to open audio device.'

What am I missing, please?
(Or is it just a matter of getting a newer version of Ardour?)

Thanks!

Greenerpastures
User offline. Last seen 5 weeks 15 hours ago. Offline
Joined: 2017-08-14
Posts:

What version of Ardour does your Maudio Quattro work with under Ubuntu and LMMS.
Are are all those operating systems on the same computer.
Are there any security / permission issues, like adding yourself to the audio group.

Some times people need to reboot the computer with the interface plugged in, and
second time around it works, also try another usb port, obvious, make sure the usb
cord is plugged in / pushed all the way in at both ends.

Greenerpastures
User offline. Last seen 5 weeks 15 hours ago. Offline
Joined: 2017-08-14
Posts:

Just did a google search for usb 1 problem on Ubuntu 16.04 and
see other have same problem with usb 1 not working.

Greenerpastures
User offline. Last seen 5 weeks 15 hours ago. Offline
Joined: 2017-08-14
Posts:

From here, ubuntuforums.org/showthread DOT php?t=2188370 rReplace the DOT and pre-pend the usual
Here is an example of how someone got ports working,
Re: GA-970A-DS3P revision 1 no usb 3.0

Here is my updated fix

First enable iommu in the uefi by restarting your computer and pressing delete to enter the uefi

plug your usb mouse, keyboard and thumbdrive in usb 2 ports.

save and exit the uefi

Then In Ubuntu:

press Ctrl+Alt+T to open up a terminal

run the following command: sudo gedit /etc/default/grub

Only edit the empty quotes in this line to read: GRUB_CMDLINE_LINUX="iommu=soft"

save changes to grub and exit gedit and the terminal

Open up a new terminal with ctrl+alt+t

run the following command: sudo update-grub

then exit the terminal using this command: exit

Restart your computer press delete to get back into the uefi

Disable iommu in bios, load optimized defaults and restart.

usb, 2.0 usb 3.0 and networking all work now in Ubuntu, and disabling iommu in bios may also help improve your boot times.

If the above post helps anyone I am happy

mongoose
User offline. Last seen 1 week 6 days ago. Offline
Joined: 2017-08-08
Posts:

Thanks for all the advice Greenerpastures.

I should clarify that it works on my Ubuntu 16.04 operating system. I can plug in the Quattro and use it instead of built in soundcard, I can run LMMS (another Linux DAW) and it happily uses the Quattro via ALSA. So based on all this, and the description of Ardour, it should work. But when I start up Ardour, it is 'not able to open audio device'. I do not know how to find out any specific limitations of the various Ardour versions, I am only going by the description on https://ardour.org/requirements.html i.e. any ALSA supported device should work, in particular if it is already working with the host OS (which it is).
Thanks!
p.s. I have tried a full reboot with Quattro USB connected.

Greenerpastures
User offline. Last seen 5 weeks 15 hours ago. Offline
Joined: 2017-08-14
Posts:

Are you starting Ardour up and selecting ALSA or jack, and where have you configured
which sound device to use for Ardour.

Greenerpastures
User offline. Last seen 5 weeks 15 hours ago. Offline
Joined: 2017-08-14
Posts:

I start jack using qjackctl or cadence,
from within either qjjackctl or cadence, I select an input device from the jack settings / configuration section,
(do you see your audio interface and can select it as input device)?
if so, then from the same location (jack configuration block) select how many channels you want to use,
if your device has two, select two for in,
for channels out, I leave default so I can play the recorded sound back through my laptop for testing,
if I wanted to hear the playback through monitors connected to my external audio device I would select the device as output
and again select the correct number of channels to use.
Then I start Ardour, which gives me the choice of JACK AlSA and I think pulseaudio, I Select JACK,
Is this how you are approaching setting up Ardour.

Once Ardour is running, then you need to add a track, mono for a mic,
then go to mixer on the far top right, open mixer, select input for the track you created,
and select one of the channels from you audio device, if all went ok, there will be listings there such
as in 1, in 2, in 3 etc, so select the one your mic or instrument is connected to,
arm your track, arm record in the top bar, if the levels from you audio interface are set high enough
you will see the track meter moving because of local noises, speak or play your instrument and the meter will
of course rise accordingly, now hit play, and recording will start.

I can either start my laptop with the usb interface connected, or connect the usb interface after I start the computer,
either way, I have the interface connected to my laptop before I start jack, or Ardour.
In some cases I have heard of people need to reboot with the interface connected, I never have to.

Hope this helps

ccaudle
User offline. Last seen 1 day 20 hours ago. Offline
Joined: 2009-12-08
Posts:

Ardour will attempt to open the ALSA device for exclusive access, so make sure you do not have another software running which also uses exclusive access. For example, I would expect LMMS and Ardour cannot both run simultaneously while using ALSA, you would either need to use one, close it, then start the other, or use jackd to manage routing to the ALSA device.

Greenerpastures
User offline. Last seen 5 weeks 15 hours ago. Offline
Joined: 2017-08-14
Posts:

https://harrisonconsoles.lpages.co/heavyweight-bass-offer/

mongoose
User offline. Last seen 1 week 6 days ago. Offline
Joined: 2017-08-08
Posts:

Thanks ccaudle, but I do not have any other software running simultaneously. Ardour simply 'cannot open audio device' even though I can use it fine in other DAW software or even use it instead of built in sound. I have tried many reboots and different USB ports. It is a mystery.

paul
paul's picture
User offline. Last seen 17 hours 57 min ago. Offline
Joined: 2006-03-16
Posts:

When Ardour cannot access the device, run this command: cd /tmp && wget http://jackaudio.org/downloads/adevices.sh && bash ./adevices.sh

Show us the output. I tiwll not modify your system.