Error after building ardourvst

No replies
muzicman0
muzicman0's picture
User offline. Last seen 38 weeks 5 days ago. Offline
Joined: 2007-05-16
Posts:

I just rebuilt ardour to include the fftw3 library (see other thread), but now when trying to start ardourvst, I get this error:

wine: could not load L"Z:\\usr\\local\\lib\\ardour2\\ardour_vst.exe.so": Bad EXE format for

I have gotten this error many times before, and usually end up just reinstalling my OS, but I really don't want to do that! Also, ardour worked just fine yesterday...but since I rebuilt, it doesn't! Please someone help me out with this one! I've checked google, but there is no useful info that I could find...

mm0

DrG
User offline. Last seen 4 years 22 weeks ago. Offline
Joined: 2008-01-05
Posts:

I don't know if this will help but you need to make sure that, in winecfg, drive Z is mapped to '/'.

muzicman0
muzicman0's picture
User offline. Last seen 38 weeks 5 days ago. Offline
Joined: 2007-05-16
Posts:

yeah, it is, and like I said, nothing has changed except for recompiling ardourvst. Also, I have seen this on multiple distro's (Kubuntu, Debian, and Fedora).

If any one has anything to try, I would appreciate it, I really don't want to reinstall if I can avoid it...maybe I will try recompiling again...

mm0

muzicman0
muzicman0's picture
User offline. Last seen 38 weeks 5 days ago. Offline
Joined: 2007-05-16
Posts:

I've rebuilt 2 tmes now, no luck...anybody have any ideas?

muzicman0
muzicman0's picture
User offline. Last seen 38 weeks 5 days ago. Offline
Joined: 2007-05-16
Posts:

Well, I gave up and reinstalled Kubuntu, and first compile, went fine, and it starts fine...but if someone has an explanation, I would love to hear it, since I know I will run into this again!
mm0

muzicman0
muzicman0's picture
User offline. Last seen 38 weeks 5 days ago. Offline
Joined: 2007-05-16
Posts:

OK, so I rebuilt my system, and just got around to installing ardour...same problem again...anyone have any ideas?????

kanin_te_sova
User offline. Last seen 5 years 23 weeks ago. Offline
Joined: 2008-10-26
Posts:

Bitter taste of Wine and Scons? [Problem Solved]

I get the EXACT same problem as you people! This with Ardour 2.6.1 and the fst-VST support.

I have Ubuntu Studio 8.04 2.6.24-21rt kernel and has NOT had this problem before.

- Errorcode:

wine: could not load L"Z:\\usr\\local\\lib\\ardour2\\ardour_vst.exe.so": Bad EXE format for

The Low-Down:

WELL -- 1:st time I compiled and installed the latest Ardour as of Nov -08-08 everything got just right -- and WORKED FINE!

I THEN decided to install the SLV2 (and dependencies) on my system cuz I wanted to check it out.
So I did a scones uninstall and even used scones -c, making sure no traces of Ardour were present (also looking for files in MC).

I rebuilt and installed and guess what? I NOW get the above error! I tried un-/re-installing/compiling a few times. Even without SLV2 "SLV2=0" enabled.

Problem persists!

Seems to has something to do with Wine!
My Wine config "Z:" points to my root (/)

But something puzzles me about the error line:

Why the double (2) backlashes? \\\?

I think I read something about this might be a Wine or Scons problem / issue (I have Wine 1.1.4).
But as I said -- IT DID RUN fine the first time (w/out SLV2).

I have also succesfully compiled/installed Ardour 2.5 with VST support, running my current version of Wine.

However! This is what it says in the "ardourvst" shell script file anyways:

#!/bin/sh

# NOTE: the use of PREFIX is incorrect - it should be INSTALL_PREFIX,
# but somehow scons puts leading /'s on INSTALL_PREFIX and that causes
# wine to be unable to find the .exe.so file

export GTK_PATH=/usr/local/lib/ardour2:$GTK_PATH

LD_LIBRARY_PATH=/usr/local/lib/ardour2:$LD_LIBRARY_PATH exec wine /usr/local/lib/ardour2/ardour_vst.exe.so "$@"

So some Wine issues! But as I said -- IT DID WORK the first time (pre SLV2 as I see it)

I even tried adding PREFIX=/usr/whatever. But that didn't work.

I DO NOT KNOW WHAT TO DO!

I run a lot of VST(i)'s with dssivst with Wine and it works great! I don't want to reinstall my system (it's set up nicely and took me a looooooooong time, since I'm a Linux noob, but getting the hang of it he he. The backwards way: that is figuring out things from the GUI and then looking behind the scenes to see what goes on so to speak ;)).

HELP!!!! Anyone?!!! Seems not TOO many folks run into this...?

Peace!

/emil

GMaq
GMaq's picture
User offline. Last seen 3 days 14 hours ago. Offline
Joined: 2007-12-11
Posts:

Hi,

I don't think your problem is Wine, I have encountered this problem before when I tried to update my Redland RDF libraries. I had a perfectly functioning ArdourVST, Installed Redland and then had the same error as you.

Ardour uses "librdf" for SLV2 support and "liblrdf" for LADSPA support, in my case Synaptic had uninstalled "liblrdf" which I thought was OK with the redland update but it wasn't. I then re-installed "liblrdf" and it was working again.

Of course I can't guarantee that is your particular problem, but it may be worth looking into. If you don't want SLV2 don't use SLV2=0, just don't put any SLV2 line in at all.

Also in my experience I have never had to alter any paths or prefixes to have ArdourVST install and work properly, Unless you are a real hardcore "nixer" I'd be careful about that. Ardour is pretty good about finding stuff and should halt the configure stage if it can't.

kanin_te_sova
User offline. Last seen 5 years 23 weeks ago. Offline
Joined: 2008-10-26
Posts:

Hi there Gmag.

Thank you SO much! This solved this problem!

I reinstalled the librdf's and now Ardour is working again.

Wow, that was easy, but when you don't have a clue you're in the foggely mist. He he...

Again THANK'S! :o)

//emil

kanin_te_sova
User offline. Last seen 5 years 23 weeks ago. Offline
Joined: 2008-10-26
Posts:

Hi, I don’t think your

Hi,

I don’t think your problem is Wine, I have encountered this problem before when I tried to update my Redland RDF libraries. I had a perfectly functioning ArdourVST, Installed Redland and then had the same error as you.

Ardour uses “librdf” for SLV2 support and “liblrdf” for LADSPA support, in my case Synaptic had uninstalled “liblrdf” which I thought was OK with the redland update but it wasn’t. I then re-installed “liblrdf” and it was working again.

Of course I can’t guarantee that is your particular problem, but it may be worth looking into. If you don’t want SLV2 don’t use SLV2=0, just don’t put any SLV2 line in at all.

Also in my experience I have never had to alter any paths or prefixes to have ArdourVST install and work properly, Unless you are a real hardcore “nixer” I’d be careful about that. Ardour is pretty good about finding stuff and should halt the configure stage if it can’t.
--

My Site: www.bandshed.net
Wife’s Site: www.morethanwordsbooks.ca

svideo (not verified)

dostum saolasın sikiş erotik video sikiş erotik video izleyelim lütfen

svideo (not verified)

saolasınn sikiş erotik video sikiş erotik video izleyinnn.