ardour/jack crash

5 replies [Last post]
WhiteLion
User offline. Last seen 12 weeks 2 days ago. Offline
Joined: 2016-06-28
Posts:

while I'm recording or plain a track in Ardour I hear a strange sound in my headphones then the music stops but the track keeps going, In htop I see one of my core 100% busy, I try to close the ardour but it takes a while, if I try to restart it it says

"Could not reconnect to Audio/MIDI engine"

if I reboot the sistem I can restart ardour an going back to work for alf an hour before the error occures again..

Help!

seablade
User offline. Last seen 3 hours 35 min ago. Offline
Joined: 2007-01-22
Posts:

Sadly would need to know more information to really troubleshoot this, what OS/Version are you on? Did you get Ardour from here? I assume you are using the Jack backend, does Jack actually crash or is it hung in the background, and what version of Jack are you using? Does this problem happen if you use the ALSA backend?

Seablade

WhiteLion
User offline. Last seen 12 weeks 2 days ago. Offline
Joined: 2016-06-28
Posts:

i'm using

Ubuntu 16.04.1 LTS
Ardour 5.12.0
Jack 0.4.2

and In one of the tracks I'm using Helm, a midi synth instrument

jack is in the background
and an other thing I noticed that the error doesn't really happen so frequently in other projects, now I'm working on an other project with no midi tracks and it didn't happen for 2 days...

WhiteLion
User offline. Last seen 12 weeks 2 days ago. Offline
Joined: 2016-06-28
Posts:

I downloade Ardour here
and yes, I use ALSA

WhiteLion
User offline. Last seen 12 weeks 2 days ago. Offline
Joined: 2016-06-28
Posts:

what you mean backend?

WhiteLion
User offline. Last seen 12 weeks 2 days ago. Offline
Joined: 2016-06-28
Posts:

There must be some bug with midi files or with Helm , I solved the problem exporting the midi track and reimporting it as an audio file, now the project doesn't crash anymore, I hope that may be helpful for someone else.