Midi setup with Jack Audio

8 replies [Last post]
Demious
User offline. Last seen 4 weeks 6 days ago. Offline
Joined: 2017-12-23
Posts:

Hello Everyone,

I'm new to Ardour and I've got a lot to figure out, still and I hope that someone will be able to help me with the following...
I've installed Ardour and it flawlessly connects to my MOTU 282mk3 and it's MIDI ports. I can pick the 282 midi from the drop down menu at the top of the channel and it works perfectly.
Now I installed Jack Audio, for internal routing and the audio routing is a great tool! It gives so much flexibility!
However, when I have Ardour's I/O-routing setup through Jack, the MIDI inputs in the menu at the top of the channel have disappeared and I have no option to connect to incoming MIDI signals from the 282's MIDI input.

If anyone can advise me on how to proceed, or can point me to an explanation or tutorial of how to setup MIDI through Jack Audio, would be greatly appreciated!

Cheers!
Maarten

peder
User offline. Last seen 15 hours 6 min ago. Offline
Joined: 2007-05-08
Posts:

There are two ways to speak MIDI to the sound card. Either through ALSA or Jack.
See https://wiki.archlinux.org/index.php/JACK_Audio_Connection_Kit#MIDI

peder
User offline. Last seen 15 hours 6 min ago. Offline
Joined: 2007-05-08
Posts:

Ah, we're talking Windows.
The bottom entry of http://jackaudio.org/faq/jack_on_windows.html suggests adding -X winmme to the jack command line to get Jack MIDI

Demious
User offline. Last seen 4 weeks 6 days ago. Offline
Joined: 2017-12-23
Posts:

I indeed saw that part, but it doesnt mean anything to me. I'm just a user, not a programmer, I need steps explaining where to go and what to do. Also, it mentions QjackCtl, I've got only 4 files in the Jack-folder: Jack Command, Jack Control, Jack Netdriver and Jack Portaudio. My PC cant find anything named QjackCtl.

peder
User offline. Last seen 15 hours 6 min ago. Offline
Joined: 2007-05-08
Posts:

You don't have to be a programmer to use the command line and you don't even have to use the command line to add those flags to the Jack startup.

Create a link on your desktop to c:\Program Files(x86)\Jack\jackd.exe and add the -S -X winmme -d portaudio to the Target line
Double click the new link to start Jack with those flags.

Jack Control is the same as QJackCtl.

peder
User offline. Last seen 15 hours 6 min ago. Offline
Joined: 2007-05-08
Posts:

You can also add the -X winmme line in Jack Control; in "Server Prefix" under Setup... and the Advanced tab.

paul
paul's picture
User offline. Last seen 6 hours 59 min ago. Offline
Joined: 2006-03-16
Posts:

Is there a a specific reason you're using JACK? Unless you want route audio and/or MIDI between different applications, it doesn't really offer you anything.

Demious
User offline. Last seen 4 weeks 6 days ago. Offline
Joined: 2017-12-23
Posts:

That's a whole lot clearer, already, I had no idea where to look for a 'server backend', or the 'jack command line', or what a 'terminal' is and I couldnt find anything called 'server path' anywhere...
But anyways, I tried both options you describe, only for the second option I put the additional text in the setup menu in the 'settings' tab, I cant find an 'advanced' tab and that's the only place where I can find a 'server prefix'... But non of those 2 ways makes any difference... The only MIDI I get to see in the Jack 'connect' page, is from Ardour itself and nothing to connect it to and also inside Andour, still no MIDI options in the input section.

I want to route audio between different applications.

peder
User offline. Last seen 15 hours 6 min ago. Offline
Joined: 2007-05-08
Posts:

Yes, the "Server Prefix" is in the Advanced tab in the Settings tab.
When I set that line to jackd -S -X winmme and Stop and Start Jack I get a "system_midi / playback_1" under "Writable Clients" in the Connect/MIDI window.

Like this https://i.imgur.com/0QK4xce.jpg