Configure Ardour on Linux with QJackCtl and a Tascam US-122mkII

2 replies [Last post]
TimeMen
User offline. Last seen 3 days 5 hours ago. Offline
Joined: 2018-02-14
Posts:

Hey there,

I've installed Ardour5 and QJackCtl from AUR.
I want to use Ardour with the Tascam US-122mkII USB 2.0 Audio/MIDI Interface.
Is there any tutorial about setting up Ardour with Tascam using Jack?

The Tascam is connecte (proofed with lsusb).
There's also an existing MIDI-Bridge (a2j_control start) and a running Jack Server (QJackCTL).
What do I have to do, that it will all work?

Thanks in advance and excuse my bad English (i'm 17 and german...),
TimeMen

vasakq
User is online Online
Joined: 2013-03-30
Posts:

What kind of a problem are you encountering exactly? There should be none.

First make sure that the interface you are using with Qjackctl is indeed Tascam card and not computer's internal device (Qjackctl -> Setup -> Settings -> Parameters -> Interface: there should read hw:Tascam or something similar).

Second, start Ardour and after selecting and naming "New Session", Audio/MIDI Setup dialog appears. In the "Audio System:" box select JACK from the dropdown menu and click the "Start" button to the right. That should do the trick.
You could do the same without Qjackctl or JACK at all, you just need to select ALSA as the Audio System, it will work just as good. Jack is only useful if you use another standalone program you need to connect to Ardour (Hydrogen drum machine or Aeolus organ comes to mind...). If you use only plugins, you can skip JACK altogether.

TimeMen
User offline. Last seen 3 days 5 hours ago. Offline
Joined: 2018-02-14
Posts:

Hey, this problem is actually solved (Thanks to the guys in Ardours IRC).
Now there's another interesting problem...

But thanks for your answer :)