Cakewalk and Ardour- help setting up

8 replies [Last post]
HernanLG
HernanLG's picture
User offline. Last seen 13 weeks 1 hour ago. Offline
Joined: 2018-01-10
Posts:

Hi everyone,

I am running Ardour 5.5 and Jack 0.44.I am trying to record an instrument with a Cakewalk UA-25 EX.

I am very new to music production in Linux. I am a long-time musician, but this is my first time trying to set up a usb-interface in my linux machine.

I have seen many video tutorials. So far, I (think I) have set up realtime audio by editing limits.conf.

I can start jack with no problem. Same goes for Ardour.
The Cakewalk is recognized by my computer.
The instrument, connected to the interface via usb, is recognized by the interface, as indicated by the peak light lighting up when I turn the sensitivity knob all the way up and play the instrument

But... I cannot see the cakewalk in the jack Connections window.

I would appreciate if there are any skilled Ardour users that would be willing to guide me through setting this up.

Thanks in advance

ccaudle
User offline. Last seen 11 hours 46 min ago. Offline
Joined: 2009-12-08
Posts:

That jack version does not make sense (the two common versions of jack in use on linux are 0.125 and 1.9.11 or 1.9.12.
You perhaps mean that you are using qjackctl 0.4.4 to start jack, but that version is also old, from the end of 2016, the current version is 0.5.0.

The version of Ardour you have is also very old, the current version is 5.12. The ardour news page does not have dates on the announcements so I don't remember when 5.5 came out, but that is 6 releases back, so at least a couple of years ago. There is no reason to run a version that old, you won't get any help when you hit bugs which are already fixed in new versions.

But to your original question, the audio interface in the jack connections window would be listed as "system" so if you were expecting to see a name specific to your interface that may be why you think is it not present.

You don't need to mess with jack at all for what you are trying to do, just start Ardour and select to use ALSA as the audio system instead of jack, Ardour will connect to the audio interface directly. But definitely update Ardour.

What linux distribution are you using? Are you using something really ancient and just using the software versions that shipped with the original release?

HernanLG
HernanLG's picture
User offline. Last seen 13 weeks 1 hour ago. Offline
Joined: 2018-01-10
Posts:

Thanks for the reply @ccaudle

You're right, I was reporting the version of qjackctl. The jackd package installed in my system says version 5... I don't know if that makes sense given the numbers you gave me just now... I am running MX. It is based on Debian stable, which is known for having outdated software.

As for my goal of being able to record an instrument, I selected Alsa as the sound for Ardour and it looks more promising. If I choose the default input, then Ardour recognizes the sound from my built-in laptop microphone. I can't, however, get any sound through the interface when I select it as input. I checked the input preferences of the track I created and in the 'hardware' tab I have the track connected to capture_1 and capture_2, but none of those options give me any sound. The interface is still getting the sound from the instrument as well as being recognized by the computer.

I will ask the maintainers of my distribution of add the newest version of Ardour to the repositories of my system.

On the meantime, do you have any tips to get the sound from my instrument (coming from the usb interface) to be recognized by the computer? So far I create a track but I get no input sound to be recognized.

paul
paul's picture
User offline. Last seen 3 hours 7 min ago. Offline
Joined: 2006-03-16
Posts:

Using the ALSA backend, you cannot mix different audio interfaces for input and output. You should read this to find out why this is a bad idea in general: http://jackaudio.org/faq/multiple_devices.html

Ardour does not "recognize" sound from the built-in laptop microphone. You told it which audio interface to use, and it uses it.

ccaudle
User offline. Last seen 11 hours 46 min ago. Offline
Joined: 2009-12-08
Posts:

It would probably help to get comfortable working in a terminal for some of the debug steps.
To determine the actual version of jack in use, you can run in a terminal window: jackd --version
That should print out version information for the version of jackd on your system.

To determine how your USB interface is named (to be sure you are connecting to which interface you think you are), you can use this also utility to list the interfaces discovered: aplay -l

Assuming that you did connect Ardour to the correct interface you intended, then possibly there is an ALSA mixer control that has the input gain turned all the way down. Look in your applications for something with a name of alsamixer or similar, it should show a set of controls for inputs and outputs.

To get the latest version of Ardour you can pay a nominal amount and download the version directly from this web site. That is the only version which the Ardour developers will directly support.

HernanLG
HernanLG's picture
User offline. Last seen 13 weeks 1 hour ago. Offline
Joined: 2018-01-10
Posts:

Thanks Paul, I know now I should select the interface for both input and output.

@ccaudle Thanks for the suggestions. My jack version is 1.9.11

The interface is recognized as:

card 1: UA25EX [UA-25EX], device 0: USB Audio [USB Audio]
Subdevices: 0/1
Subdevice #0: subdevice #0

In Ardour, it is named as UA-25EX.

I checked the ALSA mixer, but the master was set to 20 and the capture to 18. I set both to 40 but still I get no input.

I would be glad to contribute to the Ardour project, but I would first like to know I can use it. Do you think I require the latest version to be able to get sound from an instrument through this usb interface?

Thanks for the help so far

ccaudle
User offline. Last seen 11 hours 46 min ago. Offline
Joined: 2009-12-08
Posts:

Seems like it should work, probably will need someone with more understanding of checking the USB device. Maybe linux-audio-users mailing list, some of the ALSA developers read that.
Or try on IRC (see link at the bottom of the web page).

vasakq
User offline. Last seen 2 hours 26 min ago. Offline
Joined: 2013-03-30
Posts:

This may help:

https://alsa.opensrc.org/Edirol_UA-25EX

peder
User offline. Last seen 3 days 10 hours ago. Offline
Joined: 2007-05-08
Posts:

Open QJackCtl, make sure it's stopped and click the Setup button.
Make sure you're on the Settings tab and click the Advanced tab below it.
To the right you should see Output Device and Input Device drop-downs, hit the buttons and your UA should show up.
Select it for both In and Out, click OK and hit the Start button.