moving multiple regions without copying them..

3 replies [Last post]
calimerox
calimerox's picture
User offline. Last seen 4 hours 5 min ago. Offline
Joined: 2007-10-19
Posts:

What happens to me a lot when i m editing multiple regions is that the regions get copied and stay underneath the moved region. this can sometimes mess up a lot of work and make mixing unpredictable..

what i do: mark regions from multiple tracks.

move these regions or apply to all a fade in or fade out.

half of the time everything is fine. the other half the regions get copied and stay underneath the newly altered region.

I have no idea how i trigger this behaviour, maybe there is a shortcut i m not aware of ? How could i prevent this from happening? thank you !

colinf
colinf's picture
User offline. Last seen 5 weeks 5 days ago. Offline
Joined: 2007-11-26
Posts:

<Ctrl>+drag copies regions, leaving the original in place: maybe you've just done <Ctrl>+"something else" immediately before and haven't let go of the control key quickly enough, or you've done done <Ctrl>+click to select mutiple regions and accidentally dragged enough to make a region copy. I've done both of these things :)

calimerox
calimerox's picture
User offline. Last seen 4 hours 5 min ago. Offline
Joined: 2007-10-19
Posts:

aah! this is pretty probable! as i usually mark with Ctrl+click the regions! so while marking them a tiny little mouse shift would copy all the marked regions already... I wonder if i can disable the shortcut ctrl+drag to circumvent that issue...

Andreas1
User offline. Last seen 2 hours 38 min ago. Offline
Joined: 2015-12-27
Posts:

Ok i am not alone with this mess.
The manual shows that selecting multiple regions by using crtl-left + mouseclick is also used to copy them when dragging the mouse. Therefore copying instead of only selecting the regions is done with the slightest mouse movement. Lock does not help. And when i select multiple regions vertically with shift + mouse click the regions left to the wanted regions are selected too. The only solution yet is to start above the first or last region to select, click left and hold while moving the mouse over the wanted regions. The worst thing about this selection/copy mess is that you don't get informed about the regions copy. Some when later you might see it, but then the mess is done. How to switch off this behavior?