How do I load MIDNAM files?

4 replies [Last post]
Bransby
User offline. Last seen 3 weeks 2 days ago. Offline
Joined: 2015-10-07
Posts:

I'm trying to follow the instructions in this guide http://libremusicproduction.com/tutorials/using-avl-drumkits-fluid-synth-ardour
to load a midnam file with AVL Drumkits. It says to click on the dropdown menu lablled "generic" to select the MIDNAM files, which I've already copied to the relevant config folder. My problem is I don't have any dropdown menus in my MIDI track header. Even with the track fully expanded I only have the basic fader, and the usual mute solo, arm track etc. buttons, I have no drop down menus at all.
I've got the AVL Drumkit soundfont loaded into a-fluid synth and can hear the drums fine, but can't load the MIDNAM file. I'm running Ardour 5.12 on Ubuntu 18.10. Thanks.

paul
paul's picture
User offline. Last seen 1 hour 15 min ago. Offline
Joined: 2006-03-16
Posts:

Increase the height of your MIDI track just a bit, and the selectors for MIDNAM data will become visible, below the fader, solo, mute, playlist and automation buttons.

To go back to the default "Generic MIDI" setting, select "MMA > Generic" (MMA = MIDI Manufacturers' Association).

x42
x42's picture
User offline. Last seen 6 hours 36 min ago. Offline
Joined: 2006-11-05
Posts:

Prefer the dedicated http://x42-plugins.com/x42/x42-avldrums plugin, that has a built-in midnam. There is no need to install any custom files and it is a lot simpler than the tutorial that you've linked.
I don't think Ubuntu packages those, but KXStudio does, you can also get binaries and/or source-code from the x42-plugins.com -- see also
http://libremusicproduction.com/news/20170119-boom-avl-drumkits-plugins

PS. Since Ardour 5.5. in 2016, a-fluidsyth does not allow any custom midnam. The plugin auto-generates a file depending on the description in the .sf2 file. The tutorial is no longer valid.

Bransby
User offline. Last seen 3 weeks 2 days ago. Offline
Joined: 2015-10-07
Posts:

Thanks both. @Paul I have increased the height but there are still no dropdown menus, but it looks like that might be because of what @x42 says about not being able to add custom midnams to a-fluidsynth since 5.5, that would seem to make sense of the problem I'm having.

@x42, thanks for those tips, will try your plugin.

Bransby
User offline. Last seen 3 weeks 2 days ago. Offline
Joined: 2015-10-07
Posts:

@x42, plugin works perfectly, thank you.