MAJOR PROBLEMS

10 replies [Last post]
kdaffolder
User offline. Last seen 6 years 3 weeks ago. Offline
Joined: 2008-03-20
Posts:

Hi. I am a Music Technology student that is very interested in using this software, however, I have been having major problems and cannot get this program to run on my Macbook Pro. Below is my computer's hardware for reference:

Model Name: MacBook Pro
Model Identifier: MacBookPro3,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.2 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 4 MB
Memory: 2 GB
Bus Speed: 800 MHz
Boot ROM Version: MBP31.0070.B02
SMC Version: 1.16f8
Sudden Motion Sensor:
State: Enabled

System Version: Mac OS X 10.5.2 (9C31)
Kernel Version: Darwin 9.2.0
Boot Volume: Macintosh HD
Boot Mode: Normal

I thought I had followed the instructions to install this program, but apparently I either did something wrong or something is not running correctly. I installed both Ardour and Jack OSX. I know that I need to run the Jack OSX server before I run Ardour....correct? So, when I click 'Start' under the Jack OSX GUI, it says it's starting to run, then it gives me a error message that says, "Error. Cannot start Jack server, Please check preferences or retry after a system reboot. I opened my Mac's compiler to try and capture the error, which I have pasted below:

http://img2.freeimagehosting.net/uploads/9d95c10223.png

When I try to run Ardour, the icon appears in my dock, bounces a couple of times, then disappears. I don't know what to do! :(

Also, another question. Does anyone know if Ardour supports input from a firewire-connected PreSonus Firepod? Thanks.

Could someone please help a student out? I would GREATLY appreciate it. Thank you.

letz
User offline. Last seen 49 weeks 2 days ago. Offline
Joined: 2006-09-27
Posts:

You probably have a driver setting issue. This is somewhat completely unrelated to Ardour; that is you should have jack server configurated properly before using Ardour:

- read the JackOSX documentation especially the section related to aggregate devices: you'll have to setup an aggregate device to use your machine in duplex (in/out) mode

- select the aggregate device in JackPilot preferences windows

- start Jack server and check is works correctly using CoreAudio applications like iTunes

- then start Ardour

kdaffolder
User offline. Last seen 6 years 3 weeks ago. Offline
Joined: 2008-03-20
Posts:

OK, I downloaded the documentation that you suggested from the JackOSX website and read the section about aggregate devices. It's wonderful because I read it, and followed reinstalling JackOSX and entering new Preferences and now I can successfully get my JackOSX server to run. YEAY! ;) haha. I am still having problems with Ardour though. I open my JackPilot and select to run the server and then after the server starts running I try running the Ardour application. The icon still appears in my dock for a split second, bounces a couple of times, and then almost disappears instantly. I've read on the forums that on Ardour's 'first run', it usually takes about four or five minutes to load, but I've tried running it several times and waiting at least fifteen minutes for each run attempt. What could be wrong? Please help. I'd really like to use this open source program for my music technology major at college. Thanks to anyone that helps, and thank you 'letz'...I really appreciate your previous helpful hints.

-Kyle

mattb
mattb's picture
User offline. Last seen 45 weeks 2 days ago. Offline
Joined: 2007-02-22
Posts:

Sorry if this is an obvious one, but you have got X11 installed haven't you?

kdaffolder
User offline. Last seen 6 years 3 weeks ago. Offline
Joined: 2008-03-20
Posts:

I tried re-downloading the Ardour program to see if maybe it hadn't downloaded it correctly. After re-installing and starting the JackOSX server, I try running Ardour. The same thing happens, even after I have re-installed Ardour: the icon appears in the dock, bounces a few times, then disappears. I thought I would open up a console window and capture any program output to post on here for anyone that might be able to help. This is all it output:

3/21/08 2:28:27 PM [0x0-0x37037].org.ardour.Ardour2[398] /Applications/Ardour2.app/Contents/Resources/script: line 38: open-x11: command not found
3/21/08 2:28:27 PM [0x0-0x37037].org.ardour.Ardour2[398] Unable to find application named 'XDarwin'
3/21/08 2:28:39 PM [0x0-0x39039].org.ardour.Ardour2[413] /Applications/Ardour2.app/Contents/Resources/script: line 38: open-x11: command not found
3/21/08 2:28:39 PM [0x0-0x39039].org.ardour.Ardour2[413] Unable to find application named 'XDarwin'

I did a Google search for what XDarwin was, and it looks like it has something to do with X11. I thought I had X11 installed on my computer though. Isn't that installed by default with Leopard? So, I thought, well what if I just ran X11 by going to Applications > Utilities and double clicking on X11? I did this and then tried re-running Ardour and Ardour actually started! Yeay! However, it looked really nasty. Here's a screenshot of the window that popped up after Ardour finally loaded after a couple of minutes:

http://img2.freeimagehosting.net/uploads/988019732b.png

I also have copied and pasted Console output below. I noticed an error with some font or something as you might have already figured out in the above window-screenshot.

This is my first run-attempt:

3/21/08 2:28:39 PM [0x0-0x39039].org.ardour.Ardour2[413] /Applications/Ardour2.app/Contents/Resources/script: line 38: open-x11: command not found
3/21/08 2:28:39 PM [0x0-0x39039].org.ardour.Ardour2[413] Unable to find application named 'XDarwin'
3/21/08 2:34:39 PM org.x.X11[436] X11.app = /Applications/Utilities/X11.app/Contents/MacOS/X11
3/21/08 2:34:39 PM org.x.X11[436] TransformProcessType: Success
3/21/08 2:34:40 PM org.x.X11[436] TransformProcessType: Success
3/21/08 2:34:40 PM org.x.X11[436] Launchd command line argument noticed.
3/21/08 2:34:40 PM org.x.X11[436] X11.app starting:
3/21/08 2:34:40 PM org.x.X11[436] X.org Release 7.2
3/21/08 2:34:40 PM org.x.X11[436] X.Org Xquartz X Server 1.3.0-apple5
3/21/08 2:34:40 PM org.x.X11[436] Build Date: 20080109
3/21/08 2:34:40 PM org.x.X11[436] Xquartz: run by launchd for fd 0
3/21/08 2:34:40 PM org.x.X11[436] _XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix will not be created.
3/21/08 2:34:40 PM org.x.X11[436] Could not init font path element /Library/Fonts, removing from list!
3/21/08 2:34:40 PM org.x.X11[436] Could not init font path element /System/Library/Fonts, removing from list!
3/21/08 2:34:40 PM [0x0-0x3b03b].org.x.X11[435] X11.app: main(): closing the display and sleeping
3/21/08 2:34:40 PM [0x0-0x3b03b].org.x.X11[435] command=/usr/X11/bin/xterm
3/21/08 2:34:40 PM com.apple.launchd[104] ([0x0-0x3b03b].org.x.X11[435]) Stray process with PGID equal to this dead job: PID 440 PPID 1 login
3/21/08 2:44:05 PM [0x0-0x42042].org.ardour.Ardour2[464] /Applications/Ardour2.app/Contents/Resources/script: line 38: open-x11: command not found
3/21/08 2:44:05 PM [0x0-0x42042].org.ardour.Ardour2[464] Unable to find application named 'XDarwin'
3/21/08 2:44:05 PM defaults[486]
The domain/default pair of (.GlobalPreferences, AppleCollationOrder) does not exist

3/21/08 2:44:05 PM [0x0-0x42042].org.ardour.Ardour2[464] 2008-03-21 14:44:05.643 defaults[486:10b]
3/21/08 2:44:05 PM [0x0-0x42042].org.ardour.Ardour2[464] The domain/default pair of (.GlobalPreferences, AppleCollationOrder) does not exist
3/21/08 2:44:08 PM [0x0-0x42042].org.ardour.Ardour2[464] Ardour/GTK 2.1
3/21/08 2:44:08 PM [0x0-0x42042].org.ardour.Ardour2[464] (built using 2496 and GCC version 4.0.1 (Apple Computer, Inc. build 5250))
3/21/08 2:44:08 PM [0x0-0x42042].org.ardour.Ardour2[464] Copyright (C) 1999-2007 Paul Davis
3/21/08 2:44:08 PM [0x0-0x42042].org.ardour.Ardour2[464] Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker
3/21/08 2:44:08 PM [0x0-0x42042].org.ardour.Ardour2[464] Ardour comes with ABSOLUTELY NO WARRANTY
3/21/08 2:44:08 PM [0x0-0x42042].org.ardour.Ardour2[464] not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
3/21/08 2:44:08 PM [0x0-0x42042].org.ardour.Ardour2[464] This is free software, and you are welcome to redistribute it
3/21/08 2:44:08 PM [0x0-0x42042].org.ardour.Ardour2[464] under certain conditions; see the source for copying conditions.
3/21/08 2:44:52 PM [0x0-0x42042].org.ardour.Ardour2[464] loading default ui configuration file /Applications/Ardour2.app/Contents/Resources/etc/ardour2/ardour2_ui_default.conf
3/21/08 2:44:52 PM [0x0-0x42042].org.ardour.Ardour2[464] Configuration::pack_canvasvars () called, canvas_colors.size() = 82
3/21/08 2:44:52 PM [0x0-0x42042].org.ardour.Ardour2[464] ardour: [INFO]: Loading ui configuration file /Applications/Ardour2.app/Contents/Resources/etc/ardour2/ardour2_ui_dark.rc
3/21/08 2:44:52 PM [0x0-0x42042].org.ardour.Ardour2[464] loading system configuration file /Applications/Ardour2.app/Contents/Resources/etc/ardour2/ardour_system.rc
3/21/08 2:44:53 PM [0x0-0x42042].org.ardour.Ardour2[464] theme_init() called from internal clearlooks engine
3/21/08 2:44:53 PM [0x0-0x42042].org.ardour.Ardour2[464] ardour: [INFO]: Apple VecLib H/W specific optimizations in use
3/21/08 2:44:53 PM [0x0-0x42042].org.ardour.Ardour2[464] ardour: [INFO]: looking for control protocols in /Users/kyleaffolder/.ardour2/surfaces/:/Applications/Ardour2.app/Contents/Resources/lib/surfaces/
3/21/08 2:44:53 PM [0x0-0x42042].org.ardour.Ardour2[464] ardour: [INFO]: Control surface protocol discovered: "Generic MIDI"
3/21/08 2:44:53 PM [0x0-0x42042].org.ardour.Ardour2[464] ardour: [INFO]: Control surface protocol discovered: "Mackie"
3/21/08 2:44:54 PM [0x0-0x42042].org.ardour.Ardour2[464] ardour: [INFO]: Control protocol Tranzport not usable
3/21/08 2:44:54 PM [0x0-0x42042].org.ardour.Ardour2[464] execpath = /Applications/Ardour2.app/Contents/Resources/bin/ardour
3/21/08 2:44:54 PM [0x0-0x42042].org.ardour.Ardour2[464] (ardour:465): Pango-WARNING **: shape engine failure, expect ugly output. the offending font is 'Lucida Grande 10.9990234375'
3/21/08 2:44:54 PM [0x0-0x42042].org.ardour.Ardour2[464] (ardour:465): Pango-WARNING **: pango_font_get_glyph_extents called with bad font, expect ugly output

This is my second run-attemp:

3/21/08 2:54:53 PM org.x.X11[532] X11.app = /Applications/Utilities/X11.app/Contents/MacOS/X11
3/21/08 2:54:53 PM org.x.X11[532] TransformProcessType: Success
3/21/08 2:54:53 PM org.x.X11[532] TransformProcessType: Success
3/21/08 2:54:53 PM org.x.X11[532] Launchd command line argument noticed.
3/21/08 2:54:53 PM org.x.X11[532] X11.app starting:
3/21/08 2:54:53 PM org.x.X11[532] X.org Release 7.2
3/21/08 2:54:53 PM org.x.X11[532] X.Org Xquartz X Server 1.3.0-apple5
3/21/08 2:54:53 PM org.x.X11[532] Build Date: 20080109
3/21/08 2:54:53 PM org.x.X11[532] Xquartz: run by launchd for fd 0
3/21/08 2:54:53 PM org.x.X11[532] Could not init font path element /Library/Fonts, removing from list!
3/21/08 2:54:53 PM org.x.X11[532] Could not init font path element /System/Library/Fonts, removing from list!
3/21/08 2:54:53 PM [0x0-0x45045].org.x.X11[531] X11.app: main(): closing the display and sleeping
3/21/08 2:54:53 PM [0x0-0x45045].org.x.X11[531] command=/usr/X11/bin/xterm
3/21/08 2:54:53 PM com.apple.launchd[104] ([0x0-0x45045].org.x.X11[531]) Stray process with PGID equal to this dead job: PID 534 PPID 1 login
3/21/08 2:54:53 PM org.x.X11[532] Could not init font path element /Library/Fonts, removing from list!
3/21/08 2:54:53 PM org.x.X11[532] Could not init font path element /System/Library/Fonts, removing from list!
3/21/08 2:56:37 PM [0x0-0x48048].org.ardour.Ardour2[539] /Applications/Ardour2.app/Contents/Resources/script: line 38: open-x11: command not found
3/21/08 2:56:37 PM [0x0-0x48048].org.ardour.Ardour2[539] Unable to find application named 'XDarwin'
3/21/08 2:56:37 PM defaults[561]
The domain/default pair of (.GlobalPreferences, AppleCollationOrder) does not exist

3/21/08 2:56:37 PM [0x0-0x48048].org.ardour.Ardour2[539] 2008-03-21 14:56:37.540 defaults[561:10b]
3/21/08 2:56:37 PM [0x0-0x48048].org.ardour.Ardour2[539] The domain/default pair of (.GlobalPreferences, AppleCollationOrder) does not exist
3/21/08 2:56:37 PM [0x0-0x48048].org.ardour.Ardour2[539] Ardour/GTK 2.1
3/21/08 2:56:37 PM [0x0-0x48048].org.ardour.Ardour2[539] (built using 2496 and GCC version 4.0.1 (Apple Computer, Inc. build 5250))
3/21/08 2:56:37 PM [0x0-0x48048].org.ardour.Ardour2[539] Copyright (C) 1999-2007 Paul Davis
3/21/08 2:56:37 PM [0x0-0x48048].org.ardour.Ardour2[539] Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker
3/21/08 2:56:37 PM [0x0-0x48048].org.ardour.Ardour2[539] Ardour comes with ABSOLUTELY NO WARRANTY
3/21/08 2:56:37 PM [0x0-0x48048].org.ardour.Ardour2[539] not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
3/21/08 2:56:37 PM [0x0-0x48048].org.ardour.Ardour2[539] This is free software, and you are welcome to redistribute it
3/21/08 2:56:37 PM [0x0-0x48048].org.ardour.Ardour2[539] under certain conditions; see the source for copying conditions.
3/21/08 2:56:38 PM [0x0-0x48048].org.ardour.Ardour2[539] loading default ui configuration file /Applications/Ardour2.app/Contents/Resources/etc/ardour2/ardour2_ui_default.conf
3/21/08 2:56:38 PM [0x0-0x48048].org.ardour.Ardour2[539] Configuration::pack_canvasvars () called, canvas_colors.size() = 82
3/21/08 2:56:38 PM [0x0-0x48048].org.ardour.Ardour2[539] ardour: [INFO]: Loading ui configuration file /Applications/Ardour2.app/Contents/Resources/etc/ardour2/ardour2_ui_dark.rc
3/21/08 2:56:38 PM [0x0-0x48048].org.ardour.Ardour2[539] loading system configuration file /Applications/Ardour2.app/Contents/Resources/etc/ardour2/ardour_system.rc
3/21/08 2:56:39 PM [0x0-0x48048].org.ardour.Ardour2[539] theme_init() called from internal clearlooks engine
3/21/08 2:56:39 PM [0x0-0x48048].org.ardour.Ardour2[539] ardour: [INFO]: Apple VecLib H/W specific optimizations in use
3/21/08 2:56:39 PM [0x0-0x48048].org.ardour.Ardour2[539] ardour: [INFO]: looking for control protocols in /Users/kyleaffolder/.ardour2/surfaces/:/Applications/Ardour2.app/Contents/Resources/lib/surfaces/
3/21/08 2:56:39 PM [0x0-0x48048].org.ardour.Ardour2[539] ardour: [INFO]: Control surface protocol discovered: "Generic MIDI"
3/21/08 2:56:39 PM [0x0-0x48048].org.ardour.Ardour2[539] ardour: [INFO]: Control surface protocol discovered: "Mackie"
3/21/08 2:56:39 PM [0x0-0x48048].org.ardour.Ardour2[539] ardour: [INFO]: Control protocol Tranzport not usable

So, what am I doing wrong?!? Someone please help! :(

Thanks so much!
Kyle

paul
paul's picture
User offline. Last seen 1 day 5 hours ago. Offline
Joined: 2006-03-16
Posts:

You have downloaded an old version (2.1) of the Ardour X11 version that cannot be used on Leopard because Apple changed the way X11 apps are supposed to start up. This is my fault because I did not update the OS X binary download page. If you check the download page you will see that 2.3 is the latest version and it will run on Leopard (at least until Apple changes the rules of the game again). My apologies for the out-of-date link.

kdaffolder
User offline. Last seen 6 years 3 weeks ago. Offline
Joined: 2008-03-20
Posts:

Paul, thank you, as this newer binary ran X11 automatically therefore no need for me to open it manually. However, I am still having some type of a problem. Please check the image link below. You'll see what I mean. I have also included the Console output when I start to run Ardour so that maybe you or someone can figure out why I am not getting any characters.

The image: http://img2.freeimagehosting.net/uploads/b573f755eb.png

Here is the Console output:

3/21/08 6:23:26 PM [0x0-0x72072].org.ardour.Ardour2[926] 2008-03-21 18:23:26.519 defaults[944:10b]
3/21/08 6:23:26 PM [0x0-0x72072].org.ardour.Ardour2[926] The domain/default pair of (.GlobalPreferences, AppleCollationOrder) does not exist
3/21/08 6:23:30 PM [0x0-0x72072].org.ardour.Ardour2[926] Ardour/GTK 2.3.1
3/21/08 6:23:30 PM [0x0-0x72072].org.ardour.Ardour2[926] (built using 3025 and GCC version 4.0.1 (Apple Computer, Inc. build 5250))
3/21/08 6:23:30 PM [0x0-0x72072].org.ardour.Ardour2[926] Copyright (C) 1999-2007 Paul Davis
3/21/08 6:23:30 PM [0x0-0x72072].org.ardour.Ardour2[926] Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker
3/21/08 6:23:30 PM [0x0-0x72072].org.ardour.Ardour2[926] Ardour comes with ABSOLUTELY NO WARRANTY
3/21/08 6:23:30 PM [0x0-0x72072].org.ardour.Ardour2[926] not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
3/21/08 6:23:30 PM [0x0-0x72072].org.ardour.Ardour2[926] This is free software, and you are welcome to redistribute it
3/21/08 6:23:30 PM [0x0-0x72072].org.ardour.Ardour2[926] under certain conditions; see the source for copying conditions.
3/21/08 6:23:31 PM org.x.X11[952] X11.app = /Applications/Utilities/X11.app/Contents/MacOS/X11
3/21/08 6:23:31 PM org.x.X11[952] TransformProcessType: Success
3/21/08 6:23:31 PM org.x.X11[952] TransformProcessType: Success
3/21/08 6:23:31 PM org.x.X11[952] Launchd command line argument noticed.
3/21/08 6:23:31 PM org.x.X11[952] X11.app starting:
3/21/08 6:23:31 PM org.x.X11[952] X.org Release 7.2
3/21/08 6:23:31 PM org.x.X11[952] X.Org Xquartz X Server 1.3.0-apple5
3/21/08 6:23:31 PM org.x.X11[952] Build Date: 20080109
3/21/08 6:23:31 PM org.x.X11[952] Xquartz: run by launchd for fd 0
3/21/08 6:23:31 PM org.x.X11[952] Could not init font path element /Library/Fonts, removing from list!
3/21/08 6:23:31 PM org.x.X11[952] Could not init font path element /System/Library/Fonts, removing from list!
3/21/08 6:23:32 PM [0x0-0x72072].org.ardour.Ardour2[926] loading default ui configuration file /Applications/Ardour2.app/Contents/Resources/etc/ardour2/ardour2_ui_default.conf
3/21/08 6:23:33 PM [0x0-0x72072].org.ardour.Ardour2[926] Loading ui configuration file /Applications/Ardour2.app/Contents/Resources/etc/ardour2/ardour2_ui_dark.rc
3/21/08 6:23:33 PM [0x0-0x72072].org.ardour.Ardour2[926] loading system configuration file /Applications/Ardour2.app/Contents/Resources/etc/ardour2/ardour_system.rc
3/21/08 6:23:34 PM [0x0-0x72072].org.ardour.Ardour2[926] theme_init() called from internal clearlooks engine
3/21/08 6:23:34 PM [0x0-0x72072].org.ardour.Ardour2[926] ardour: [INFO]: Apple VecLib H/W specific optimizations in use
3/21/08 6:23:34 PM [0x0-0x72072].org.ardour.Ardour2[926] ardour: [INFO]: looking for control protocols in /Users/kyleaffolder/.ardour2/surfaces/:/Applications/Ardour2.app/Contents/Resources/lib/surfaces/
3/21/08 6:23:34 PM [0x0-0x72072].org.ardour.Ardour2[926] ardour: [INFO]: Control surface protocol discovered: "Generic MIDI"
3/21/08 6:23:34 PM [0x0-0x72072].org.ardour.Ardour2[926] ardour: [INFO]: Control surface protocol discovered: "Mackie"
3/21/08 6:23:34 PM [0x0-0x72072].org.ardour.Ardour2[926] ardour: [INFO]: Control protocol Tranzport not usable
3/21/08 6:23:35 PM [0x0-0x72072].org.ardour.Ardour2[926] (ardour:928): Pango-WARNING **: shape engine failure, expect ugly output. the offending font is 'Lucida Grande 10.9990234375'
3/21/08 6:23:35 PM [0x0-0x72072].org.ardour.Ardour2[926] (ardour:928): Pango-WARNING **: pango_font_get_glyph_extents called with bad font, expect ugly output
3/21/08 6:27:23 PM org.x.X11[952] Quitting XQuartz...
3/21/08 6:27:23 PM org.x.X11[952] meta mod is 4

Thanks in advance for any help someone might be able to give.

-Kyle

paul
paul's picture
User offline. Last seen 1 day 5 hours ago. Offline
Joined: 2006-03-16
Posts:

Where did you install Ardour? (i.e. the full path to the Ardour2.app folder)

kdaffolder
User offline. Last seen 6 years 3 weeks ago. Offline
Joined: 2008-03-20
Posts:

On my Mac, I installed Ardour under the path: /Applications/Ardour

paul
paul's picture
User offline. Last seen 1 day 5 hours ago. Offline
Joined: 2006-03-16
Posts:

OK, this is an error with Apple's X11.app .... and unfortunately it seems to be something that will be a pain for you to fix - I am on the mailing list for that "product" (Apple have basically outsourced its development now), and the situation on Leopard is wierd - on the one hand, Apple now installs it by default. on the other hand, the version that came with Leopard is broken in some important ways and Apple expects you to update from an open source project release page.

I would suggest that you join us on IRC and try out the native version instead. If it has similar issues (it may), then we'll know its because something has messed up your system font configuration.

kdaffolder
User offline. Last seen 6 years 3 weeks ago. Offline
Joined: 2008-03-20
Posts:

paul, thank you. I joined the IRC and downloaded the native version. I no longer have any problems with running Ardour and getting squares. Now I get regular characters! Thank you so much. So far, I haven't run into any problems with Ardour, but then again I am just starting to get used to the program. It looks very nice. Thanks again!...must have been something with X11.

-Kyle