Alternating tracks when recording

No replies
joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 2 days ago. Offline
Joined: 2008-02-27
Posts:

Hi all, every day I learn a little more about ardour, but today something really weird started happening which never before had happened to me.

I start a new project, create a new track and I can record fine on it, then create second track and will not record, but third will, and fourth won't, fifth will, and so on, this is the strange pattern I am having problems with, any tips?

Thanks.

Joe

Pablo Fernández
User offline. Last seen 49 weeks 5 days ago. Offline
Joined: 2007-02-20
Posts:

Maybe it's obvious but...
Have you checked the connections?
I think that could happen if your audio card has two inputs and ardour connects the inputs automatically (Menu: Options -> autoconnect inputs to physical inputs), which is enabled by default. It could be that the capture nº1 is autoconnected to the first track, the capture nº2 to the second and so on.
But that's not an issue, you always have to check the connections. The ardour way is Menu: Windows -> Track/bus inspector. Select the input for the track you want to record into, then connect the capture device.
If you have qjackctl you can make these connections (Connect button, audio tab) just as easily.
I hope this helps
Pablo

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 2 days ago. Offline
Joined: 2008-02-27
Posts:

Yes it was very obvious, sorry for such a dumb post but I was so used to that Ardour would connect my inputs all automatically and thought that's the way it worked when launched, but I must of done something on my system that must of reset that setting. All is working well now, I only have another question, so when I create a stereo track I connect both channels to capture n°1? If I put them as Left > Capture n°1 and Right > Capture n°2 obviously Right will not record my guitar although it's a stereo I/O config, but if I record via PCM it will record via input n°2 also, why is that?

thorgal
User offline. Last seen 1 year 20 weeks ago. Offline
Joined: 2007-08-03
Posts:

maybe you have some hardware mixing behind your back ?

Pablo Fernández
User offline. Last seen 49 weeks 5 days ago. Offline
Joined: 2007-02-20
Posts:

Joe, not dumb post!
Unfortunately, they not teach Linux at school! And nobody knows it all! Don't hesitate to ask if you have doubts! I second what Thorgal says. Have you tried something? How is it going? If you don't seem to go ahead, it's better if you give info about your system, which audio card, which card mixer-controller software (alsa-mixer? envy24...?), which distro... Sorry if there is some broken English
Pablo

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 2 days ago. Offline
Joined: 2008-02-27
Posts:

Pablo Fernandez, thx for the help, don't worry about broken english to me it sounds perfect (ademas yo tambien hablo el español a la perfeccion, pero hay que hacer esto en ingles para que otros usuarios que tengan el mismo problema puedan identificarlo tambien :P ).

My distro is Ubuntu Feisty 32 bit.
Alsa
Soundcard not one of the best but enough to do it, it's an Audigy Sound Blaster (Line in, Digital, Firewire, etc)

Couple of days ago I recorded my guitar and it would sound well on both channels even on mono tracks, I noticed then omething changed and would only sound out through one (Left), noticed that recording via PCM would record both channels, but my line in would not, just as I would hear my guitar coming out from one side. So I openend the volume control panel on ubuntu and enabled all the sliders for my card to see them all, some don't do anything but I found an interesting one which is 3D control sigmatel switch and depth, is this the one to fiddle with for line in on my sound card to enable stereo? It doesn't do anything to PCM but it does to line in, by enabling it and putting the slider a little below half would make my guitar sound both channels and also record, maybe this is what got disabled in the past days, but I'm not sure, or am I just like fiddling with surround sound? All my other sliders are locked together and pushed all the way up (paired), so I don't know if it does have anything to do with that 3D sigmatel thing or not.

How do you guys have it?

Thx for all.

Pablo Fernández
User offline. Last seen 49 weeks 5 days ago. Offline
Joined: 2007-02-20
Posts:

Hola!
Are you familiar with Jack? do you run qjackctl? Ardour depends on jack. While running ardour Jack takes some control of your sound card. Do you know the "connect" button of qjackctl? Have you read this?: http://www.ardour.org/jack
Suerte!
Pablo

thorgal
User offline. Last seen 1 year 20 weeks ago. Offline
Joined: 2007-08-03
Posts:

hey! unless your instrument is outputting stereo, it will be hard to make a stereo track out of a mono input unless you connect an ardour stereo track to the same input twice (L and R channels connected to say system:capture1). But doing so will result in using twice the disk space because the same data will be written for each channel of the stereo track. You could make a mono track and simply add the mono-to-stereo splitter plugin in the post-fader if you really need a stereo output, or make two mono tracks and record twice the same guitar line (useful for acoustic guitar takes if you don't have two or more mics, sounds nice if you don't make too many mistakes).

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 2 days ago. Offline
Joined: 2008-02-27
Posts:

Well the thing is that my guitar is plugged into an fx pedal with stereo output (headphones) to line in in the soundcard, I still can't get the stero sound as before. Only if I connect to the mic in of the sound card I get stereo output and recording, but it's kinda noisy, I don't know where I went wrong but pluggin' into the line in I only hear my guitar on the left side and only records that channel, that's why I need to understand if the 3D sigmatel switch in alsa for audigy is the propper way to go to enable stereo or is it just a surround emulator, or should I just plug into mic in with low volumes so no hissing is picked up. How do you guys do it?

Thx

thorgal
User offline. Last seen 1 year 20 weeks ago. Offline
Joined: 2007-08-03
Posts:

two thoughts :
1- your cable (FX to line in) : is it stereo ?
2- line in : is it a stereo input ?

I am not familiar with your h/w but in my case, I record from mono sources. I play with stereo effects inside the DAW.

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 2 days ago. Offline
Joined: 2008-02-27
Posts:

Yes cable is stereo 3.5mm three sections I am not sure about line in in soundcard being stereo or not, but I connected a mono cable with on side being RCA tapped the RCA side with finger and only heard static noise on left side I am suspecting maybe my card went bad :( maybe overdriven and burnt the line in affecting right side because in mic in works well, both sides sound fine.

If I record with mic in is it valid or propper? I mean it's a high impedance connector creating huge amounts of hissing, I disable the +20DB boost so it's not so noisy, but I'm not sure if that's wrong, I think for these type of things you are supposed to use line in, but maybe I screwed up by plugging the phone out from FX to line in in soundcard, since it's a hot wired output to a low impedance input. I'm not sure, but I do know about a week ago I had stereo (both channels sounding) when hooking to line in.

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 2 days ago. Offline
Joined: 2008-02-27
Posts:

Ahhhh! I finally figured it all out.

Went to buy new 3.5mm cable and it's all working well now again, Something strange because as I mentioned before it sounded well in mic in but not in line in, new cable sounds well in both, maybe the new one is just a little wider or longer avoiding false contacts.

Sorry for all the trouble and thx for all your help.

:D

duffrecords
duffrecords's picture
User offline. Last seen 36 weeks 3 days ago. Offline
Joined: 2008-05-20
Posts:

Technically speaking, neither the mic in nor the line in is an ideal load to drive with a guitar. A guitar has relatively high output impedance but this impedance varies greatly depending on whether your pickups are stock or custom, and active or passive. Therefore, you shouldn't treat it as a line-level source (such as a CD player or a sampler). Plugging it into the mic input will almost certainly cause distortion and poor frequency response and risk damage to the soundcard if the guitar signal's voltage becomes too high. Plugging it into the line input will raise the noise floor, limiting your dynamic range, and it will accentuate the "antenna" effect of the guitar cable, picking up hum. The best way to do this (aside from miking an amp) is to plug the guitar into a direct box (preferably active) and feeding the direct box into the soundcard's mic input. The direct box will lower the guitar signal's impedance to an appropriate level for a microphone input.