Any way to get Ardour to work on 10.3.9 system?

3 replies [Last post]
robn
User offline. Last seen 6 years 1 week ago. Offline
Joined: 2008-04-07
Posts:

I have tried installing Jack (took 2 downloads for some reason, but now works fine) and Ardour on my powerbook G4, but Ardour will not load. X11 starts up but the prog never opens up. Here's what I get in console:

===== Mon Apr 07 2008 ===== 21:16:21 US/Central =====
jackd 0.101.3
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with POSIX SHM support.
loading driver ..
cannot read request from client (0/2104/Unknown error: 0)
could not handle external client request

XFree86 Version 4.3.0 / X Window System
(protocol Version 11, revision 0, vendor release 6600)
_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
[DRI] screen 0 installation complete
Screen 0 added: 1280x854 @ (0,0)
bash: no job control in this shell
2008-04-07 21:16:58.378 defaults[567]
The domain/default pair of (.GlobalPreferences, AppleCollationOrder) does not exist

Please excuse me if this is a stupid question. My usual DAW is Pro Tools (that should explain a lot, huh :)

robn
User offline. Last seen 6 years 1 week ago. Offline
Joined: 2008-04-07
Posts:

I was a little quick on the console copy. Here's the full listing:

===== Mon Apr 07 2008 ===== 21:16:21 US/Central =====
jackd 0.101.3
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with POSIX SHM support.
loading driver ..
cannot read request from client (0/2104/Unknown error: 0)
could not handle external client request

XFree86 Version 4.3.0 / X Window System
(protocol Version 11, revision 0, vendor release 6600)
_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
[DRI] screen 0 installation complete
Screen 0 added: 1280x854 @ (0,0)
bash: no job control in this shell
2008-04-07 21:16:58.378 defaults[567]
The domain/default pair of (.GlobalPreferences, AppleCollationOrder) does not exist
dyld: /Applications/Ardour2.app/Contents/Resources/bin/ardour Undefined symbols:
_wordexp
_wordfree
_vDSP_maxmgv
_vDSP_maxv
_vDSP_minv
_vDSP_vsma

paul
paul's picture
User offline. Last seen 1 day 13 hours ago. Offline
Joined: 2006-03-16
Posts:

Ardour does not run under 10.3.9. One of our developers spent quite a considerable amount of time trying to establish why it would not run/build correctly. In the end we decided that whatever the problem was, we could not justify more time investigating something that was clearly at least 50% Apple's fault. Sorry about this. If anyone ever does figure it out and comes up with a patch, we will be happy to use it.

Just out of interest, is there a reason you don't want to upgrade to at least Tiger?

robn
User offline. Last seen 6 years 1 week ago. Offline
Joined: 2008-04-07
Posts:

Yeah, I figured as much. I haven't upgraded because I got my powerbook right before tiger came out along with my Pro Tools rig. They work great together so I haven't really needed to upgrade quite yet. That being said, software updates (and any new programs and plugs) have my system showing it's age. I will probably have to upgrade to a newer system with dual processors as well as the newer OS. Thanks for the response.