how do I change gtk theme to the system default?

No replies
cb951303
User offline. Last seen 5 years 48 weeks ago. Offline
Joined: 2008-05-15
Posts:

well the title says it all :)
is there a way to force ardour to use the default system gtk theme?

if no how do I change the font size? thanks very much

nowhiskey
User offline. Last seen 4 weeks 1 day ago. Offline
Joined: 2006-09-30
Posts:

menu->window->preferences->misc. tab->font scaling

cheers,
doc

paul
paul's picture
User offline. Last seen 9 hours 31 min ago. Offline
Joined: 2006-03-16
Posts:

you almost certainly do not want the system default theme. ardour relies on the use of color to indicate various states (rec-enable, solo, mute etc) that become VERY much less obvious with the system theme(s). if you would prefer a lighter theme, go to Windows -> Theme Manager and switch it there.

if you do want the system default theme, you will need to set the environment variable ARDOUR2_UI_RC to /dev/null.

alkos333
User offline. Last seen 5 years 29 weeks ago. Offline
Joined: 2008-09-17
Posts:

Where exactly do you change this variable? I want to give it a try and see what it looks like. If I like it, then I'll start using it from the start to get used to the colors and if doesn't work out, I can always switch to the default.

vervelover
vervelover's picture
User offline. Last seen 1 week 2 days ago. Offline
Joined: 2009-06-10
Posts:

I'm as well interested in this. Where are you supposed to set this variable?