Total lock-up/X-run city

4 replies [Last post]
Lost_Highway
User offline. Last seen 7 weeks 1 day ago. Offline
Joined: 2006-03-29
Posts:

This used to happen occasionally with the version I was using under DeMuDi 1.2.1 (beta29 I think it was) but with the version that ships with DeMuDi 1.3 (I think it's 0.99.3) it is making Ardour completely unusable...

Ardour will work fine for a while, anywhere from seconds to minutes, sometimes longer. I'm currently working on a very intensive session (it's very slowly nearing completion) -- the DSP load is up at around 80% when it's stable.

But all of a sudden the DSP load will just creep up and up and up to nearly 100% and then playback stops and the playhead crawls along. I've just looked at Jack and even when Ardour's transport is stopped, Jack is registering literally thousands of Xruns, the messages screen just keeps on cycling rapidly.

I've just managed to listen to the track all the way through from the beginning -- about three minutes in the Xruns started, at roughly the same point in the piece that I've been jumping straight to recently.

Ardour's been stopped severl minutes now and still the Xruns keep coming. What's going on? How do I stop it?

paul
paul's picture
User offline. Last seen 1 hour 14 min ago. Offline
Joined: 2006-03-16
Posts:

what plugins are you using, if any?

and you are running JACK in realtime mode, yes?

sampo
User offline. Last seen 10 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

See http://www.ardour.org/node/139

Lost_Highway
User offline. Last seen 7 weeks 1 day ago. Offline
Joined: 2006-03-29
Posts:

Many apologies for the "hit and run": I've been unable to devote any time to music for the past two weeks but now I'm back.

Yes, Jack is running in realtime mode -- is that good or bad?

Yes, I am using a lot of plugins. You might have noticed the other topic I started about rising noise levels on the master channel -- I found the cause of this is always the Triple Parametric with Shelves EQ plug that I have on nearly every track.

Many tracks are also running one or more of the following: TAP Reverberator, SC1 compressor, Plate Reverb, Glame High Pass and Low Pass filters (I've recently substituted a few Triple Para w/Shelves for these).

Cheers

qb

Lost_Highway
User offline. Last seen 7 weeks 1 day ago. Offline
Joined: 2006-03-29
Posts:

I've now done a bit of investigation and it was two instances of the GLame High Pass plugin (which I only recently put in to overcome problems with the Triple Band Parametric with shelves) that was responsible for all the Xruns and a 30--40% spike in processor usage!

qb