Recording was stopped because your system could not keep up.

No replies
valer
User offline. Last seen 5 years 36 weeks ago. Offline
Joined: 2008-07-15
Posts:

I've just installed Ardour 2.3 and qjackctl 0.3.2 on a Dell Inspiron 1420 (Intel Core2 Duo T5550 @ 1.83GHz with 4GB memory) running Ubuntu 8.04 with the 2.6.24-19-rt kernel.

When I attempt to record a track, it immediately gives me this error:
"Recording was stopped because your system could not keep up."

I would imagine this is an issue with my settings, either in Ardour or Jack. Any recommendations? I didn't see too many postings with this error message. Thanks.

valer
User offline. Last seen 5 years 36 weeks ago. Offline
Joined: 2008-07-15
Posts:

I am still getting this error “Recording was stopped because your system could not keep up.”

I have upgraded Ardour to version 2.4.1

I have added the following to /etc/security/limits.conf
@audio - memlock unlimited
@audio - nice -19

I have the sample rates set the same in jack and ardour.

This is very frustrating - I don't want to go back to CoolEdit.
Can anybody offer any suggestions?

philip8888
philip8888's picture
User offline. Last seen 1 year 3 days ago. Offline
Joined: 2007-03-30
Posts:

Try adding the below code to your /etc/security/limits.conf just like you see and save it.

@audio - rtprio 99
@audio - nice -19

@audio hard memlock unlimited
@audio soft memlock unlimited

I am not familiar with Buntu so I can't help you there.

But a couple of questions for you.

Are there any other RT kernel patches the you are missing or have not installed?

And have you installed the Ubuntu Studio Audio Package?

Please post back when you can.

peder
User offline. Last seen 48 weeks 6 days ago. Offline
Joined: 2007-05-08
Posts:

It shouldn't have anything to do with the limits values, but more likely something with the harddrive.
See this thread: http://ardour.org/node/1941

valer
User offline. Last seen 5 years 36 weeks ago. Offline
Joined: 2008-07-15
Posts:

Thank you for your responses. I do suspect that it has something to do with the harddrive or cheap soundcard, but to exhaust all possibilities, I have added the limits.conf entries and checked my kernel patches.

I found the following connection between xrun and my error message:

ARDOUR_UI::halt_on_xrun_message ()
{
ENSURE_GUI_THREAD (mem_fun(*this, &ARDOUR_UI::halt_on_xrun_message));

MessageDialog msg (*editor,
_("Recording was stopped because your system could not keep up."));
msg.run ();
}

My system is generating xruns. I have tried to increase the Frames/Period setting in Jack to a higher number, per suggestion from:
http://www.ubustu.com/globe/2007/05/29/how-to-configure-jack-in-ubuntu-studio/

Per the following thread, it sounds like this has been a problem for others who have upgraded to the kernel instead of installing Ubuntu Studio cleanly (I upgraded to the rt kernel):
http://ubuntuforums.org/showthread.php?t=603543

Unless there are any more suggestions, looks like I may need to resort to a fresh install of Ubuntu Studio.

Additional info that may be helpful:

$ lspci -vv | grep -A 8 Audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
Subsystem: Dell Inspiron 1420
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- SERR-

$ sudo hdparm -t /dev/sda
/dev/sda:
Timing buffered disk reads: 190 MB in 3.00 seconds = 63.30 MB/sec

$ sudo hdparm -T /dev/sda
/dev/sda:
Timing cached reads: 2024 MB in 2.00 seconds = 1012.09 MB/sec

Again, thanks for any suggestions.

peder
User offline. Last seen 48 weeks 6 days ago. Offline
Joined: 2007-05-08
Posts:

And just to make sure: you are running jack realtime and you have added yourself to the audio group (and rebooted/re-logged in)?
Also, intel soundcards usually needs to be run with periods/buffer=3 to be happy.

There's also a setting in ardour to allow you to continue running even in case of xruns.

valer
User offline. Last seen 5 years 36 weeks ago. Offline
Joined: 2008-07-15
Posts:

Thanks for the suggestions. I found the setting to allow Ardour to continue running despite the xrun's and that seemed to do the trick. At least I can record now.

Do you happen to know what the negative side affects are to recording despite the xrun's? I seem to get them immediately upon starting Jack, no matter how high I set the Frames/Period setting.

Thanks again for your help so far.

peder
User offline. Last seen 48 weeks 6 days ago. Offline
Joined: 2007-05-08
Posts:

The drawback is loss of input.

(caveat: this might be technically slightly inaccurate but I think the overall effects are true)
The xrun happens when the soundcard can't deliver the data to the disk fast enough. What happens is that the data gets discarded, so if you're recording your latest (pressumed to be) million dollar selling album you really don't want xruns at all.
If you're doing a demo for personal use you can probably live with the small glitches.

wizard
User offline. Last seen 1 year 6 weeks ago. Offline
Joined: 2008-03-25
Posts:

make sure the r_limits are installed and the user a member of audio group