Ardour can't connect to other soft/hard ware (in qjackctl)

5 replies [Last post]
irok84
User offline. Last seen 4 years 44 weeks ago. Offline
Joined: 2008-10-22
Posts:

Welcome!

I have some problem:

I'm using ardour2 with polish interface language. In qjackctl inputs of ardour are named like on this screen: http://rymy.com.pl/ard.png.

When i'm tying to connect other software/hardware to ardour2 then jack displays error:

unknown destination port in attempted connection [ardour:główna/wejście 1]

I think, it's problem with this bad encoding od polish characters.

Do you know how to change names of ardour2 inputs, or how to change ardour2 language to english? Maybe You know some other fix of this problem?

paul
paul's picture
User offline. Last seen 58 min 52 sec ago. Offline
Joined: 2006-03-16
Posts:

1) you can edit the names of the ports in the session (*.ardour) file using a regular text editor.

2) setting en_US.UTF-8 in your environment will cause Ardour (and other programs to use English)

3) please file a bug report about this in our Bug/Issue tracker. My guess it that we should not translate port name "templates" like "input_%d".

irok84
User offline. Last seen 4 years 44 weeks ago. Offline
Joined: 2008-10-22
Posts:

Point 1 is only partial solution (for temporary use).

Point 2.. hmmm.... I can't change language for other programs. Only ardour

Point 3 - reported (http://tracker.ardour.org/view.php?id=2426)

Pablo Fernández
User offline. Last seen 50 weeks 6 days ago. Offline
Joined: 2007-02-20
Posts:

Point 2: You can use the language prefix to launch ardour in English:
$ LANG=en_US.UTF-8 /usr/bin/ardour2

irok84
User offline. Last seen 4 years 44 weeks ago. Offline
Joined: 2008-10-22
Posts:

thanks Pablo Fernández.

salman22
User offline. Last seen 5 years 26 weeks ago. Offline
Joined: 2008-10-25
Posts:

This is a TEST Comment
Salman Khan
Salman Khan
http://www.google.com/