ardour 2.6 packaged for debian and ubuntu (w/ user packaged VST)

13 replies [Last post]
oggei
oggei's picture
User offline. Last seen 5 years 16 weeks ago. Offline
Joined: 2008-10-11
Posts:

Hi, just dropping a line for let you know that i've uploaded the couple on my repository:

While i have to translate the repository specific page, i think it's anyway pretty straightforward:

* https://www.scimmia.net/code/wiki/DebianRepository

OTOH, translated instructions for (easily) building a vst enabled ardour 2.6 are here:

* https://www.scimmia.net/code/wiki/DebianPackages/ArdourVst

hope this helps, ciao

paul
paul's picture
User offline. Last seen 1 day 8 hours ago. Offline
Joined: 2006-03-16
Posts:

good work, but 2.6.1 is just about to roll! :))

oggei
oggei's picture
User offline. Last seen 5 years 16 weeks ago. Offline
Joined: 2008-10-11
Posts:

Argh :P

so let's rebuild them :))

just uploaded debian one and ubuntu is on the way, love pkg factories

ciao,

GMaq
GMaq's picture
User offline. Last seen 13 hours 47 min ago. Offline
Joined: 2007-12-11
Posts:

oggei,

At this point I'm afraid to ask, but how were you able to solve the Wine "Window Nesting" issue? It would be useful info for other distros.

rozea
User offline. Last seen 16 weeks 1 day ago. Offline
Joined: 2008-09-23
Posts:

Thanks. Is LV2 enabled?

About your project, do you also have a realtime kernel for Debian?

DeathByGuitar
User offline. Last seen 5 years 21 weeks ago. Offline
Joined: 2007-04-22
Posts:

linux n00b question:

So this means the Ubuntu respositories have 2.6 in it right now? I freaking hate compiling it.

Seb
Seb's picture
User offline. Last seen 2 days 2 hours ago. Offline
Joined: 2006-04-07
Posts:

n00b answer: it's not ion the official ubuntu repositories. The new ubuntu version is coming out just about now so it'll be 6 months before they put it in. But this guy oggei has made an "inofficial" repository which you can add to your package sources, and thus use oggei's build instead of Ubuntu's official, without compiling the lot.

I'll try that this afternoon, or maybe i'll compile my own anyway (because i freakin love it!)

oggei
oggei's picture
User offline. Last seen 5 years 16 weeks ago. Offline
Joined: 2008-10-11
Posts:

@gmaq: i can't fix this problem just relinking to "wine version that works on gmaq desktop", so we'll have to wait for ardour devs to fix it ... it's the only feasible way :-)

@rozea: no for now it isn't compiled against lv2 libs, as they aren't available on debian and so i should adopt them before ... while i'll have some more spare time to dedicate, i'll eventually investigate, feel free to file a ticket on my trac.
For realtime kernel, is on the way, i'm building a decent factory cause i have to maintain at least a 5/6 packages on 2 arches, and also lot of patched modules (most notably, nvidia that doesn't work with -mingo).

@DeathByGuitar: add "gonzy" repositories to your plain ubuntu distro and enjoy

@seb: thank you :)

mirami
User offline. Last seen 3 years 1 week ago. Offline
Joined: 2008-03-19
Posts:

I was building LV2 enabled with these debian packages...
http://download.drobilla.net/debian/dists/sid/main/binary-i386/

mirami

rozea
User offline. Last seen 16 weeks 1 day ago. Offline
Joined: 2008-09-23
Posts:

CAn I use this repro for Ubuntu Hardy?

I have problems with the key:

sudo wget http://www.scimmia.net/debian/pubkey.asc -O - | apt-key add -
--14:13:35-- http://www.scimmia.net/debian/pubkey.asc
=> `-'
Resolving www.scimmia.net... 92.243.12.138
Connecting to www.scimmia.net|92.243.12.138|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1,799 (1.8K) [text/plain]

100%[====================================>] 1,799 --.--K/s

14:13:35 (69.86 MB/s) - `-' saved [1799/1799]

gpg: no writable keyring found: eof
gpg: error reading `-': general error
gpg: import from `-' failed: general error

thorgal
User offline. Last seen 1 year 21 weeks ago. Offline
Joined: 2007-08-03
Posts:

rozea, it's because your 'sudo' is misplaced. You should do this :

wget blabla | sudo apt-key add -

sudo wget is not recommended ;)

rozea
User offline. Last seen 16 weeks 1 day ago. Offline
Joined: 2008-09-23
Posts:

@thorgal, thanks

But it doesn't work on Ubuntu hardy... ? Or is it possible and advisible to install the dependencies?

The following packages have unmet dependencies:
ardour: Depends: libasound2 (> 1.0.17) but 1.0.15-3ubuntu4 is to be installed
Depends: libgtk2.0-0 (>= 2.14.1) but 2.12.9-3ubuntu5 is to be installed
Depends: liblo0ldbl (>= 0.23) but it is not installable
Depends: libpango1.0-0 (>= 1.21.6) but 1.20.5-0ubuntu1 is to be installed

thorgal
User offline. Last seen 1 year 21 weeks ago. Offline
Joined: 2007-08-03
Posts:

I don't know, I use debian sid and always compile ardour myself. I usually don't respect strict lib dependencies because I use quite a few custom compiled softwares. Things I usually keep in line with the repos are system packages and ALSA is definitely one of them. Kernel is an exception, it needs tailoring. But at the application level (end user programs), I am not so strict.

oggei
oggei's picture
User offline. Last seen 5 years 16 weeks ago. Offline
Joined: 2008-10-11
Posts:

@rozea: no, ubuntu bin packs are for intrepid ibex so using in other version is very YMMV (and doesn't work in this case)

The real sense of redoing ardour package is, apart eliminating horrors from ubuntu/debian maintainers, having a simple way to produce binary packages with and without vst support that can cohexists nicely on the same system: that is, i face system setup and similar question because i know how, you use that and enjoy.

So feel free to put repository and go on with building instructions, or switch to intrepid :)

ciao