ardour 2.6.1 install question

No replies
jaskah
User offline. Last seen 1 day 18 hours ago. Offline
Joined: 2006-05-01
Posts:

hello
i am trying to upgrade to ardour 2.6.1 from v. 2.5.
my only problem is with the libasound2-dev library, which i can't install as it requires libasound2 library v. 1.0.16-2ubuntu1, which is actually part of the ubuntu unstable "intrepid" package. i am currently running ubuntu "hardy" (8.04).
my question: has anyone successfully installed ardour 2.6.1 on ubuntu 8.04?
i ask, as it seems i will also need to install a new version of libc6, which seems like something pretty central to the rest of the operating system. i just don't want to get into any system-wide conflicts for this update.
thanks in advance for any help!

jaskah
User offline. Last seen 1 day 18 hours ago. Offline
Joined: 2006-05-01
Posts:

hello again
i've now installed what i thought to be all depenencies but now get the following read out in
the terminal when i run scons:

Checking for C header file fftw3.h... yes
Checking for usb_interrupt_write() in C library usb... no
Checking for C header file linux/input.h... yes
Checking for FLAC__seekable_stream_decoder_init() in C++ library FLAC... no
Checking for C++ header file boost/shared_ptr.hpp... no
Boost header files do not appear to be installed. You also might be running a buggy
version of scons. Try scons 0.97 if you can.

i already have scon 0.97 installed. i am running ubuntu 8.04
does anyone know how i can resolve these error messages?
thanks in advance for any help on this.

sebos69
User offline. Last seen 4 years 38 weeks ago. Offline
Joined: 2007-05-21
Posts:

Boost header files do not appear to be installed.

so, as it says, you should install boost-dev

jaskah
User offline. Last seen 1 day 18 hours ago. Offline
Joined: 2006-05-01
Posts:

hi
thanks very much for your reply. this fixed it... i didn't realize that header files referred to the development package.
now everything installed great and ardour appears to be running without any problems.