Frontent Message: System is to slow to play.

No replies
Undefined
Undefined's picture
User offline. Last seen 2 years 2 hours ago. Offline
Joined: 2008-11-23
Posts:

If you get this starttup Message ...

WARNING: Your system has a limit for maximum amount of locked memory!
         This might cause Ardour to run out of memory before your system runs
         out of memory. You can view the memory limit with 'ulimit -l', and it
         is normally controlled by /etc/security/limits.conf

... or ardour says System to slow when click the play button.
The followed Configuration fix this Problem.
Create Subdir /etc/security/limits.d/ and save ardour2.conf File.
Add your group Name e.g. audio to the limit configuration.

# /etc/security/limits.d/ardour2.conf
#####################################################
# @see Manpages limits.conf pam_limits
# @short add new group @audio
# NOTE pam.d/xdm:pam_limits.so must add
#####################################################
@audio soft memlock 64
@audio hard memlock 96

Set Module pam_limits.so to /etc/pam.d/xdm* Session Configuration

#%PAM-1.0
auth include common-auth
account include common-account
password include common-password
session required pam_loginuid.so
session include common-session
session required pam_resmgr.so
#####################################################
# @since 2008/11/23
# @see /etc/security/limits.d/ardour2.conf
session required pam_limits.so debug

relogin and check the Debugging output

*> grep pam /var/log/messages
... pam_limits(xdm:session): reading settings from '/etc/security/limits.conf'
... pam_limits(xdm:session): reading settings from '/etc/security/limits.d/ardour2.conf'
... pam_limits(xdm:session): checking if undefined is in group audio
... pam_limits(xdm:session): process_limit: processing soft memlock 64 for GROUP
... pam_limits(xdm:session): checking if undefined is in group audio
... pam_limits(xdm:session): process_limit: processing hard memlock 96 for GROUP

you can check with ulimit -l if new configuration exists