Ardour updates on Ubuntu

20 replies [Last post]
heminder
heminder's picture
User offline. Last seen 1 year 27 weeks ago. Offline
Joined: 2008-02-06
Posts:

hey.

i've got an Ubuntu Studio install (8.04, Hardy Heron), and recently checked to see that it came with Ardour 2.3. i'd like to update to the latest version (2.7 as of now) but it would be annoying if i had to compile and install it every time there was a patched release. is there a repository i could add to the list in Synaptic Package Manager such that updates would happen automatically?

i noticed Ardour have a project page on Launchpad https://launchpad.net/ardour
i'm a bit of a linux noob, and i think it would make things quite a bit easier.
i'd rather stick with free software than resort to using Windoze or Mac.

:)

GMaq
GMaq's picture
User offline. Last seen 2 hours 6 min ago. Offline
Joined: 2007-12-11
Posts:

Hi,

Two of the best places I know (for Ubuntu)of are www.getdeb.net or http://archive.ematech.fr/ a great repository that does what Ubuntu Studio SHOULD be doing.

Usually new releases are out in a few weeks.

rozea
User offline. Last seen 15 weeks 6 days ago. Offline
Joined: 2008-09-23
Posts:

thanks for the links.

How do you make an Ubuntu pacakage for Ardour?

[code]dpkg-buildpackage -rfakeroot[/code]

seems to fail, has it something to do with scons?

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 3 days ago. Offline
Joined: 2008-02-27
Posts:

Read here (at bottom):

http://ardour.org/node/1947

heminder
heminder's picture
User offline. Last seen 1 year 27 weeks ago. Offline
Joined: 2008-02-06
Posts:

cool.
i've added the EMA Tech repository in synaptic, and installed all the "updates", and now using Ardour 2.6 and jack 0.3.3. problem now is that at first jack wouldn't start, so i ran this command:
sudo su -c 'echo @audio - rtprio 99 >> /etc/security/limits.conf'
(from ubuntu forums, op isn't me - http://ubuntuforums.org/showthread.php?t=453486)
logged out/in and started jack again.
it seems to work, but i get xruns a lot more often than i used to. and when i stop and quit jack, any other audio fails to play. 'sudo alsa force-reload' doesn't help.
help.

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 3 days ago. Offline
Joined: 2008-02-27
Posts:

/etc/security/limits.conf file should have this:

@audio - rtprio 100
@audio - nice -10 (This one I have seen quite varied some do it at -15 other at -10)
@audio - memlock unlimited

if not edit and reboot machine.

heminder
heminder's picture
User offline. Last seen 1 year 27 weeks ago. Offline
Joined: 2008-02-06
Posts:

thanks, everything jack and ardour related seems to be working properly.

but i still can't get my normal sound back :P
Banshee media player refuses to play, and there's out of sync sound from pidgin.
audacious, and totem won't play anything either.

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 3 days ago. Offline
Joined: 2008-02-27
Posts:

hmmmm, never had that type of issue, I'm also on Hardy.

On your sound preferences for gnome all setup to alsa?

heminder
heminder's picture
User offline. Last seen 1 year 27 weeks ago. Offline
Joined: 2008-02-06
Posts:

they were on "Autodetect". changed to ALSA, all is working. silly me.
thanks a million.

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 3 days ago. Offline
Joined: 2008-02-27
Posts:

Ok, good to hear. BTW, selecting all to ALSA in those preferences disables pulseaudio. Pusleaudio is only loaded when a user logs in to his/her account. If pulseaudio was loaded as a system default it would be more of a hassle to disable it.

heminder
heminder's picture
User offline. Last seen 1 year 27 weeks ago. Offline
Joined: 2008-02-06
Posts:

pulseaudio fails on my computer. i have my applications set to use ALSA. if i select their pulseaudio option, i get no sound.

i had a go at compiling Ardour 2.7 from the source tarball, but it keeps giving me errors. someone know what's wrong?

heminder@Haspire:/usr/local/src/ardour-2.7$ sudo checkinstall scons FREESOUND=1 install -D

checkinstall 1.6.1, Copyright 2002 Felipe Eduardo Sanchez Diaz Duran
This software is released under the GNU GPL.

*****************************************
**** Debian package creation selected ***
*****************************************

This package will be built according to these values:

0 - Maintainer: [ root@Haspire ]
1 - Summary: [ lol? ]
2 - Name: [ ardour ]
3 - Version: [ 2.7 ]
4 - Release: [ 1 ]
5 - License: [ GPL ]
6 - Group: [ checkinstall ]
7 - Architecture: [ i386 ]
8 - Source location: [ ardour-2.7 ]
9 - Alternate source location: [ ]
10 - Requires: [ ]

Enter a number to change any of them or press ENTER to continue:

Installing with scons FREESOUND=1 install -D...

========================= Installation results ===========================
scons: Entering directory `/usr/local/src/ardour-2.7'
scons: Reading SConscript files ...
Checking for pkg-config version >= 0.8.0... yes
Checking for gthread-2.0... yes
Checking for lrdf... yes
Checking for libgnomecanvas-2.0... yes
Checking for gtk+-2.0... yes
Checking for jack... yes
Checking for samplerate... yes
Checking for glib-2.0... yes
Checking for libxml-2.0... yes
Checking for raptor... yes
Checking for fftw3f...yes
Checking for fftw3...yes
Checking for aubio...yes
Checking for C header file fftw3.h... yes
Checking for C header file curl/curl.h... yes
Checking for slv2... no
LV2 support is not enabled (SLV2 not found or older than 0.6.0)
WIIMOTE not enabled. Build with 'scons WIIMOTE=1' to enable support.
Congratulations, you have a functioning C++ compiler.
system triple: i686-pc-linux-gnu

*******************************
detected DIST_TARGET = i686
*******************************

Checking for C header file fftw3.h... yes
Checking for usb_interrupt_write() in C library usb... no
Checking for C header file linux/input.h... yes
Checking for FLAC__seekable_stream_decoder_init() in C++ library FLAC... no
Checking for C++ header file boost/shared_ptr.hpp... yes
Checking for lo_server_new() in C library lo... no
liblo does not appear to be installed.

**** Installation failed. Aborting package creation.

Cleaning up...OK

Bye.

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 3 days ago. Offline
Joined: 2008-02-27
Posts:

First you have to configure before building and installing, GMaq showed me how to build deb with scons, but fisrst build, easy steps:

1) scons FREESOUND=1

will take a while.....then after do:

2) sudo checkinstall scons install -D

remember to give your deb a version number before it starts building it (Thx GMaq).

building deb will take a loooooong while also.

Luck!

GMaq
GMaq's picture
User offline. Last seen 2 hours 6 min ago. Offline
Joined: 2007-12-11
Posts:

Hi,

To install Ardour cd to your source folder and do "scons FREESOUND=1" (without quotes) if you don't have any dependency problems the scons script will configure and make Ardour. After Ardour has built correctly you then install it with checkinstall by typing "sudo checkinstall scons install -D" (without quotes)

**EDIT**
Looks like Joe typed faster!

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 3 days ago. Offline
Joined: 2008-02-27
Posts:

Ah! well, there you go, GMaq just posted to legally backup my support

;)

heminder
heminder's picture
User offline. Last seen 1 year 27 weeks ago. Offline
Joined: 2008-02-06
Posts:

ok, did the first step, and it didn't stop for any error messages, but after looking at the config.log, i saw bits like this:

...

file /usr/local/src/ardour-2.7/SConstruct,line 569:
Configure(confdir = .sconf_temp)
scons: Configure: Checking for slv2...
pkg-config --atleast-version=0.6.1 slv2
close failed: [Errno 9] Bad file descriptor
scons: Configure: no

file /usr/local/src/ardour-2.7/SConstruct,line 632:
Configure(confdir = .sconf_temp)
g++ --version
g++ (GCC) 4.2.4 (Ubuntu 4.2.4-1ubuntu3)
Copyright (C) 2007 [blah...]

close failed: [Errno 9] Bad file descriptor

...

scons: Configure: Checking for C header file /System/Library/Frameworks/CoreMIDI.framework/Headers/CoreMIDI.h...
.sconf_temp/conftest_40.c
|
|#include "/System/Library/Frameworks/CoreMIDI.framework/Headers/CoreMIDI.h"
|
|
gcc -o .sconf_temp/conftest_40.o -c -O3 -fomit-frame-pointer -ffast-math -fstrength-reduce -pipe -DARCH_X86 -mmmx -march=i686 -msse -mfpmath=sse -DUSE_XMMINTRIN -DBUILD_SSE_OPTIMIZATIONS -Wall -DHAVE_LIBLO -Ilibs -DENABLE_NLS -D_REENTRANT -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -Ilibs/surfaces/control_protocol -Ilibs/ardour .sconf_temp/conftest_40.c
.sconf_temp/conftest_40.c:2:76: error: /System/Library/Frameworks/CoreMIDI.framework/Headers/CoreMIDI.h: No such file or directory
close failed: [Errno 9] Bad file descriptor
scons: Configure: no

...

is this something i should go back and fix before moving on ?

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 3 days ago. Offline
Joined: 2008-02-27
Posts:

you will have to download and compile lates slv2. remove the one fron synaptic first if already installed, then go here to download:

http://drobilla.net/software/slv2/

but this is not a MUST, only if you want to copile with LV2 plugin support.

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 3 days ago. Offline
Joined: 2008-02-27
Posts:

Now that I remember I think slv2 is not included in synaptic just LV2core, don't remember, correct me if wrong, but I wanted to use lv2 plugins so I had to download the slv2 source from link I gave you above.

heminder
heminder's picture
User offline. Last seen 1 year 27 weeks ago. Offline
Joined: 2008-02-06
Posts:

heh, yeh i was just compiling it as i read your post.
so i've done that, and it's solved.

i'm getting:
...
Checking for FLAC__seekable_stream_decoder_init() in C++ library FLAC... no
...

and

...
Checking for C function gtk_widget_set_tooltip_text()... yes

scons: warning: Ignoring missing SConscript 'manual/SConscript'
File "/usr/local/src/ardour-2.7/SConstruct", line 1429, in [module]
...
(the [module] is in greater than / less than brackets)

i have libflac and libflac++ libraries installed (including -dev verions).
and i've got no idea what the second one is about...

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 3 days ago. Offline
Joined: 2008-02-27
Posts:

Ok, ignore the config error log for now and try to build.

heminder
heminder's picture
User offline. Last seen 1 year 27 weeks ago. Offline
Joined: 2008-02-06
Posts:

installed successfully, but can't import FLAC files (doesn't recognize them).
it's not a big issue i guess.

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 3 days ago. Offline
Joined: 2008-02-27
Posts:

Ok, good, the important thing is you don't get errors at compiling+building and then it stops because of them, just so it will install succesfully despite all the errors in the build log. Flac probably isn't installed in proper prefix or wrong version, or you dont have the flac devel packages (if any neeed in ardour), check repos I think they are there somewhere.........