which control surface?

15 replies [Last post]
A1
User offline. Last seen 5 years 9 weeks ago. Offline
Joined: 2008-04-17
Posts:

I want to buy a control surface for Ardour, and I want to know if automation can be updated with the BCF2000 even though it doesn't have touch faders.

I would also like to know if there is any control surface that Adour supports, and can assign and edit plugins.

Any suggestions about any control surface that Ardour supports?

paul
paul's picture
User offline. Last seen 2 days 17 hours ago. Offline
Joined: 2006-03-16
Posts:

all surfaces that generate MIDI CC's can be used to control plugins.

half_monkey
User offline. Last seen 51 weeks 1 day ago. Offline
Joined: 2008-11-04
Posts:

I recently bought a yamaha promix 01 off ebay for not a lot of dollar, and that seems to work ok as a control surface. Doesn't have any transport controls though.

allank
allank's picture
User offline. Last seen 5 weeks 6 days ago. Offline
Joined: 2006-12-07
Posts:

I have been happily using the BCF for all of those function sfor quite a while now..

rooker
rooker's picture
User offline. Last seen 1 week 4 days ago. Offline
Joined: 2009-03-03
Posts:

Hi.
I'm also quite interested in remote-controlling Ardour and would write a serial-pyio proxy in order to use monome devices.

However, I can't find the MIDI mapping specifications anywhere. If someone could point me into the right direction, that'd be awesome.

Thanks in advance.

anechoic
User offline. Last seen 1 year 19 weeks ago. Offline
Joined: 2009-01-05
Posts:

MIDI FADER BOX -> MIXER QUESTION

my config
===========
Ubuntu 8.10
Jack 0.3.2
Ardour 2.5 (3525)

=========================

I'm using a Doepfer Pocket Fader connected to a MOTU Fastlane

the Fastlane MIDI interface shows up in Jack when connected
I created a connection in Output panel as follows:
Client: Fastlane
Port A

then set up the Input panel:

Client: Input
plug: control

q1: is this correct?

then...

in Ardour under Options/Control Surfaces
I selected:
Remote ID assigned by user
(also tried 'Remote ID follows order of Mixer')
Generic MIDI
Controls Feedback=true

next I adjusted the MIDI settings in Window/Prefs/MIDI panel
and clicked on 'control' and the 'Trace Input'
MTC, MMC and MIDI param contrl are all white
mcu and seq are turned off since I'm not using them

then I opened the mixer and clicked ctrl + middle mouse button
a hint came up with 'operate controller now'
moved a slider on Doepfer
and nothing

I looked in the manual and Googled but haven't found anything that seems to point me to the right set of instructions

questions:
===========
- what channel should MIDI CC information be coming in on?
- does the CC# follow the fader number? i.e. 1-16?
- or can this be set somewhere?

- how can I see if I'm getting MIDI into Ardour and/or Jack?
- is there a LED or indicator somewhere?

allank
allank's picture
User offline. Last seen 5 weeks 6 days ago. Offline
Joined: 2006-12-07
Posts:

Ardour doesn't care what MIDI channel or CC number you send on.

I'm not quite sure what you mean by "output panel" is this an OSX thing??

Simply in qjackctl (or equivalent) you can create a connection from the output port of your Doepfer to the "Control" input of Ardour.

If the device has some sort of feedback (automation, or LED's to indicate position) then I would recommend also connecting the "Control" output of Ardour to the input of the device.

Also, to see incoming MIDI go into the Edit -> preferences menu and on the MIDI tab you will see the buttons to press that will display MIDI input. You must have started ardour from command line, in this shell you will see all the MIDI information streaming... (There will be quite a bit).

anechoic
User offline. Last seen 1 year 19 weeks ago. Offline
Joined: 2009-01-05
Posts:

@Alan
thanks for your help! :)
to clear up some things:

//Ardour doesn’t care what MIDI channel or CC number you send on.
:::OK so Ardour sees the midi as if it were coming in as omni mode?

and Ardour just allows you to grab whatever midi is coming in when you crtl + middle click the fader on the mixer?

//I’m not quite sure what you mean by “output panel” is this an OSX thing??
:::no I'm working in Ubuntu as stated
but it is the 'Output Sockets/Plugs' panel in Jack Patchbay

//Simply in qjackctl (or equivalent) you can create a connection from the output port of your Doepfer to the “Control” input of Ardour.
:::yes I have done this as pointed out in my post
but I dont think I'm getting midi in
although my Fastlane midi I/O does come up in Jack

//If the device has some sort of feedback (automation, or LED’s to indicate position) then I would recommend also connecting the “Control” output of Ardour to the input of the device.
:::Pocket Fader is a plain vanilla midi fader box
all channel and CC# settings are set with DIP switches on the back

//Also, to see incoming MIDI go into the Edit -> preferences menu
::: in the Linux Ardour the prefs are under the Window menu pull down in Prefs or Alt-O

//and on the MIDI tab you will see the buttons to press that will display MIDI input.
:::I.m not clear on what you mean here...does this mean that the little orange square in the midi panel acts as an indicator?

//You must have started ardour from command line, in this shell you will see all the MIDI information streaming… (There will be quite a bit)
:::are you saying that the terminal is where the midi data can be seen and that I need to start Ardour from the command line?

thanks again for your response! :)

allank
allank's picture
User offline. Last seen 5 weeks 6 days ago. Offline
Joined: 2006-12-07
Posts:

:::OK so Ardour sees the midi as if it were coming in as omni mode?

and Ardour just allows you to grab whatever midi is coming in when you crtl + middle click the fader on the mixer?

Exactly.

//and on the MIDI tab you will see the buttons to press that will display MIDI input.
:::I.m not clear on what you mean here…does this mean that the little orange square in the midi panel acts as an indicator?

Press on the orange square, it simply acts as a button and you will see the MIDI messages in terminal.

//You must have started ardour from command line, in this shell you will see all the MIDI information streaming… (There will be quite a bit)
:::are you saying that the terminal is where the midi data can be seen and that I need to start Ardour from the command line?

That's exactly what I am saying.

If you are on the ardour-users ML then send a message to me via there and I'll get your email address to send you back some screenshots..

allank
allank's picture
User offline. Last seen 5 weeks 6 days ago. Offline
Joined: 2006-12-07
Posts:

Not for another 8 hours or so, I'm at work on a stupid vista box..

anechoic
User offline. Last seen 1 year 19 weeks ago. Offline
Joined: 2009-01-05
Posts:

yeah somethings not giving up the love here
but not sure where the problem is

the messages in the Jack window look encouraging but I still can't tell if I'm getting midi in

I started 'ardour2' from the command line
turned on the trace input and trace output in the midi panel of prefs
twiddled the midi faders and still nada
I also tried
cat /dev/snd/midiC1D0

but that didn't show any midi data either

========================================

here are messages from the Jack message window:

19:47:25.410 /usr/bin/jackd -dalsa -dhw:0 -r96000 -p1024 -n3 -P -m
19:47:25.454 JACK was started with PID=7069.
jackd 0.109.2
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
loading driver ..
apparent rate = 96000
creating alsa driver ... hw:0|-|1024|3|96000|0|0|nomon|swmeter|-|32bit
control device hw:0
19:47:25.761 MIDI active patchbay scan...
19:47:25.764 kim1: 20:0 Fastlane -> 129:0 ardour checked.
19:47:25.774 ALSA connection change.
configuring for 96000Hz, period = 1024 frames (10.7 ms), buffer = 3 periods
ALSA: final selected sample format for playback: 32bit little-endian
ALSA: use 3 periods for playback
19:47:26.026 MIDI active patchbay scan...
19:47:26.028 kim1: 20:0 Fastlane -> 129:0 ardour checked.
19:47:27.875 Server configuration saved to "/home/kim/.jackdrc".
19:47:27.888 Statistics reset.
19:47:27.964 Client activated.
19:47:27.976 JACK connection change.
19:47:27.985 JACK connection graph change.
19:47:27.988 XRUN callback (1).
**** alsa_pcm: xrun of at least 1236825087672.320 msecs

maybe something above will give you some more info
anyway I'm in San Francisco so I'll check the forum manana
ciao and thanks again
KIM

allank
allank's picture
User offline. Last seen 5 weeks 6 days ago. Offline
Joined: 2006-12-07
Posts:

I'm stumped. all your connections look fine from what I can see..
Some kernel versions have had problems with MIDI.. what kernel version are you using?

anechoic
User offline. Last seen 1 year 19 weeks ago. Offline
Joined: 2009-01-05
Posts:

http://alsa.opensrc.org/index.php/USBMidiDevices

MOTU Fastlane

Use of the MOTU Fastlane [2] is discouraged as it will not work with Linux kernels 2.6.18 and later[3]. When it does work, it does so without requiring a firmware loader. As of 2.6.24.3, this interface is still not supported.

=======================

this seems to be the problem I'm having
time to buy another midi interface

anechoic
User offline. Last seen 1 year 19 weeks ago. Offline
Joined: 2009-01-05
Posts:

sorry but the kernel version is 2.6.27-11
so it seems the info on the alsa page is correct
the kernel still doesn't support the MOTU Fastlane midi interface
:(
will post here how the Emu Xmidi works out
thanks again for pointing me in the right direction
cheers!

allank
allank's picture
User offline. Last seen 5 weeks 6 days ago. Offline
Joined: 2006-12-07
Posts:

that sounds better..
general rule for Linux and audio.. keep away from MOTU... My life has been much better since I dumped my MTP-AV units and found some second hand emagic ones (AMT8 and Unitor 8 Mk II)

anechoic
User offline. Last seen 1 year 19 weeks ago. Offline
Joined: 2009-01-05
Posts:

Allan
I just got the EMU Xmidi and it works like a charm!
thanks again for your help!
:)
peace
KIM