Building 2.7.1 with LV2 support

No replies
DrG
User offline. Last seen 4 years 22 weeks ago. Offline
Joined: 2008-01-05
Posts:

I've not tried building Ardour for a while, but since my distro now has LV2 in the repos I thought I'd give it a try... I'm using Mandriva 2008.1 and I've installed the following:

libslv2-devel 0.6.0
libslv2_9 0.6.0
lv2core 2.0
lv2core_devel 2.0
slv2 0.6.0

Then I do

scons LV2=1

and I get

Checking for slv2... no
LV2 support is not enabled (SLV2 not found or older than 0.6.0)

?????
I've got version 0.6.0.. it's installed... what is scons looking for and why can't it find it?

joegiampaoli
joegiampaoli's picture
User offline. Last seen 23 weeks 2 days ago. Offline
Joined: 2008-02-27
Posts:

I think you're gonna have to download from here

http://drobilla.net/software/slv2/

and compile, I had to do same in my ubuntu box.

philip8888
philip8888's picture
User offline. Last seen 1 year 1 week ago. Offline
Joined: 2007-03-30
Posts:

Download what version?

joegiampaoli
joegiampaoli's picture
User offline. Last seen 23 weeks 2 days ago. Offline
Joined: 2008-02-27
Posts:

maybe latest?

GMaq
GMaq's picture
User offline. Last seen 3 days 17 hours ago. Offline
Joined: 2007-12-11
Posts:

0.6.1 is needed,

You'll probably soon find out as I did that LV2 is more fun to play around with compiling than it actually is to use, not much choice there, and a loooooong way to go.

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

Hmmm, if I'm not mistaken you actually need 0.6.2 (which is the latest) for ardour 2.7.1.

As for LV2 choices check out the bottom of http://lv2plug.in. There's also the http://calf.sourceforge.net/ plugins which show off the LV2 GUI possibilities.

DrG
User offline. Last seen 4 years 22 weeks ago. Offline
Joined: 2008-01-05
Posts:

So if I need 0.6.2 why does it say

"SLV2 not found or older than 0.6.0" ?

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

Bug, perhaps...
Have you tried 0.6.2 ?

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

Also, you might need to upgrade scons; ardour seems picky about which scons version you're using. 1.1.0 or 0.98.5 and python 2.5.2 appears to be OK here at least.