Ardour can't connect to jack

No replies
caamg
User offline. Last seen 5 years 15 weeks ago. Offline
Joined: 2008-12-14
Posts:

Hi,
I have a major issue, but not a lot of information is given by ardour.
Since I upgrade to jack 0.116.1 and ardour-2.7.1 on my gentoo ardour can't connect to the jack server

for example I do

$/usr/bin/jackd -p512 -t10000 -dalsa -dhw:0 -r48000 -p1024 -n4 -o2 -Xseq&
$ardour2

And then if I open a project it try to launch a new instance of jack and fails
Even if I don't start jackd before it will fail

(In fact most of jack-based application don't work any more, but some still work)

I really don't know what to do as I've no particular error messages (I can also start jack with qjackctl but it don't give me more information)

Does someone have an idea?

paul
paul's picture
User offline. Last seen 1 day 5 hours ago. Offline
Joined: 2006-03-16
Posts:

sounds like you have 2 versions of JACK installed on your system. this is always a recipe for disaster.

you must either (a) remove packaged versions of JACK before installing a version from source (not recommended) or (b) make sure you build and install the source version using --prefix=/usr when using ./configure.

the forum is not the right place to fix this. get on IRC (the #jack channel at freenode.net). ask for help. be patient.

caamg
User offline. Last seen 5 years 15 weeks ago. Offline
Joined: 2008-12-14
Posts:

Ok thanks, I had two versions but remove the 2 and reinstall the software don't change anything, I asked on the chan but I don't get any relevant answer yet