Audacity wont start

11 replies [Last post]
werty37
User offline. Last seen 7 years 49 weeks ago. Offline
Joined: 2006-05-15
Posts:

hi everyone,

I am an new user of ardour. I was impressed byt the screen shots of
ardour. so I installed ardour(i686) in my ubuntu dapper using the
synaptic.
when i start ardour it sez

Ardour could not connect to jack
There are several possible reasons:

1) JACK is not running
2) JACK is running as another user, perhaps root
3) There is another client called "ardour"

please consider the possibillities, and perhaps (re)start JACK

What is wrong?

Thanks in advance

niemau
User offline. Last seen 5 years 24 weeks ago. Offline
Joined: 2006-04-07
Posts:

guessing you meant 'ardour' when you mentioned 'audacity' in the subject line of your post.

seems like the cause of your problem is that you are simply not running jack. jack is required by ardour. please download and install jack (if you haven't already done so) and make sure it is running before trying to run ardour. jack is a console app (think commandline) but there are several graphical frontends available that are very simple to setup and use. 'qjackctl' is my favorite.

jack is available at http://jackit.sourceforge.net but you'd have to compile it yourself. i'm sure that ubuntu has all of the software you need in their repository. you can probably just open synaptic and search for qjackctl. if you can install that from synaptic, all of its dependencies (including jack) should be downloaded and installed automatically... then again, if you downloaded ardour via synaptic, you should already have jack on your system.

werty37
User offline. Last seen 7 years 49 weeks ago. Offline
Joined: 2006-05-15
Posts:

Hi
Sorry - wrong Subject line

My synaptic says that i ve jackit already installed

libjack0.100.0-0
JACK Audio Connection Kit (libraries)

Anyways installing qjackctl thru synaptic...
Installation successful...

opening qjackctl...
terminal>"qjackctl"

A dialog box with the message appears:
"Could not open ALSA sequencer as a client"
"MIDI patch will not be available"

I cancel it (actually there is only one one button--cancel).

In the Jack Audio Connection Kit GUI, i press the button "Start"

A dialog box with the message:

"Could not start jack
Sorry"

I close it..

What is wrong?

Thanks

Seb
Seb's picture
User offline. Last seen 3 hours 3 min ago. Offline
Joined: 2006-04-07
Posts:

You probably want to install the realtime-lsm module to run jack as non-root in realtime mode: use "module-assistant" for that, it will download & compile it for you (i assume you use dapper drake release, that did not work for me with breezy). Once that is done you can tick the "Realtime" box in the qjackctl tickbox and still run it as non-root.

The “Could not open ALSA sequencer as a client” is nothing to really worry about, you can wire up midi clients in qjackctl but it's nothing to do with jackd really and ardour will work fine without it.
It appears the midi sequencer module does not get loaded automatically in ubuntu. Try "sudo modprobe snd-seq-midi" to install this module, that will only work until reboot though. Place something in /etc/modules to sort it out permanently.
Good luck. ardour0.99 runs fine for me with dapper (as did 0.93 with breezy actually)

werty37
User offline. Last seen 7 years 49 weeks ago. Offline
Joined: 2006-05-15
Posts:

Hi
You mean the synaptic manager by "module-assistant" is it not?
Installing realtime-lsm...
Installation successful...

terminal> "qjackctl"
The error which used to occur when i open qjackctl--
"Could not open ALSA sequencer as a client"
dosen't occur anymore.

qjackctl>Setup>Parameters>"checking Realtime"

now starting jack...
error:

Could not start jack
Sorry

This is what it sez in the messages window:

22:55:17.476 Patchbay deactivated.
22:55:17.494 Statistics reset.
qstring_to_xtp result code -2
22:55:17.560 MIDI connection graph change.
22:55:17.708 MIDI connection change.
Qt: Locales not supported on X server
QInputContext: no input method context available
QInputContext: no input method context available
qstring_to_xtp result code -2
22:55:43.035 Startup script...
22:55:43.036 artsshell -q terminate
qstring_to_xtp result code -2
sh: artsshell: command not found
22:55:43.254 Startup script terminated with exit status=32512.
22:55:43.256 JACK is starting...
22:55:43.257 jackd -R -dalsa -dhw:0 -r44100 -p1024 -n2
22:55:43.261 Could not start JACK. Sorry.
qstring_to_xtp result code -2
22:55:45.424 JACK was stopped successfully.
qstring_to_xtp result code -2

I ll post some more info about my hardware:

Intel 915GAV m/b, 1gb 400mhz ram, built in audio card(Realtec, i think), 2.1 speakers

volume control says that im using "Realtec ALC880 (OSS Mixer)

Thanks in advance

taybin
User offline. Last seen 41 weeks 2 hours ago. Offline
Joined: 2006-03-15
Posts:

It looks like you are using the deprecated OSS drivers for your soundcard instead of the modern ALSA ones. This is probably your distro's fault. Which distro are you using so we can tell people to stay away from it?

To enable ALSA, you'll probably need to recompile your kernel.

Bussman
User offline. Last seen 4 years 27 weeks ago. Offline
Joined: 2006-03-31
Posts:

@ werty37: Try checking out Ubuntu Studio, they have a few articles on what you need to do to get that distro up to snuff with audio stuff.

I don't know how helpful it will be to you as I don't use Ubuntu. Good luck!

tuomashelin
User offline. Last seen 7 years 48 weeks ago. Offline
Joined: 2006-04-13
Posts:

Building a realtime kernel is my recommendation for jackd. Easiest way to accomplish this is to install
1) Fedora Core 3 or some other RedHat based Linux (CentOS, Scientific Linux)
2) head to Planet CCRMA and download their two cd-images and read the very good documentation

Realtime module is used for letting regular users to get realtime priorities to the kernel processes - that is the reason for error message: "could not connect to jack as client".
A quick workaround for this is starting jackd as a regular user in a terminal:
jackd -d alsa -d hw:0 -r 48000 -p 1024 -D
After issuing this command start qjackctl. It will not run with realtime priorities but will work anyway.

If you want to use Deb-based system, you must install kernel-packages and download the realtime-lsm module package from sourceforge. I also recommend the CK (Con Kolivas) kernel patches, that are widely used in Linux multimedia applications.

Here is how it goes:
1. make sure you have kernel source on your system, usually in /usr/src
2. copy the CK-patch package to /usr/src along with realtime-lsm package
3. unpack the realtime package: tar -xzvf realtime-x.x.tar.gz
4. make a symbolic link to your kernel source: ln -s linux-version.x.x linux
5. move to your kernel source directory: cd linux
6. patch the kernel source with the CK patch - make sure your kernel version is correct(!): bzcat ../ck-patch.x.x.bz2 | patch -p1
7. copy your working kernel configuration from /boot-directory to your kernel source directory:
cp config-your.kernel.version /usr/src/linux/.config
8. make a configuration to your kernel source:
make menuconfig
9. remember: realtime capability must be loaded as a module to the kernel, not compiled to the kernel - this is configured in "Processor type and features"
8. make your kernel after saving your new configuration: make all
9. make a bzImage of your kernel: make bzImage
10. make your kernel modules: make modules
11. go to the realtime-directory ( cd ../realtime.x.x ) and give the command: make && make install
12. go back to kernel directory: cd ../linux
13. install modules: make modules_install
14. wait
15. finally, install the new kernel:
make install

If you are using GRUB, make install will update your bootloader configuration to include the new realtime kernel.
If jackd still complains about not connecting to server, give this command to load the realtime module (as root):
modprobe realtime any=1

Should work now. Ardour rules with this combination: jackd+realtime-kernel

Steph
User offline. Last seen 6 years 34 weeks ago. Offline
Joined: 2006-05-18
Posts:

I've recently installed ubuntu dapper beta2.

Everything went mostly without a problem.

For jack, after you start qjackctl, before you hit "start", go in "setup" and tweak "Interface:" and "input channel:" and "output channel:"

I set mine to "hw:0,0", "2", "2". In your case, you might have to use different values, but the point is that I had to override the default values.

Also make sure "Driver:" is "alsa".

But I do have the whole nine yard running on ubuntu, and didn't have to recompile a kernel.

One issue I had was setting up midi. But that's another story.

Markinoko
User offline. Last seen 6 years 47 weeks ago. Offline
Joined: 2006-04-09
Posts:

Ubuntu studio is certainly the simplest way to get things integrated properly. The web site is a usefull resource for Ubuntu users as well as others since it also contains some general purpose tips.

http://ubuntustudio.com/

WebThingy
User offline. Last seen 7 years 46 weeks ago. Offline
Joined: 2006-06-05
Posts:

I get many of the same problems as the guy who started this post:

When I run "ardour" from the command line I get the error about not being able to connect to Jack

I also get this if I open Jack, a dialog box with the message appears:

“Could not open ALSA sequencer as a client”
“MIDI patch will not be available”

Could this be because I'm logged in as root/Administrator? Do I need to create another user to access Arodur?
If I create another user, do I still have access to everything on my machine like I do as root?

Markinoko
User offline. Last seen 6 years 47 weeks ago. Offline
Joined: 2006-04-09
Posts:

“Could not open ALSA sequencer as a client”
“MIDI patch will not be available”

--> This happens when you launch qjackctl without the snd-seq module loaded. Load it first with "modprobe snd-seq", you should then get the proper seq device working.

--> The error you get when you run ardour is not related to this. If ardour does not connect to jack it means jackd is not running. Running qjackctl before running ardour is not sufficient. You have to start the jackd process from qjackctl (the "play" button), and then run ardour.

Marc-Olivier Barre,
Kinoko en Orbite