Upgrade to FC4 broke Jackd

6 replies [Last post]
Bussman
User offline. Last seen 4 years 27 weeks ago. Offline
Joined: 2006-03-31
Posts:

Upgraded to FC4 from FC2 using CCRMA CD images. Jack is now broken. Here's the output:

load = 0.2977 max usecs: 127.000,
spare = 21206.000
delay of 106651.000 usecs
exceeds estimated spare time
of 21206.000; restart ...

It goes on forever. Ring any bells? ALSA and my Delta-66 seem to be working fine. Everything is "stock" from CCRMA, no funky tweaks.

paul
paul's picture
User offline. Last seen 20 hours 37 min ago. Offline
Joined: 2006-03-16
Posts:

there is a bug in FC that rewrites /etc/modules.conf incorrectly. do you use the realtime LSM module? delete the line it is on in that file, and re-enter it by hand. you will have to do this every time you run system-config-network or something else does on your behalf.

that's my best guess.

Bussman
User offline. Last seen 4 years 27 weeks ago. Offline
Joined: 2006-03-31
Posts:

Thanks for your suggestion. Alas, no luck.

From CCRMA web page: "in older versions the realtime Linux Security Module was also included - to enable you to run programs like Jack with realtime privileges from a normal non-root account - this is no longer necessary with newer kernels, they use a different access mechanism that depends on a properly patched PAM, also included in Planet CCRMA"

So the answer to your question would be no. There is no realtime-lsm package to be found through apt-get either. BTW there is no /etc/modules.conf file on my system. One of these days I'm gonna have to learn what's under the hood, so I can do my own oil changes properly :-)

I googled like hell, most of the stuff I read about this particular error goes right over my head... Maybe a clean install is in order?

grantpetersen
User offline. Last seen 13 weeks 3 days ago. Offline
Joined: 2006-04-18
Posts:

It's /etc/modprobe.conf on fedora 5 but I seem to recall the modules config file was /etc/modprobe.conf in fed4 too.
Can you try starting jackd without the -R thus not running realtime: Try something basic from a terminal like:
jackd -d alsa
(making sure that jack is not already running and that esd etc are not hogging the soundcard of course) and see what happens.

--edit--

b***ger - this was ment to be a reply to the /etc/modules.conf suggestion.

Bussman
User offline. Last seen 4 years 27 weeks ago. Offline
Joined: 2006-03-31
Posts:

I no longer have xruns and the infinite display of "delay of ... ... restart..." lines is gone.

-edit-
I am REALLY stupid. It seems the upgrade had reset the Delta66 settings to some insaniac default from hell, i.e. sample rate was switched back to it's lowest (22050) etc. I must learn to be more careful and double check everything. On that note I'll go get rid of my frustrations by studying some furious chord substitution theory (as self-punishment). Thanks for all the help.
-edit-

dx9s
User offline. Last seen 10 weeks 2 days ago. Offline
Joined: 2006-05-19
Posts:

I don't use any of those various automated processes (yet?) to install bleeding edge (like Ardour, or Cinelerra).

The only expansion fo PAM = Pluggable Authentication Module. and I fail to see how a patch PAM (if it has to do with logging onto the system) can "give" RT access on a kernel (as a normal use) w/o some realtime module.

curious, I suspect PAM (in this case) means something other than Pluggable Authentication Module. (of which I normally don't use -- I am a Slackware guy).

Please expand it's meaning if somebody knows what this PAM is and how it has been patched.

--Doug

grantpetersen
User offline. Last seen 13 weeks 3 days ago. Offline
Joined: 2006-04-18
Posts:

I read about this a while back: It allows members of a configurable group to be given real-time rights otherwise only available to root. I found it referred to as "rlimits" and needs support in the kernel and PAM (added to PAM by patch in this case).
This way non-root users can run jackd and therefore ardour with real-time privileges.

google rlimits should give you all you need.