Mackie Emulation problem (for bcf2000)

No replies
Blindekinder
User offline. Last seen 40 weeks 6 days ago. Offline
Joined: 2009-01-21
Posts:

Hi,
I'm new on the forum... First of all, I really like Ardour, although I have a lot of problem... especially with FFADO drivers, which are still in developement...
Well: I bought a BCF2000, and it works with "generic midi" mode... I wanted to use Mackie Emulation, but when I select it, I get this error message:
[ERROR]: Error instantiating MackieControlProtocol: The Mackie MCU driver will not use a port with device=ardour
[ERROR]: control protocol name "Mackie" could not be initialized

I tried to add lines in ardour.rc as explainded here, but nothing happens, and it supress them when I quit Ardour...
Any Idea?

Ardour 2.7.1 :: jackd 0.116.1 :: qjackctl 0.3.4 :: Edirol FA-101 :: FFADO 2.0 RC1 :: Ubuntu Studio 8.04

hogiewan
User offline. Last seen 3 years 32 weeks ago. Offline
Joined: 2007-05-02
Posts:

why would you use FFADO? the BCF2000 is a usb inferface and FFADO is for firewire

allank
allank's picture
User offline. Last seen 5 weeks 2 days ago. Offline
Joined: 2006-12-07
Posts:

look at his setup.. he as an edirol fa-101 in there.. I thought these were well supported by now.. Have you joined the ffado users mailing list?

As for the BCF- can I ask why you want to use it in Mackie emulation mode? What benefits are there?

I have one and am pretty happy with Generic MIDI mode.. but if there are improvements, then let me know....
okay I can see said improvements.. may try this.. as i have an evolution uc-17 I could use for plugin automation..

roaldz
User offline. Last seen 1 year 38 weeks ago. Offline
Joined: 2008-11-12
Posts:

@Blindekinder:

It would be easier to help you if you'd post the specific mackie ardour.rc config lines from your ardour.rc file.
Please take a second look at the device in:

MIDI-port tag="mcu" device="/dev/snd/midiC2D0" type="alsa/raw" mode="duplex"/

the /dev/snd/midiC2D0 device must point to your BCF device, mine is /dev/snd/midiC1D0

also make sure that type="alsa/raw", not alsa/sequencer

make sure you boot the BCF in Login control mode (3rd butten from top left if i recall correctly).

Blindekinder
User offline. Last seen 40 weeks 6 days ago. Offline
Joined: 2009-01-21
Posts:

Thank's...
=>hogiewan: as allank said, I use ffado for my FA-101, and alsa for the BCF, connected with USB...
=>allank: I read it's more confortable to use mackie-mode, everything is already configured, and when add a track, control is automatically added... (am I right?)... I didn't found in Ardour the way to attribute CC to each control (eg: I give this fader CC 81, this mute CC 33 etc...). If there aren't so many improvements, maybe I let this mode at the moment...

The lines in ardour.rc are:
MIDI-port tag="control" device="ardour" mode="duplex" type="alsa/sequencer"/>
MIDI-port tag="mcu" device="ardour" mode="duplex" type="alsa/sequencer"/>
MIDI-port tag="seq" device="ardour" mode="duplex" type="alsa/sequencer"/>
If I add a line, it's automatically suppressed after quit... I added the lines as explained in the link in my first post, changing C2D0 for my own config of course...
Maybe I should replace the original "mcu" line by this?
What I don't understand is the error message. I can't find any reference on the web...

[no way to subscribe to a topic?]

roaldz
User offline. Last seen 1 year 38 weeks ago. Offline
Joined: 2008-11-12
Posts:

MIDI-port tag=”control” device=”ardour” mode=”duplex” type=”alsa/sequencer”/>
MIDI-port tag=”mcu” device=”ardour” mode=”duplex” type=”alsa/sequencer”/>
MIDI-port tag=”seq” device=”ardour” mode=”duplex” type=”alsa/sequencer”/>

You have to edit the second line containing "mcu", make it like this:

MIDI-port tag=”mcu” device=”/dev/snd/midiC1D0” mode=”duplex” type=”alsa/raw”/>

mind the device="/dev/snd/midiC1D0"
and type is alsa/raw, not alsa/sequencer

make shure the device /dev/snd/midiC1D0 is present on your system, to check:

"ls /dev/snd/"

You can also read this:
http://ardour.org/files/manual/sn-mackie.html

It is not needed to use the BCF in Mackie mode, what I did is just make the BCF preset 1 keys bind to ardour channels 1-8, and BCF preset 2 bind to channels 9-16.
This works better for me, because I don't like the shift-key workflow for solo/mute in mackie emulation mode.

If you like I can download my P1 and P2 presets from my BCF, so you can try those, they work with every generic midi-enabled ardour with "auto rebind controls" and "feedback" options enabled.

Now I have a question to anyone who can answer it:

I noticed the knobs and faders in mackie emulation mode are much more precise (14-bit?). If I put my BCF in Generic Midi mode, and config my faders/knobs for Abs14 (14 bit absolute), ardour doesn't know any way to understand this, while it does if using the mackie driver... Is is possible to use 14bit midi CC values in some other way?

Blindekinder
User offline. Last seen 40 weeks 6 days ago. Offline
Joined: 2009-01-21
Posts:

Ok,
I replaced the line, and it works great...
I'll tell you after some practice what would be the advantages to use normal mode or Mackie mode...

But I can't make this setting persistant: if I start ardour without the BCF connected, it gives an error message and doesn't show the Mackie mode in Option menu, all right... but then it suppress the lines in ardour.rc, and we're back to the beginning... I tried to change also in /etc/ardour2/ardour_system.rc . It's persistant but doesn't have any effect on the problem (I don't have any ardour.rc in /etc/ardour2 as explained in the link you gave me roaldz).

I put this line too, but I don't really understand its function (it works without):
Option name="mackie-emulation" value="mcu"/>

And yes, roaldz, it would be nice if you could send these settings... (how do you download a preset? I know how to do it on the bcf, but how to get it on the computer?).
Just a precision for solo/mute: one is on the button (the other is to enable recording mode) and the other is on the knob-button (don't remember which one). But I understand you, I don't like so much these "multi functions buttons" with shifting, like a car radio... ;-)