prevent overdub

No replies
pleasebeus
pleasebeus's picture
User offline. Last seen 2 years 15 weeks ago. Offline
Joined: 2008-11-28
Posts:

I can't seem to stop an overdub happening - I've recorded drums on tracks 1&2 through Hydrogen which comes into my 1010LT card on channel 11&12. I'm trying to record midi keyboard (which also comes in on 11&12 on my card) on tracks 3&4.

Hitting the record button gets my keyboard ok but also gets the drum track I recorded all over again. I've looked & played endlessly with jack connections (also looked via patchage) to resolve it. I keep getting either nothing or the new keyboard AND the old drum track. Something's crossed somewhere but how do I resolve it?

Ideally I'd like to hear the drums on monitor but not have them re-record onto the keyboard track. Is there a good example setup of Jack connections I can look at?

peder
User offline. Last seen 49 weeks 1 day ago. Offline
Joined: 2007-05-08
Posts:

Do you have an external PC with hydrogen, since it's coming in on the LT card?
Internal sound programs, like Hydrogen or ZynAddSubFX, running on the same PC as Ardour don't go through the sound card to get to Ardour. You just patch them from their output (in qjackctl for instance) to the relevant track in Ardour.

pleasebeus
pleasebeus's picture
User offline. Last seen 2 years 15 weeks ago. Offline
Joined: 2008-11-28
Posts:

They're on the same pc. I've laid the Hydrogen piece down as a recorded track. I then want to play along to it on the keyboard on a separate track. But when I try and do this, the first track gets repeated onto the second I'm trying to record.

Both instruments appear on my Ardour as inputs 11 & 12. I'm trying to work out the patches needed in Jack but am stuck.

peder
User offline. Last seen 49 weeks 1 day ago. Offline
Joined: 2007-05-08
Posts:

As you can see here (http://www2.park.se/~peder/JackHydro.jpg) I only have the output from Hydrogen patched to the input of the drum track in Ardour.
When the drums are recorded I close Hydrogen all together ant the the only drum output is from the drumtrack to playback_1 and 2

I don't really understand your connections but, to quote myself from this http://ardour.org/node/1941, on the Audiophile 2496 at least inputs 11-12 are some mixing inputs that sends back the output as well.

Try seeing if your keyboard isn't input on some other channel on the LT.

pleasebeus
pleasebeus's picture
User offline. Last seen 2 years 15 weeks ago. Offline
Joined: 2008-11-28
Posts:

Yes, I always close Hydrogen before recording keyboards otherwise the drums get hit with the same keys.

Anyhow - that's not the problem as my drum track is already laid down and Hydrogen is shut.

Here's a shot of my setup. There are two drum tracks there but it's irrelevant; I get the same problem with just one. The keyboard track here is titled 'drone'.

ardour screenshot

peder
User offline. Last seen 49 weeks 1 day ago. Offline
Joined: 2007-05-08
Posts:

I always close Hydrogen before recording keyboards otherwise the drums get hit with the same keys.

So, are you using an external MIDI keyboard to record the sounds of an internal synt, like qsynth in your screenshot?
In that case you shouldn't have any of the system/capture ports assigned to any of the Ardour inputs. You just connect the qsynth left/right to the proper track in Ardour.

Nontheless, I'd disconnect all the capture ports and start troubleshooting there. Connect them one by one to a track and see what gets recorded. And I strongly suspect that the 11-12 ports are in fact mix ports, like on my 2496

pleasebeus
pleasebeus's picture
User offline. Last seen 2 years 15 weeks ago. Offline
Joined: 2008-11-28
Posts:

yes, it's an external keyboard hooked up to qsynth. I just disconnected all the capture ports and connected qsynth to the relevant input track in Ardour. Now there's no input at all - but at least the drums have gone, too...

The 11 & 12 are midi inputs on the LT; it's how the external Roland keyboard is hooked up to the pc.

I only seem to get a signal if capture 11 & 12 are connected to audio 1 & 2 ... but I also get the drums again when I do that.

peder
User offline. Last seen 49 weeks 1 day ago. Offline
Joined: 2007-05-08
Posts:

The MIDI inputs aren't on the Audio tab in qjackctl, they're in the MIDI or ALSA tab depending on how you have things set up:

So switch over to the MIDI or ALSA tab and connect the MIDI signal going into the LE to qsynth, then switch to the Audio tab and connect qsynth's outs to the track

pleasebeus
pleasebeus's picture
User offline. Last seen 2 years 15 weeks ago. Offline
Joined: 2008-11-28
Posts:

Yes, that's exactly what I have already in my Alsa tab - ie my QSynth input port is connected to the 1010LT's MIDI Output Port.

But QSynth out on the audio tab connected to Ardour's track doesn't deliver anything. It only works when I connect Capture 11 & 12.

peder
User offline. Last seen 49 weeks 1 day ago. Offline
Joined: 2007-05-08
Posts:

From what I can see in your shot, you have qsynth connected to playback_1/2 and capture_11/12 to Drone (and Audio1 ?).

If I do the same connections on my 2496 and record I get a track filled with the other tracks mixed with the synth.

But if I disconnect those, connect the synth only to the track and playback_1/2 I hear it and it, and only it, gets recorded on that track.

pleasebeus
pleasebeus's picture
User offline. Last seen 2 years 15 weeks ago. Offline
Joined: 2008-11-28
Posts:

hmm - if I try that, I can hear the rest of the mix but I get a blank on the track I'm trying to record (though I can hear the synth thro' the monitors).

PS I'm really appreciating your help in me solving this, peder!

peder
User offline. Last seen 49 weeks 1 day ago. Offline
Joined: 2007-05-08
Posts:

Sure, no prob.

OK, last attempt before it's bedtime (here in Sweden anyway):
Create a new Ardour project, add a track, head over to the qjackctl connections and disconnect all. Then connect it like this:

Don't forget to connect the MIDI port.
I run the mono synt Hexter here but you can connect your stereo synth to a stereo track, of course.
Arm the track, start recording and start playing your keyboard. You won't hear anything but you should see the waveform in Ardour.
Stop recording and play it back and you should hear your (well...) masterpiece.

pleasebeus
pleasebeus's picture
User offline. Last seen 2 years 15 weeks ago. Offline
Joined: 2008-11-28
Posts:

I can get a waveform, yes - and I can hear it on stopping & playback.

In my setup I can't connect Audio1/out1 to master/in 1 and Audio1/out2 to master/in 2. Jack refuses to make those connections.

I think you're doing the right thing getting me to strip this back to basics :)

What I want now is the ability to monitor what I've recorded on Audio 1 whilst recording new synth to Audio 2 without getting Audio 1 overdubbed onto Audio 2.

peder
User offline. Last seen 49 weeks 1 day ago. Offline
Joined: 2007-05-08
Posts:

I'm wondering if you've made some weird setting in Ardour. Try removing your .ardour2 dir prior to starting.
Also, what jack version are you using? 0.109 had some problems that could potentially be related to this.

I guess you connected Audio1/2 directly to playback_1/2 to hear it on playback.
In my image above I could've connected hexter's out to playback_1/2 to hear what I played during recording.

pleasebeus
pleasebeus's picture
User offline. Last seen 2 years 15 weeks ago. Offline
Joined: 2008-11-28
Posts:

I'm using the latest Jack from repos; I've reset my Ardour2 dir and am starting over again.

This time I think I'm getting the hang of Jack's connections. So far, so good - I've been able to record Hydrogen and then get a synth track without an overdub.

I think my problem lies in the fact that Jack seems to create connections (mostly) automatically on launch and up to now I've been happy to let it play the engineer whilst I concentrate on composing & playing. For example, as soon as I launch Ardour and Hydrogen, I get capture_11 & 12 (my 1010LT's Midi) hooked up to an audio track. I now realise this isn't necessary at all; the captures are only needed when I plug guitar/bass/vox etc in.

The auto function gets you off the mark out of the box but stops you learning the inputs & outputs and how they work in Jack. I don't know where to turn this auto function off. Any ideas?

PS thx again for steering me back to basics

roaldz
User offline. Last seen 1 year 39 weeks ago. Offline
Joined: 2008-11-12
Posts:

Please take a look at ardours options regarding monitoring. There are as far I can remember 3 options: Jack does monitoring/Ardour does monitoring/Audio hardware does monitoring(no software monitoring). Ardour monitoring means that all tracks marked to record are played back to the master, and all recorder tracks are played back while recording. Maybe your problem is around here, not shure.

pleasebeus
pleasebeus's picture
User offline. Last seen 2 years 15 weeks ago. Offline
Joined: 2008-11-28
Posts:

Thanks Roald; I've just recorded some stuff successfully though it took a lot of switching around stuff in Jack. But at least I've some sort of working process now.

There seems to be sthg that's auto connecting in Jack but I can't see where to switch it off. In Ardour, I've switched off Autoconnect but when I launch Rosegarden for example, Jack is making connections which I always have to undo (particularly captures on my midi channels 11 & 12 on the 1010LT card).