Ardour 2 SVN debugging symbols

1 reply [Last post]
duffrecords
duffrecords's picture
User offline. Last seen 37 weeks 5 days ago. Offline
Joined: 2008-05-20
Posts:

I'm trying to generate a backtrace for a crash, but when I run ./ardbg I get the error

gtk2_ardour/ardour-2.7.1: No such file or directory.

I compiled it from svn (with DEBUG=1) so there is no ardour-2.7.1 directory; it's 2.0-ongoing. I tried running

gdb /usr/local/bin/ardourvst

but then it says this:

"/home/ian/src/ardour-trunk/2.0-ongoing/vst/ardourvst": not in executable format: File format not recognized

Sorry, this probably has an easy solution but I have the flu and thinking about syntax seems to make it worse.

paul
paul's picture
User offline. Last seen 7 hours 43 min ago. Offline
Joined: 2006-03-16
Posts:

First, running gdb on the VST build is more or less completely pointless. This has been one of my most important reasons for being reluctant to support VST plugins - it is often impossible to debug problems. Second, the VST build generates a totally different executable than a normal build. You almost certainly don't want to know the details :)