cant geht audigy 2 mic hw:0,2 running under jackd

No replies
gorn
User offline. Last seen 3 years 36 weeks ago. Offline
Joined: 2009-02-26
Posts:

first sorry for my poor english

i have got a mic signal on hw:0,2 - i can record it with audacity.

But if i want to record it with ardour i only record the output of channel 1

here my jackd conf:

Free Image Hosting at www.ImageShack.us

Free Image Hosting at www.ImageShack.us

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

I'm not at all sure what you want to do.
Do you have multiple soundcards? Otherwise change Input Device in the jack setup to default.

The connection graph in your first picture shows that you have Audio 1/2 out connected directly to playback_1/2. Normally all the Audio-outputs on the left should be connected to ardours master_in1/2 on the right and ardours master_out1/2 on the left should be connected to playback_1/2 on the right.

And as your setup is now, you'd be recording one of the input channels of your sound card to track 3 and 4 in Ardour.

gorn
User offline. Last seen 3 years 36 weeks ago. Offline
Joined: 2009-02-26
Posts:

Hello,

oh ok. I only have one Soundcard. I changed input device to defaul. I changed settings in my connection graph as you said.

But where to connect capture 1 and capture 2? I would say to the right side to audio 3 in. But then i record my already recorded tracks (i did it with an old sound card - there it was easy). When i do not plugin capture 1 and 2 in there is a zero line on track 3 when i record.

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

To record something on audio track 3 you connect the captures to the track as you said. If it's a mono signal you can conect either of the captures (or possibly both) to the audio in, if it's a stereo signal you need to create a stereo track and connect each capture to the respective audio in.

Then in ardour you arm the track (press the little red button nex to the m,p and a ones) press the big record button on the top and then play.

gorn
User offline. Last seen 3 years 36 weeks ago. Offline
Joined: 2009-02-26
Posts:

hello again,

after a while now i just try my luck again.

it is easly possible to record one track - if i want to record another track it always records my output and not my microfone.
the output are coming over capture_1 and capture_2... can someone help me?

Here my Connections

Free Image Hosting at www.ImageShack.us

And here my Ardour Record
Free Image Hosting at www.ImageShack.us

I

thorgal
User offline. Last seen 1 year 21 weeks ago. Offline
Joined: 2007-08-03
Posts:

looks like it's your soundcard setting. I believe others reported the same kind of issue: your card will redirect the PCM output to input internally so you are recording the PCM playback audio on top of any other input. I am not sure why the alsamixer would set this option by default. This is really annoying. So fire up alsamixer and disable whatever option causes that (I don't know for sure as I am not using that kind of generic mixer app in my system). Your issue has therefore nothing to do with ardour nor jack. It's a mixer setting at the soundcard level.