Ardour 2.8 install - liblo does not appear to be installed

5 replies [Last post]
tictactatic
User offline. Last seen 1 year 2 weeks ago. Offline
Joined: 2007-08-02
Posts:

Hi,

I've run into trouble trying to install 2.8 on my Kubuntu 8.04.

I ran: scons VST=1 FFT_ANALYSIS=1 LV2=1 FREESOUND=1

And scons builds fine, but when I try to install with: sudo checkinstall scons install -D

the install fails with liblo does not appear to be installed.

I tried searching around the forum, uninstalled the liblo packages that came with the system, got fresh liblo sources, compiled them, and still the error persists.

Has anybody had similar experiences? Any pointers?

Thanks in advance!

Matt Francomb
Matt Francomb's picture
User offline. Last seen 1 hour 13 min ago. Offline
Joined: 2006-09-12
Posts:

I've had a similar problem; in my case it was caused by the fact that the library was installed in /usr/local/lib (as are most locally-installed
libraries), but the default for pkg-config is only to search /usr/lib, at least for root. You can override this by setting the PKG_CONFIG_PATH
variable.

so try this:
sudo su -
cd to where you built ardour
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig
checkinstall scons install -D

[I can't remember whether you have to set PKG_CONFIG_PATH to
/usr/local/lib:/usr/lib
or
/usr/local/lib/pkgconfig:/usr/lib/pkgconfig

but one of these two should work]

tictactatic
User offline. Last seen 1 year 2 weeks ago. Offline
Joined: 2007-08-02
Posts:

Thanks for the suggestion Matt. I only got back to my machine tonight.

Alas, neither of the two variants have worked :(

Will try to fiddle with it a bit more... or I'll just upgrade to a clean install Jaunty and try my luck there.

Thanks again.

GlatzenPer
User offline. Last seen 49 weeks 5 days ago. Offline
Joined: 2009-05-08
Posts:

The SConstruct script seem to look for 'lo_server_new' in lo.h (should be in/usr/include/lo/lo.h) however 'lo_server_new' is defined in /usr/include/lo/lo_lowlevel.h which is included by lo.h.

Bottomline, changing 'lo_server_new' in SConstruct to 'lo_server_thread_new' solved the problem for me.

Hope it helps,
Cheers

graphbobby
User offline. Last seen 3 years 9 weeks ago. Offline
Joined: 2009-05-13
Posts:

it seems that scons also breaks the build environment, so pkg-config does not find its configuration files for the libraries, and scons reports unsatisfied dependencies

unfortunately, scons is something like a 45000 lines makefile, so investigating the source of this problem in scons is out of the question.
as a workaround, i wrote a wrapper script around pkg-config for building ardour:

mv pkg-config pkg-config-bin
vi pkg-config -->
#!/bin/bash
export PKG_CONFIG_PATH=/path/to/ardour/lib/pkgconfig:/path/to/ardour/lib64/pkgconfig:/path/to/...
pkg-config-bin $*

after doing that, scons found all the libraries and continued building ardour

just don't forget to undo that wrapper-script-magic after your build is complete

seablade
User offline. Last seen 2 hours 38 min ago. Offline
Joined: 2007-01-22
Posts:

graphbobby-

Um scons should work fine with pkg-config. It actually sounds like you are just creating the PKG-CONFIG-PATH variable with what you are doing effectively, which should be an environment variable in your environment, can you confirm that it is normally there on a fresh login? Thanks.

Seablade