very high CPU load, help!

No replies
tuttlecr
User offline. Last seen 4 years 48 weeks ago. Offline
Joined: 2009-01-14
Posts:

Hi guys. I just got Ubuntu studio 8.04.1 up and running. The installation went without a hitch; however, when I start Ardour and run five tracks with the Gverb plugin I'm getting a CPU load of 70% (pretty constant while running). This is accented by xruns from time to time. This shouldn't be the case, right? I've got two 2.8 ghz xeon processors and 2g of ram. I ran a much slower machine in the past and had much better performance. (I've got ardour 2.3 installed)

Any ideas on how to fix this? I'm new to unix in general and need help asap. Thanks in advance.

qharley
qharley's picture
User offline. Last seen 3 days 12 hours ago. Offline
Joined: 2007-03-24
Posts:

Get on the bus...

Set up a bus for gverb, set up gverb on it 100% wet, and create a send to the bus from each track. This way you only have a single instance of gverb, and you could have as many tracks 'verbed as you please. Additionally you can now easily adjust the overall reverb by setting the gain on the bus.

Thank me later...

tuttlecr
User offline. Last seen 4 years 48 weeks ago. Offline
Joined: 2009-01-14
Posts:

Thanks for the tip, I've done this in the past and its a great way to cut down cpu load. I only used those plugins as a sort of test. If I add one plugin of any sort to each track, the cpu load is unreasonably high. Something isn't right.

thorgal
User offline. Last seen 1 year 21 weeks ago. Offline
Joined: 2007-08-03
Posts:

as far as I know, and Paul can contradict me, the audio processing is using only one CPU core, so all your plugins in ardour will end up in the same DSP proc, which will only use one core. Is that right Paul ? IIRC, you mentioned that multiple core for the DSP engine is not yet around the corner ...

GMaq
GMaq's picture
User offline. Last seen 4 days 13 hours ago. Offline
Joined: 2007-12-11
Posts:

Hello,

GVerb is a very CPU intensive plugin to begin with, there is a CPU optimized stereo version by Fons Adriaensen usually found in Debian and Ubuntu as the "rev plugins" package. 5 tracks of individual GVerbs running on one core could definitely jack up your CPU usage significantly.

tuttlecr
User offline. Last seen 4 years 48 weeks ago. Offline
Joined: 2009-01-14
Posts:

Again, this isn't necessarily designated to just the Gverb plugin. Five other individual plugins will give me the same result. (this is occuring without any wavs in ardour, I'm just adding plugins and hitting play). Could it be the fact that I installed Ubuntu with the plugin packages? I've done a little reading and see that this could be a contributing factor.

thorgal
User offline. Last seen 1 year 21 weeks ago. Offline
Joined: 2007-08-03
Posts:

could also be a denormal issue. Try to protect your track against denormals. In 2.8, there's an option in the track header context menu if you right-click on it.

ah wait a sec, you are still using 2.3 ? ... the denormal stuff may be hidden somewhere in the main options

qharley
qharley's picture
User offline. Last seen 3 days 12 hours ago. Offline
Joined: 2007-03-24
Posts:

Ardour 2.3...

If I remember correctly the performance was not so great on that version. Try to install at least 2.7.1 or the latest 2.8 and try again.

tuttlecr
User offline. Last seen 4 years 48 weeks ago. Offline
Joined: 2009-01-14
Posts:

There is no later edition available for update on this system. However, I've noticed that jack isn't running in real time. When I configure it to do so and hit run, it fails because i don't have permission to change the settings (getting annoying). Can anyone help me out?

Also, when running ardour or Hydrogen the sound will get really fuzzy sounding. is this related?

peder
User offline. Last seen 49 weeks 5 days ago. Offline
Joined: 2007-05-08
Posts:

Realtime won't lower your CPU utilization, but follow my post here: http://ardour.org/node/2037

tuttlecr
User offline. Last seen 4 years 48 weeks ago. Offline
Joined: 2009-01-14
Posts:

I've decided to just give up on Ubuntu. Things are just not working right. I installed Debian lenny last night and will be building pure:dyne off that. I'll start a new thread if I've got any issues that need to be resolved. Thanks for the help though. I've learned a bit from this.