Audio Units = Ardour2 Crash

No replies
axetota
axetota's picture
User offline. Last seen 38 weeks 18 hours ago. Offline
Joined: 2006-03-29
Posts:

Perhaps I have something misconfigured. This never fails and I am new to ardour on Mac OSX. Anyway, I can add AU plugins no problem, and they work great. But for some reason if I remove them from a track, ardour will crash every single time. Is this typical, or do I have something not set right. When I say Audio Units I am refering to the ones supplied by apple that came with my Mac Book.

I have the aggregate device setup and all of that. Cake.

Here is the Console Output:

5/14/09 6:51:18 PM [0x0-0x38038].org.ardour.Ardour2[2272] Loading session /Users/axetota/test using snapshot test (1)
5/14/09 6:51:24 PM [0x0-0x38038].org.ardour.Ardour2[2272] (Ardour2.bin:2272): Pango-WARNING **: Error loading GDEF table 0x6ead
5/14/09 6:51:24 PM [0x0-0x38038].org.ardour.Ardour2[2272] (Ardour2.bin:2272): Pango-WARNING **: Error loading GSUB table 0x6ead
5/14/09 6:51:24 PM [0x0-0x38038].org.ardour.Ardour2[2272] (Ardour2.bin:2272): Pango-WARNING **: Error loading GPOS table 0x6ead
5/14/09 6:51:26 PM [0x0-0x38038].org.ardour.Ardour2[2272] Loading history from '/Users/axetota/test/test.history'.
5/14/09 6:51:27 PM [0x0-0x38038].org.ardour.Ardour2[2272] (Ardour2.bin:2272): Pango-WARNING **: Error loading GDEF table 0x6ead
5/14/09 6:51:27 PM [0x0-0x38038].org.ardour.Ardour2[2272] (Ardour2.bin:2272): Pango-WARNING **: Error loading GSUB table 0x6ead
5/14/09 6:51:27 PM [0x0-0x38038].org.ardour.Ardour2[2272] (Ardour2.bin:2272): Pango-WARNING **: Error loading GPOS table 0x6ead
5/14/09 6:51:27 PM [0x0-0x38038].org.ardour.Ardour2[2272] (Ardour2.bin:2272): Pango-WARNING **: Error loading GDEF table 0x6ead
5/14/09 6:51:27 PM [0x0-0x38038].org.ardour.Ardour2[2272] (Ardour2.bin:2272): Pango-WARNING **: Error loading GSUB table 0x6ead
5/14/09 6:51:27 PM [0x0-0x38038].org.ardour.Ardour2[2272] (Ardour2.bin:2272): Pango-WARNING **: Error loading GPOS table 0x6ead
5/14/09 6:51:41 PM [0x0-0x38038].org.ardour.Ardour2[2272] (Ardour2.bin:2272): Pango-WARNING **: Error loading GDEF table 0x6ead
5/14/09 6:51:41 PM [0x0-0x38038].org.ardour.Ardour2[2272] (Ardour2.bin:2272): Pango-WARNING **: Error loading GSUB table 0x6ead
5/14/09 6:51:41 PM [0x0-0x38038].org.ardour.Ardour2[2272] (Ardour2.bin:2272): Pango-WARNING **: Error loading GPOS table 0x6ead
5/14/09 6:51:50 PM [0x0-0x38038].org.ardour.Ardour2[2272] AU plugin window shown
5/14/09 6:52:36 PM com.apple.launchd[64] ([0x0-0x38038].org.ardour.Ardour2[2272]) Exited abnormally: Bus error

Just wondering.... This happens when I choose 'cut' to remove the plugin. haven't tried 'clear' or 'delete' yet

Ardour 2.8 Binary Donationware.
OSX 10.5.6

Thanks Guys!

Mike

axetota
axetota's picture
User offline. Last seen 38 weeks 18 hours ago. Offline
Joined: 2006-03-29
Posts:

Ok I just confirmed that ardour does NOT crash when I choose 'delete' to remove the plugin. It only does this when I pick 'clear' or 'cut' to remove. Strange... I also checked the Pango Font thing. I remove .fontconfig from my home folder, this does not help...

Hopefully I'm not wasting anybody's time here by reporting something that is a 'Known BUg' I didn't see anything about this particular matter though. Then again, I'm a pro at overlooking things.

Thanks dudes!

axetota
axetota's picture
User offline. Last seen 38 weeks 18 hours ago. Offline
Joined: 2006-03-29
Posts:

Yet another correction.... ok so now ardour indeed crashes when I choose 'delete' to remove the plugin. sorry for all these successive posts

axetota
axetota's picture
User offline. Last seen 38 weeks 18 hours ago. Offline
Joined: 2006-03-29
Posts:

Solved (kind of):
Yet another one.... I think I spoke just a bit to soon this one. I took a second look at my aggregate device setup. The input was checked at 16bit and the output was at 24 bit. I changed them both to be the same and no more problems with AU plugins. Hopefully these posts will help someone in the future though.

I still get crashes though. If I open the gui for AU plugins and then try to remove them, ardour still crashes.

I have done the apple software updates prior to installing ardour as well. I'm really confused as to what is causing this issue now.

Sorry for wasting anybody's time.

-Mike

seablade
User offline. Last seen 5 hours 2 min ago. Offline
Joined: 2007-01-22
Posts:

The information about the bit-depth issues is very useful, thank you.

I believe the issue with crashes on AU removal has been fixed and wil likely be in 2.8.1 IIRC. But don't quote me on it;)

Seablade

axetota
axetota's picture
User offline. Last seen 38 weeks 18 hours ago. Offline
Joined: 2006-03-29
Posts:

excellent... only if building ardour from source code on OSX was as easy as it is in linux. Because then I'd just check out the SVN version.

Yeah, the bit depth thing seemed to help a little. Let me know if that works for you. I'm personally going to not remove plugins unless necessary and bypass them when needed. LADSPA works no problem.

seablade
User offline. Last seen 5 hours 2 min ago. Offline
Joined: 2007-01-22
Posts:

Yea building on OS X is not a walk in the park sorry.

Seablade