ardour crashing with segfault

5 replies [Last post]
musicmatt5
User offline. Last seen 13 weeks 3 days ago. Offline
Joined: 2009-05-19
Posts:

Ardour has crashed twice in about 30 minutes. I just installed AVlinux (debian) yesterday, (switched from ubuntu 9.04 for stability reasons) and it seemed to be working fine in AV then. these are the terminal logs;

the first time;
[ 4530.068212] ardour-2.8[12922]: segfault at 229 ip b6f8bd52 sp b012ac20 error 4 in libjack.so.0.0.28[b6f87000+f000]

the second time;
[ 3054.671323] ardour-2.8[30591]: segfault at 3f800000 ip b759a75c sp bfdf5d10 error 4 in libgtk-x11-2.0.so.0.1400.7[b7529000+398000]

another weird thing is that sometimes ardour will disconnect from jack, but jack will think it is still connected (ardour still shows up on the connections manager). then I have to restart jack to reconnect ardour.

am trying to get some sessions mixed, so any help would be greatly appreciated.

GMaq
GMaq's picture
User offline. Last seen 3 days 6 hours ago. Offline
Joined: 2007-12-11
Posts:

Hi,

Which AV Linux Kernel are you using? Also are you using the Ardour package that came with AV Linux or the optional ArdourVST Package?

paul
paul's picture
User offline. Last seen 1 day 57 min ago. Offline
Joined: 2006-03-16
Posts:

http://ardour.org/debugging_ardour

musicmatt5
User offline. Last seen 13 weeks 3 days ago. Offline
Joined: 2009-05-19
Posts:

sorry I posted somthing and then failed to check back for a while, got unexpectedly busy. anyway...

I am using the generic kernel from AV 2.0 (not the rt), and I am using the Ardour package that came with AV.

I will attempt to follow the advice from paul's link and provide more information and a backtrace. please be patient with me, I am new to Linux.

GMaq
GMaq's picture
User offline. Last seen 3 days 6 hours ago. Offline
Joined: 2007-12-11
Posts:

musicmatt5,

What hardware are you using Ardour with? I would strongly suggest you install and try the 2.6.29-rt1 Kernel and Headers from the "Audio Extras" folder in your home folder. I did a 3hr 8-track straight session tonight using AV Linux 2.0 with a band I'm rehearsing with, We recorded the entire rehearsal then afterward we listened back and did some mixing and later I exported a few tunes...The point is Ardour was up and running for about 5hrs and I didn't get so much as 1 xrun even running VSTs with FST as a separate host. The debugging data will be invaluable but in the meantime you may want to experiment with the -rt Kernel and see if the segfaults continue.

musicmatt5
User offline. Last seen 13 weeks 3 days ago. Offline
Joined: 2009-05-19
Posts:

Gmaq,
I finally managed to get the rt Kernel loaded. Due to a drive partition issue, it had not been showing up on my GRUB menu; In my initial post I had not figured out how to fix this problem, and was hoping for a way to get things functional in the meantime. The -rt kernel does seem to have stabilized the system. I mixed for a couple of hours yesterday and Wednesday, and nothing crashed. Thank you for your help, and for putting together what seems to be a pretty good Linux multimedia package. I will see if I can get the debugging data posted before to long.